Jump to content
Froxlor Forum
  • 0
robert de wojdom

Coustomer home default page not displayed

Question

Hello Froxlor-community,

For a few weeks I have been struggling with the problem: We can’t connect to the server at malybolek.org.
If anyone wants to help me thanks in advance
Here are some outings:

-------------------------------------------------------------------------------------

nano 000-default.conf

<VirtualHost *:80>
        ServerAdmin k2@k2.bleu7.com

        ServerName k2.bleu7.com
        ServerAlias k2.bleu7.tld *.k2.bleu7.tld
        ServerAdmin k2.k2.bleu7.com
        
        DocumentRoot /var/www/froxlor
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Allow from all
        Allow from 91.167.207.245/255.0.0.0 ::1/128
    </Directory>
        ErrorLog /var/log/apache2/error.log
        CustomLog /var/log/apache2/access.log combined

</VirtualHost>


-----------------------------------------------------------------------------

nano  35_froxlor_normal_vhost_malybolek.org.conf

<VirtualHost 192.168.0.25:80>
  ServerName malybolek.org
  ServerAlias *.malybolek.org
  ServerAdmin rob.w@hotmail.fr
  DocumentRoot "/var/customers/webs/bolek"
  FcgidIdleTimeout 30
  SuexecUserGroup "bolek" "bolek"
  <Directory "/var/customers/webs/bolek/">
    <FilesMatch "\.(php)$">
      SetHandler fcgid-script
      FcgidWrapper /var/www/php-fcgi-scripts/bolek/malybolek.org/php-fcgi-starter .php
      Options +ExecCGI
    </FilesMatch>
    Require all granted
    AllowOverride All
  </Directory>
  LogLevel warn
  ErrorLog "/var/customers/logs/bolek-error.log"
  CustomLog "/var/customers/logs/bolek-access.log" combined
</VirtualHost>


------------------------------------------------------------------------

php -v

PHP 7.3.14-1~deb10u1 (cli) (built: Feb 16 2020 15:07:23) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.14, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.14-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies

---------------------------------------------------------------------------------------

ps aux | grep php-fpm

root       609  0.0  0.3 235544 13928 ?        Ss   May31   0:06 php-fpm: master process (/etc/php/7.3/fpm/php-fpm.conf)
www-data   711  0.0  0.5 310248 22776 ?        S    May31   0:02 php-fpm: pool www
www-data   712  0.0  0.6 310392 25640 ?        S    May31   0:02 php-fpm: pool www
root     25819  0.0  0.0   3084   888 pts/1    S+   09:45   0:00 grep php-fpm

----------------------------------------------------------------------------------------

tail -30   /var/log/apache2/error.log

[Mon Jun 01 00:00:08.132553 2020] [mpm_event:notice] [pid 17198:tid 140084043842688] AH00489: Apache/2.4.38 (Debian) mod_fcgid/2.3.9 OpenSSL/1.1.1d configured -- resuming normal operations
[Mon Jun 01 00:00:08.132672 2020] [core:notice] [pid 17198:tid 140084043842688] AH00094: Command line: '/usr/sbin/apache2'

-----------------------------------------------------------------------------------------

/usr/sbin/apache2

httpd (pid 17198) already running

-----------------------------------------------------------------------------------------

/usr/sbin/apache2 -V

Server version: Apache/2.4.38 (Debian)
Server built:   2019-10-15T19:53:42
Server's Module Magic Number: 20120211:84
Server loaded:  APR 1.6.5, APR-UTIL 1.6.1
Compiled using: APR 1.6.5, APR-UTIL 1.6.1
Architecture:   64-bit
Server MPM:     event
  threaded:     yes (fixed thread count)
    forked:     yes (variable process count)
Server compiled with....
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=256
 -D HTTPD_ROOT="/etc/apache2"
 -D SUEXEC_BIN="/usr/lib/apache2/suexec"
 -D DEFAULT_PIDLOG="/var/run/apache2.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="mime.types"
 -D SERVER_CONFIG_FILE="apache2.conf"


------------------------------------------------------------------------

grep -E '^\s*listen\s*=\s*[a-zA-Z/]+' /etc/php/7.3/fpm/pool.d/www.conf

listen = /run/php/php7.3-fpm.sock

------------------------------------------------------------------------

cd /var/run

drwxr-xr-x  2 www-data          www-data   80 May 31 16:13 php

----------------------------------------------------------------------------

ps aux | grep httpd

root     25889  0.0  0.0   3084   888 pts/3    S+   09:57   0:00 grep httpd

----------------------------------------------------------------------------

ps aux | grep apache2

froxlor+  3248  0.1  1.5 462100 61544 ?        Sl   May31   1:08 /usr/bin/kate -b /home/froxlorlocal/Bureau/apache2
root     17198  0.0  0.1  15516  6436 ?        Ss   May31   0:03 /usr/sbin/apache2 -k start
www-data 20251  0.0  0.0  14872   384 ?        S    00:00   0:00 /usr/sbin/apache2 -k start
www-data 20252  0.0  0.3 1220376 13512 ?       Sl   00:00   0:00 /usr/sbin/apache2 -k start
www-data 20253  0.0  0.2 1220568 9092 ?        Sl   00:00   0:00 /usr/sbin/apache2 -k start
root     25893  0.0  0.0   3084   828 pts/1    S+   09:58   0:00 grep apache2

---------------------------------------------------------------------------

grep -r Listen /etc/apache2

/etc/apache2/ports.conf:Listen 80
/etc/apache2/ports.conf:        Listen 443
/etc/apache2/ports.conf:        Listen 443

-----------------------------------------------------------------------------

systemctl status php7.3-fpm

* php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2020-05-31 16:13:39 CEST; 17h ago
     Docs: man:php-fpm7.3(8)
 Main PID: 609 (php-fpm7.3)
   Status: "Processes active: 0, idle: 2, Requests: 272, slow: 0, Traffic: 0req/sec"
    Tasks: 3 (limit: 4567)
   Memory: 21.6M
   CGroup: /system.slice/php7.3-fpm.service
           |-609 php-fpm: master process (/etc/php/7.3/fpm/php-fpm.conf)
           |-711 php-fpm: pool www
           `-712 php-fpm: pool www


---------------------------------------------------------------------

apache2 -S

VirtualHost configuration:
[::1]:80               is a NameVirtualHost
         default server K2.bleu7.com (/etc/apache2/sites-enabled/10_froxlor_ipandport_1.80.conf:5)
         port 80 namevhost K2.bleu7.com (/etc/apache2/sites-enabled/10_froxlor_ipandport_1.80.conf:5)
         port 80 namevhost bolek.k2.bleu7.com (/etc/apache2/sites-enabled/28_froxlor_normal_vhost_bolek.k2.bleu7.com.conf:6)
                 wild alias *.bolek.k2.bleu7.com
         port 80 namevhost kasia.k2.bleu7.com (/etc/apache2/sites-enabled/28_froxlor_normal_vhost_kasia.k2.bleu7.com.conf:6)
                 wild alias *.kasia.k2.bleu7.com
         port 80 namevhost test.malakasia.com (/etc/apache2/sites-enabled/29_froxlor_normal_vhost_test.malakasia.com.conf:6)
                 wild alias *.test.malakasia.com
         port 80 namevhost malakasia.com (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_malakasia.com.conf:6)
                 wild alias *.malakasia.com
         port 80 namevhost malybolek.com (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_malybolek.com.conf:6)
                 wild alias *.malybolek.com
         port 80 namevhost malyolek.com (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_malyolek.com.conf:6)
                 wild alias *.malyolek.com
192.168.0.25:80        malybolek.org (/etc/apache2/sites-enabled/35_froxlor_normal_vhost_malybolek.org.conf:6)
*:80                   k2.bleu7.com (/etc/apache2/sites-enabled/000-default.conf:1)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex proxy: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex fcgid-pipe: using_defaults
Mutex watchdog-callback: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex fcgid-proctbl: using_defaults
Mutex ssl-stapling: using_defaults
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33
Group: name="www-data" id=33

 
Thank you in advance
 🙂

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
4 minutes ago, robert de wojdom said:

000-default.conf

irrelevant, not froxlor related config

4 minutes ago, robert de wojdom said:

<VirtualHost 192.168.0.25:80>

No external IP, plus malybolek.org does not resolv to any IP address at all

5 minutes ago, robert de wojdom said:

/etc/php/7.3/fpm/pool.d/www.conf

irrelevant, not froxlor related config, www.conf is not used in froxlor-managed vhosts/php-fpm pools

 

 

Share this post


Link to post
Share on other sites
  • 0
22 minutes ago, d00p said:

irrelevant, not froxlor related config

No external IP, plus malybolek.org does not resolv to any IP address at all

irrelevant, not froxlor related config, www.conf is not used in froxlor-managed vhosts/php-fpm pools

 

 

Thank you very much for the quick response dOOp.
I will see that and a thousand thanks for the superb hosts panel 😉

Share this post


Link to post
Share on other sites
  • 0

Hello everyone,

I think I have solved the problem:

<VirtualHost *:80  91.167.207.245   2a01:e0a:1f3:fd60:20dd:424e:565:bb1c>
     
       UseCanonicalName DNS
       VirtualScriptAliasIP  "/www/hosts/%0/cgi-bin"
    
       <FilesMatch "\.php$">
        # Note : la seule partie variable est /path/to/app.sock
        SetHandler  "proxy:unix:/var/www/froxlor.sock|fcgi://localhost/"
        </FilesMatch>
       .
        <Proxy "fcgi://localhost/" enablereuse=on max=10>
        </Proxy>
        #ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/froxlor/$1        
         
        <LocationMatch "/(ping|status)">
        #SetHandler "proxy:unix:/run/php/php7.0-fpm.sock|fcgi://localhost"
        SetHandler "proxy:fcgi://localhost:9000"
        Require ip 127.0.0.1 192.168.0.25 91.167.207.245
    </LocationMatch>
        ServerName www.k2.bleu7.com

        ServerAdmin k2@k2.bleu7.com
        DocumentRoot /var/www/froxlor
        
        <Directory />
                Options FollowSymLinks
                AllowOverride None
                Allow from all
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews ExecCGI
                AllowOverride None
                Order deny,allow
                allow from localhost
                allow from 127.0.0.1
                allow from 91.167.207.245
                deny from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        <FilesMatch "\.php$">
            SetHandler "proxy:fcgi://127.0.0.1:9000/"
        </FilesMatch>
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined   

        Include conf-available/serve-cgi-bin.conf
</VirtualHost>

---------------------------------------------------------------

<VirtualHost 91.167.207.245:80>
  ServerName malybolek.org
  ServerAlias *.malybolek.org
  ServerAdmin rob.w@hotmail.fr
  DocumentRoot "/var/customers/webs/bolek"
  FcgidIdleTimeout 30
  SuexecUserGroup "bolek" "bolek"
  <Directory "/var/customers/webs/bolek/">
    <FilesMatch "\.(php)$">
      SetHandler fcgid-script
      FcgidWrapper /var/www/php-fcgi-scripts/bolek/malybolek.org/php-fcgi-starter .php
      Options +ExecCGI
    </FilesMatch>
    Require all granted
    AllowOverride All
  </Directory>
  Alias /awstats "/var/customers/webs/bolek/awstats/malybolek.org"
  Alias /awstats-icon "/usr/share/awstats/icon/"

------------------------------------------------------------------------------------------

* php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2020-06-05 15:04:35 CEST; 1 day 8h ago
     Docs: man:php-fpm7.3(8)
 Main PID: 29849 (php-fpm7.3)
   Status: "Processes active: 0, idle: 4, Requests: 293, slow: 0, Traffic: 0req/sec"
    Tasks: 5 (limit: 4567)
   Memory: 19.4M
   CGroup: /system.slice/php7.3-fpm.service
           |-29849 php-fpm: master process (/etc/php/7.3/fpm/php-fpm.conf)
           |-29850 php-fpm: pool froxlor
           |-29851 php-fpm: pool froxlor
           |-29852 php-fpm: pool www
           `-29853 php-fpm: pool www


----------------------------------------------------------------------

ls -la /etc/php/7.3/fpm/pool.d

drwxr-xr-x 2 root root  4096 Jun  5 15:04 .
drwxr-xr-x 4 root root  4096 Jun  6 10:07 ..
-rw-r--r-- 1 root root 19753 Jun  5 15:04 froxlor.conf
-rw-r--r-- 1 root root 19623 Jun  3 21:46 www.conf

[froxlor]

user = froxlorlocal
group = froxlorlocal

listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1

------------------------------------------------------------------------

After order:    php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

root@k2:/etc/apache2/sites-enabled# /usr/sbin/apache2
[Sat Jun 06 23:27:05.571126 2020] [so:warn] [pid 26586:tid 140691258602624] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:27:05.571304 2020] [so:warn] [pid 26586:tid 140691258602624] AH01574: module proxy_fcgi_module is already loaded, skipping
(99)Cannot assign requested address: AH00072: make_sock: could not bind to address 91.167.207.245:443
no listening sockets available, shutting down
AH00015: Unable to open logs

THANK YOU IN ADVANCE FOR YOUR HELP

Share this post


Link to post
Share on other sites
  • 0

Custom vhosts, custom php-fpm pool configs...no idea what you expect.

Your Apache most likely won't start because there is no listen entry for ssl port 443 try "a2enmod ssl"

Share this post


Link to post
Share on other sites
  • 0

/usr/sbin/apache2
[Sat Jun 06 23:53:43.324118 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:53:43.324633 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_fcgi_module is already loaded, skipping
(99)Cannot assign requested address: AH00072: make_sock: could not bind to address 91.167.207.245:80
no listening sockets available, shutting down
AH00015: Unable to open logs

 

13 minutes ago, d00p said:

Custom vhosts, custom php-fpm pool configs...no idea what you expect.

Your Apache most likely won't start because there is no listen entry for ssl port 443 try "a2enmod ssl"

a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled


------------------------------------------------

rm -rf 10_froxlor_ipandport_91.167.207.245.443.conf

/usr/sbin/apache2
[Sat Jun 06 23:53:43.324118 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:53:43.324633 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_fcgi_module is already loaded, skipping
(99)Cannot assign requested address: AH00072: make_sock: could not bind to address 91.167.207.245:80
no listening sockets available, shutting down
AH00015: Unable to open logs

-------------------------------------------------

rm -rf 10_froxlor_ipandport_91.167.207.245.80.conf

/usr/sbin/apache2
[Sat Jun 06 23:55:12.439054 2020] [so:warn] [pid 26923:tid 140382180689024] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:55:12.439467 2020] [so:warn] [pid 26923:tid 140382180689024] AH01574: module proxy_fcgi_module is already loaded, skipping


----------------------------------------------

And each time i have to delate the file otherwise it won't start

 

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, robert de wojdom said:

/usr/sbin/apache2
[Sat Jun 06 23:53:43.324118 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:53:43.324633 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_fcgi_module is already loaded, skipping
(99)Cannot assign requested address: AH00072: make_sock: could not bind to address 91.167.207.245:80
no listening sockets available, shutting down
AH00015: Unable to open logs

 

a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled


------------------------------------------------

rm -rf 10_froxlor_ipandport_91.167.207.245.443.conf

/usr/sbin/apache2
[Sat Jun 06 23:53:43.324118 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:53:43.324633 2020] [so:warn] [pid 26902:tid 140518653408384] AH01574: module proxy_fcgi_module is already loaded, skipping
(99)Cannot assign requested address: AH00072: make_sock: could not bind to address 91.167.207.245:80
no listening sockets available, shutting down
AH00015: Unable to open logs

-------------------------------------------------

rm -rf 10_froxlor_ipandport_91.167.207.245.80.conf

/usr/sbin/apache2
[Sat Jun 06 23:55:12.439054 2020] [so:warn] [pid 26923:tid 140382180689024] AH01574: module proxy_module is already loaded, skipping
[Sat Jun 06 23:55:12.439467 2020] [so:warn] [pid 26923:tid 140382180689024] AH01574: module proxy_fcgi_module is already loaded, skipping


----------------------------------------------

And each time i have to delate the file otherwise it won't start

 

What can be problem, thx

 

Share this post


Link to post
Share on other sites
  • 0
55 minutes ago, robert de wojdom said:

What can be problem, thx

 

I found that:

Dad bedeutet das schon ein anderer Dienst auf diesen Port hört. Das passiert meistens wenn du via a2enmod ssl schon SSL aktiviert hast (und Apache damit unter Debian automatisch auf Port 443 hört)  und dann beim Anlegen der IP und des Ports in froxlor noch das Häkchen bei "Erstelle Listen Eintrag" gesetzt hast. Dann fügt froxlor ebenfalls ein "Listen" ein und Apache versucht zweimal zu binden. Eins von beiden musst du entfernen ;) Sinnvollerweise das Häkchen in froxlor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...