Jump to content
Froxlor Forum
  • 0
helpmehtaccess

htaccess - Erstmalige Startseite definieren

Question

Hallo Zusammen

 

Bin neu hier.

 

Ich bin neu am einarbeiten mit ".htaccess". und habe eine kleine Frage.

Ich habe im ".htaccess" folgende Zeile eingefügt "DirectoryIndex start.htm index.php".
Wenn ich jetzt meine myservice4you.ch/wp eingebe, wird start.htm aufgerufen. Klicke ich auf den Link welcher in der Datei start.htm angezeigt wird, wird die angegebene Datei nicht geöffnet. Mit "start.htm" möchte ich je nach bedarf ein Intro, Video, News Platzieren und erst dann die effektive Homepage angezeigt wird.

Ich möchte, dasnur beim Aufrufen von "myservice4you.ch/wp" die start.htm angezeigt wid, wird aber eine andere Datei zb. index.php oder so noch angegeben beim Link, so soll die Datei aufgerufen werden und nicht  die "start.htm" Datei.

 

So sieht meine ".htaccess" aus:
---
DirectoryIndex start.htm index.php
# BEGIN WPSuperCache
# Die Anweisungen (Zeilen) zwischen `BEGIN WPSuperCache` und `END WPSuperCache` sind
# dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
# Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
# END WPSuperCache
# BEGIN WordPress
# Die Anweisungen (Zeilen) zwischen `BEGIN WordPress` und `END WordPress` sind
# dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
# Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wp/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wp/index.php [L]
</IfModule>
# END WordPress
--

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Ich glaube was hier "stört" in das Rewrite von wordpress. Wenn ich deine Anweisungen bei mir so in eine .htaccess Eintrage funktioniert das wunderbar, ohne Angabe von Datei öffnet er die start.htm und wenn ich explizit index.php angebe öffnet er diese.

Warum aber löst du das denn nicht mit Wordpress selbst? Da kannst du doch auch zig Seiten anlegen und definieren welche die Startseite ist - wechselst du angenehm die gewünschte Startseite eben im Wordpress-Backend

Share this post


Link to post
Share on other sites
  • 0

Ich habe nun mal alles entfernt ausser der Zeile "DirectoryIndex start.htm index.php".

Die Start-seite wird immer noch korrekt angezeigt. Aber klicke ich dann auf den Link in der Start.htm Datei, geht die Seite nicht auf. Gebe ich am schluss noch index.php ein, geht die auch nicht auf.

 

Share this post


Link to post
Share on other sites
  • 0

index.php ist halt auch speziell, gerade bei wordpress (frontcontroller). mach doch mal eine "test.php" und schreib "<?php echo "Hello"; ?>" rein und schau ob du die aufrufen kannst

Share this post


Link to post
Share on other sites
  • 0

Ich habe mal ein Datei mit "hallo.php" erstellt und hineingeschrieben "<?php echo "Hello"; ?>".

Klicke ich nun auf den Link in der Datei "start.htm" wird die Hallo.php Datei geöffnet.

Wie kann ich das lösen, dass auch die Index.php von WordPress funktioniert, wenn man auf den Link im start.htm anklickt?

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, d00p said:

Warum aber löst du das denn nicht mit Wordpress selbst? Da kannst du doch auch zig Seiten anlegen und definieren welche die Startseite ist - wechselst du angenehm die gewünschte Startseite eben im Wordpress-Backend

Ich kann dir nicht genau sagen wieso es mit index.php nicht klappt, aber ich würde schätzen, weil die auch teil des "DirectoryIndex" ist vllt und er dann sieht: ah, start.htm steht als erstes in der liste, hab ich, geb ich aus - ist allerdings nur eine vermutung, könnte genauso gut am frontcontroller handlich von wordpress-selbst liegen - ich weiss es nicht. 

Share this post


Link to post
Share on other sites
  • 0

Ja natürlich, gib einfach NUR die start.htm als DirectoryIndex an. Aber achtung, apache definiert auch global schon index-Dateien die geprüft werden, daher musst du die Liste vorher resetten:

DirectoryIndex disabled
DirectoryIndex start.htm

Siehe dazu auch: https://httpd.apache.org/docs/2.4/mod/mod_dir.html#directoryindex

Share this post


Link to post
Share on other sites
  • 0

Auch mit diesen beiden Zeilen "DirectoryIndex disabled   ,   DirectoryIndex start.htm" in htaccess funktioiniert die Inex.php Datei von WordPress nicht.

Was muss im WP ev umgestellt werden? Den alle anderen Dateien können aufgerufen werden, nur die Index-Datei vom WP nicht.

 

Ich möchte eben die Start.htm verwenden 1stens um News, Aktionen, usw zu präsentieren für Personen, welche noch nie auf der Homepage waren. Zudem kann ich so auch meinen Counter darin verstecken.

Share this post


Link to post
Share on other sites
  • 0

Ich habe dir Möglichkeiten genannt, wie du es machen kannst. Ich würde es mit wordpress direkt lösen, aber willst du offenbar nicht. Von der Theorie her funktioniert die Technik aber, von daher kann ich nur davon ausgehen, dass es an Wordpress liegt und damit - so leid es mir tut - fällt es schlichtweg nicht mehr in den Support-Bereich von froxlor - ich kann dir da nicht helfen; frag ggfls bei Wordpress nach.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...