Jump to content
Froxlor Forum
  • 0

PHP-FPM Pfad-Eingabemethode Auswahlliste


Question

Hi d00p,

ich habe folgendes Problem:

Ubuntu Bionic mit Apache 2.4 und PHP-FPM. Alles funktioniert tadellos, mit einer Ausnahme:

In den Panel-Einstellungen habe ich die Pfad-Eingabemethode auf Auswahlliste gestellt.

Wenn ich mich nun mit einem User öffne und dort eine Domain bearbeiten möchte, bekomme ich folgende Fehlermeldung:

Zitat

AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught UnexpectedValueException: RecursiveDirectoryIterator::__construct(/var/customers/webs/draeger/): failed to open dir: Permission denied in /var/www/froxlor/lib/Froxlor/FileDir.php:497
Stack trace:
#0 /var/www/froxlor/lib/Froxlor/FileDir.php(497): RecursiveDirectoryIterator->__construct('/var/customers/...', 4096)
#1 /var/www/froxlor/lib/Froxlor/FileDir.php(407): Froxlor\\FileDir::findDirs('/var/customers/...', '10000', '10000')
#2 /var/www/froxlor/customer_ftp.php(203): Froxlor\\FileDir::makePathfield('/var/customers/...', '10000', '10000', '/example.com...')
#3 {main}
thrown in /var/www/froxlor/lib/Froxlor/FileDir.php on line 497
', referer: https://froxlor.example.com/index.php?s=2c6b4bccbbc21d4569cc024f337b7474&script=customer_ftp.php&qrystr=s%3D2c6b4bccbbc21d4569cc024f337b7474%26page%3Daccounts%26action%3Dedit%26id%3D2

Offensichtlich kann froxlorlocal nicht in dem Verzeichnis des Users lesen.

Wenn ich

id customer

ausführe, erhalte ich folgende Rückmeldung:

uid=10000(customer) gid=10000(customer) groups=10000(customer)

Wahrscheinlich auch noch relevant:

id www-data
uid=33(www-data) gid=33(www-data) groups=9999(froxlorlocal),10000(customer),33(www-data)
id froxlorlocal
uid=9999(froxlorlocal) gid=9999(froxlorlocal) groups=9999(froxlorlocal)

Ist das jetzt noch ein Fehler meiner Konfiguration, oder tatsächlich ein Fehler von Froxlor?

 

Danke für die Rückmeldung.

Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

froxlorlocal sollte als gruppen auch die kunden beinhalten, das erldigt froxlor eigentlich, denn er trägt den hinterlegten lokalen benutzer von froxlor bei den ftp-users (accounts) in die gruppe mit ein, ergo dürfte er dann auf das webdir zugreifen

Link to post
Share on other sites
  • 0

ich habe die gruppe und den user froxlorlocal selbst angelegt. sollte ich das lieber durch den cronjob erledigen lassen? Dann würde ich jetzt php-fpm noch mal stoppen, gruppe und user froxlorlocal löschen und den cronjob laufen lassen?!

Link to post
Share on other sites
  • 0

Hast du denn den user auch in Einstellungen -> Froxlor VirtualHost settings -> Local user to use for PHP-FPM (Froxlor vHost) angegeben? Normal sollte der cronjob den user zu der entsprechenden Gruppe hinzufügen, ich werde nachher mal prüfen ob er das auch tatsächlich (auch für existierende user) macht

Link to post
Share on other sites
  • 0

Dann schau doch Mal ob in der Tabelle ftp_groups ob dein froxlorlocal User da in der Liste der members mit drinsteht

Link to post
Share on other sites
  • 0

Nutzt du libnss-extrausers? Prüfe ob die Einträge in den Dateien unter /var/lib/extrausers/ Korrekt sind. Denn irgendwo her muss es ja kommen das "id [customer]" nicht die froxlorlocal Gruppe anzeigt

Link to post
Share on other sites
  • 0

Ja, nutze ich. Und habe es auch entsprechend der Konfigurationsanleitung konfiguriert.

Müsste da schon der User/die Gruppe froxlorlocal drin sein?

cat /var/lib/extrausers/group
customer:x:10000:customer,www-data,customerftp1
cat /var/lib/extrausers/passwd
customer:x:10000:10000:Customer:/var/customers/webs/customer/:/bin/false
customerftp1:x:10000:10000:Customer:/var/customers/webs/customer/example.com/:/bin/bash
Link to post
Share on other sites
  • 0

Joa, froxlorlocal steht nicht mit drin. Wurde vom erst später aktiviert? Das ich da ggfls. Den Ursprung eines möglichen Fehlers eingrenzen kann

Link to post
Share on other sites
  • 0

Das kann weniger sein, funktioniert bei mir seit jahr und tag, Vorallem wenn du sagst der froxlorlocal User steht in der Datenbank - wieso sollte er sie dann nicht mit in die extrausers Datei übernehmen? Froxlor schreibt ja da alles rein was in der Tabelle steht. Forciere doch bitte Mal den cronjob manuell mit --force --debug Parameter und schau dir die extrausers Dateien dann noch Mal an

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...