Jump to content
Froxlor Forum
  • 0

/usr/bin/XYZ mit exec ausführen (Open Basedir)


Afox
 Share

Question

Hallo,

ich möchte ein Programm /usr/bin/XYZ mittels exec-Funktion bei aktivierter OpenBasedir ausführen lassen.

Ist das möglich? Wenn ja, wo kann ich eine OpenBasedir-Ausnahme für das genannte Programm erstellen?

 

Zusatzfrage: Ist es möglich die exec-Funktion auf das genannte Programm zu beschränken?

 

Ich habe allgemein die exec Funktion aus den disable_functions herausgenommen. Eventuell geht das aber noch etwas sicherer indem man genau sagt was ausgeführt werden darf?

 

Danke und Gruß,

 

Afox

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

danke, also ich habe jetzt versucht den OpenBasedir Wert in der PHP Konfiguration (Default Config) wie folgt zu notieren:

Quote

{OPEN_BASEDIR_C}open_basedir = "{OPEN_BASEDIR}:/usr/bin/"

Das funktioniert aber leider nicht. In der php_admin_value ist open_basedir vermerkt. Muss ich das dann bei der PHP-FPM Version eintragen oder gar global in den Webserver-Einstellungen? Eventuell habe ich auch einen Typo oder Ähnliches drin.

Link to comment
Share on other sites

  • 0

Mach doch einfach ein phpinfo() bei der betreffenden Domain und schau dir den openbasedir wert an. Wird denn der Wert wie du ihn haben willst auch korrekt in die Pool config übertragen? Ggfls ist das ausführen von /usr/bin/XYZ für den User (Kunden Benutzer) auch nicht erlaubt. Eine aktuelle Fehlermeldung wäre hier hilfreich

Link to comment
Share on other sites

  • 0

Wird leider nicht übertragen wenn ich es in der Default Config ändere. Fehler gibt es leider keine außer das was das PHP-Programm sagt im Sinne von "Kann nicht auf /usr/bin/XYZ zugreifen".

Hatte vergessen zu erwähnen dass das was ich ausführen möchte ausgeführt wird sobald ich OpenBasedir für die betroffene Domain deaktiviere.

Link to comment
Share on other sites

  • 0
7 hours ago, Afox said:

Wird leider nicht übertragen wenn ich es in der Default Config ändere.

Ja dann steckt da wohl irgendwo der fehler, bei mir wird das problemlos übernommen, mit genau dieser Zeile in den php-ini settings

{OPEN_BASEDIR_C}open_basedir = "{OPEN_BASEDIR}:/usr/bin"

 

Link to comment
Share on other sites

  • 0

Also wenn ich im pool.d Ordner die configs anschaue dann ist es dort in der letzten Zeile vermerkt

php_admin_value[open_basedir] = "(...):/tmp:/usr/bin"

aber es taucht nicht in der phpinfo() auf.

Link to comment
Share on other sites

  • 0

Ich sehe auch gerade dass php_admin_value[open_basedir] zweimal auftaucht.  Einmal etwas weiter vorne und einmal ganz am Ende. Der Wert weiter vorne stimmt mit dem Ergebnis der phpinfo() überein.

Link to comment
Share on other sites

  • 0

...ja darauf bezog sich auch meine antwort....du sagst es taucht 2x in der generierten pool config auf, also schau doch bitte nach den daten woraus die erstellt werden, also deiner php-configuration im froxlor interface

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...