Jump to content
Froxlor Forum
  • 0

Cron "please add '--ecc' parameter if you want to use that cert."


Question

Hi,

mir ist gestern als ich eine neue Domain angelegt habe aufgefallen das der Cron immer wieder los läuft, wenn ich diesen als debug anstoße bekomme ich für jede Domain folgende Meldung:

[information] Updating certificate for anzah.co
[information] Adding SAN entry: anzah.co
[information] Adding SAN entry: www.anzah.co
[Tue 24 Mar 2020 05:52:01 AM CET] Lets find script dir.
[Tue 24 Mar 2020 05:52:01 AM CET] _SCRIPT_='/root/.acme.sh/acme.sh'
[Tue 24 Mar 2020 05:52:01 AM CET] _script='/root/.acme.sh/acme.sh'
[Tue 24 Mar 2020 05:52:01 AM CET] _script_home='/root/.acme.sh'
[Tue 24 Mar 2020 05:52:01 AM CET] Using default home:/root/.acme.sh
[Tue 24 Mar 2020 05:52:01 AM CET] Using config home:/root/.acme.sh
[Tue 24 Mar 2020 05:52:01 AM CET] Using server: https://acme-v02.api.letsencrypt.org/directory
[Tue 24 Mar 2020 05:52:01 AM CET] Running cmd: renew
[Tue 24 Mar 2020 05:52:01 AM CET] Using config home:/root/.acme.sh
[Tue 24 Mar 2020 05:52:01 AM CET] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Tue 24 Mar 2020 05:52:01 AM CET] DOMAIN_PATH='/root/.acme.sh/anzah.co'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Tue 24 Mar 2020 05:52:01 AM CET] The domain 'anzah.co' seems to have a ECC cert already, please add '--ecc' parameter if you want to use that cert.
[Tue 24 Mar 2020 05:52:01 AM CET] Renew: 'anzah.co'
[Tue 24 Mar 2020 05:52:01 AM CET] 'anzah.co' is not a issued domain, skip.
[information] Updated Let's Encrypt certificate for anzah.co

Einstellung:

image.thumb.png.1c8ce8106cdf23e1df456ba2334fd328.png

Kann es sein das das den loop verursacht?

Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

Einfach Mal /root/.acme.sh/anzah.co_ecc löschen und evtl vorhandenen Zertifikate in froxlor, dann sollte es wieder gehen

Link to post
Share on other sites
  • 0

Also wieder mal alle Zertifikate entfernen? Wie hier beschrieben?

 

Woher kommt das denn? Ich habe ja extra schon einmal alle Zertifikate entfernt um auf ecc umzustellen.

 

 

Gibts dafür einen Command oder muss ich das dann wirklich für jede Domain einzeln machen? Weil 60 mal "root/.acme.sh/acme.sh remove [domain] -ecc" eintippen ist weniger spaßig.

Link to post
Share on other sites
  • 0

Ach du hast das auch noch bei allen Domains? Also k.a. was du da fummelst, ich hab auf keiner meiner Server solche Probleme, egal ob ECC oder nicht. Aber wenn du natürlich ständig Einstellungen änderst die sich auf die Zertifikaterstellung Auswirken würde es mich nicht wundern wenn es halt hin und wieder knallt 

Link to post
Share on other sites
  • 0

was heißt ständig, ein mal als ich den obigen Fehler hatte. Ich mache eigentlich sehr wenig an dem Server außer mal eine neue Domain anlegen, ansonsten läuft der vor sich hin und bekommt halt Updates.

Für spielerreien hab ich extra andere Server. Daher wundert es mich ja.

Ganz nach dem Motto: Never change a running system

Link to post
Share on other sites
  • 0

Geht auch nicht immer nur um einen Server, darf/muss auch ein paar andere Verwalten, aber deswegen spiel ich darauf nicht rum...

Aber irgendwann zwischen 4 März und jetzt muss der Fehler aufgetaucht sein und da hab ich außer updates nichts gemacht.

Link to post
Share on other sites
  • 0
2 hours ago, Tealk said:

mir ist gestern als ich eine neue Domain angelegt habe aufgefallen das der Cron immer wieder los läuft, wenn ich diesen als debug anstoße bekomme ich für jede Domain folgende Meldung:


[information] Updating certificate for anzah.co

Also sorry, aber das kann ich halt nicht nachvollziehen und noch weniger reproduzieren. Du fügst eine Domain hinzu und alle anderen renewen sich auch einmal? Ne sorry

Link to post
Share on other sites
  • 0

das hab ich nicht gesagt, mir ist das mit dem cron nur aufgefallen weil ich eben eine Domain hinzugefügt habe. Sonst schaue ich ja nicht jeden Tag in Froxlor.

Link to post
Share on other sites
  • 0

Natürlich hast du das gesagt:

2 hours ago, Tealk said:

mir ist gestern als ich eine neue Domain angelegt habe aufgefallen das der Cron immer wieder los läuft, wenn ich diesen als debug anstoße bekomme ich für jede Domain folgende Meldung:

1) "eine neue Domain angelegt"
2) "bekomme ich für jede Domain folgende Meldung"

Also wenn mach bitte korrekte Aussagen, so kann ich nicht helfen, das dreht sich im Kreis

Link to post
Share on other sites
  • 0

ok dann so:

Ich habe eine neue Domain angelegt, da warte ich dann eig. immer die 2-3 Crons ab bis die Fertig ist wegen Zertifikat und Configs anlegen etc.

Da ist mir augefallen das der Cron, obwohl das schon alles Fertig war, immer wieder von neuem anläuft, unabhängig jetzt von der angelegten Domain.

Mir ist das nicht früher aufgefallen da ich nicht ständig Froxlor überwache.

Link to post
Share on other sites
  • 0

Also liegt es doch nur an 1 oder 2 bestimmten domains? Dann einfach wie gesagt, das Zertifikat mal löschen und dann rennt das wieder

Link to post
Share on other sites
  • 0

Und die sind nachweislich tatsächlich alle für ein renew dran? Also mind. 30 Tage bis zum Ablauf oder weniger?

Link to post
Share on other sites
  • 0

Also wenn wir uns jetzt mal das Beispiel anzah.co ansehen, wäre das so weit ja. Also alle Zertifikate die ich mal neu gemacht habe laufen quasi aus.

image.thumb.png.849441d3d0ebe81f17f1a96e4c1c0e76.png

So wie ich die Meldung lese fehlt ja nur ein Schalter in dem Kommando der übergeben wird?

Link to post
Share on other sites
  • 0

nein, die ssl Einstellungen sind seit langem gleich geblieben, jedenfalls bei den Zertifikaten. Das letzte was ich dort gemacht habe war TLS 1.3 zu aktivieren.

Link to post
Share on other sites
  • 0

wenn ich das einfach aus sitze? Oder laufe ich dann in das Problem das das Zertifikat ausläuft?

In /root/.acme.sh gibt es auch nur zert ordner mit _ecc Endung. Also gemischt ist es auch nicht.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...