Jump to content
Froxlor Forum
  • 0
CZPortal4Gamers

SSL for Froxlor panel

Question

19 answers to this question

Recommended Posts

  • 0

If SSL and let's encrypt is activated globally and have a SSL enabled up/port you can activate let's encrypt for the froxlor vhost in "settings" => "froxlor vhost settings"

Share this post


Link to post
Share on other sites
  • 0

[Sat 14 Mar 2020 07:56:48 PM UTC] Creating domain key
[Sat 14 Mar 2020 07:56:50 PM UTC] The domain key is here: /root/.acme.sh/panel.p                                                                                                                               4g.cz/panel.p4g.cz.key
[Sat 14 Mar 2020 07:56:50 PM UTC] Single domain='panel.p4g.cz'
[Sat 14 Mar 2020 07:56:50 PM UTC] Getting domain auth token for each domain
[Sat 14 Mar 2020 07:56:53 PM UTC] Getting webroot for domain='panel.p4g.cz'
[Sat 14 Mar 2020 07:56:53 PM UTC] Verifying: panel.p4g.cz
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL was not found on this server.</p>
<hr>
<address>Apache/2.4.38 (Debian) Server at panel.p4g.cz Port 80</address>
</body></html>

Share this post


Link to post
Share on other sites
  • 0

[Sat 14 Mar 2020 08:06:52 PM UTC] Creating domain key
[Sat 14 Mar 2020 08:06:53 PM UTC] The domain key is here: /root/.acme.sh/panel.p                                                                                                                               4g.cz/panel.p4g.cz.key
[Sat 14 Mar 2020 08:06:53 PM UTC] Single domain='panel.p4g.cz'
[Sat 14 Mar 2020 08:06:53 PM UTC] Getting domain auth token for each domain
[error] Could not get Let's Encrypt certificate for panel.p4g.cz:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Sat 14 Mar 2020 08:06:52 PM UTC] Creating domain key
[Sat 14 Mar 2020 08:06:53 PM UTC] The domain key is here: /root/.acme.sh/panel.p                                                                                                                               4g.cz/panel.p4g.cz.key
[Sat 14 Mar 2020 08:06:53 PM UTC] Single domain='panel.p4g.cz'
[Sat 14 Mar 2020 08:06:53 PM UTC] Getting domain auth token for each domain
[information] No new certificates or certificates due for renewal found
[information] apache::createIpPort: creating ip/port settings for  89.203.250.53                                                                                                                               :80
[notice] 89.203.250.53:80 :: namevirtualhost-statement no longer needed for apac                                                                                                                               he-2.4
[debug] 89.203.250.53:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  89.203.250.53                                                                                                                               :443
[debug] System certificate file "/etc/apache2/apache2.pem" does not seem to exis                                                                                                                               t. Disabling SSL-vhost for "panel.p4g.cz"
[error] panel.p4g.cz :: empty certificate file! Cannot create ssl-directives
[debug] 89.203.250.53:443 :: inserted vhostcontainer
[information] apache::createVirtualHosts: creating vhost container for domain 3,                                                                                                                                customer n00b
[information] apache::createVirtualHosts: creating vhost container for domain 2,                                                                                                                                customer frox
[information] apache::createVirtualHosts: creating vhost container for domain 1,                                                                                                                                customer n00b
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\Apache::reload: reloading Froxlor\Cron\Http\Apac                                                                                                                               he
[notice] Checking system's last guid
 

Share this post


Link to post
Share on other sites
  • 0

Seems like you did not configured the Webserver according to the configuration templates after activating SSL/let's encrypt, a 404 when verifying indicates you are missing the acme-alias config

Share this post


Link to post
Share on other sites
  • 0

Yeah, i had. but i already fixed that. But  there is still some problem with generating certificate or something

 

[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Sat 14 Mar 2020 08:19:05 PM UTC] Creating domain key
[Sat 14 Mar 2020 08:19:06 PM UTC] The domain key is here: /root/.acme.sh/panel.p                                                                                                                               4g.cz/panel.p4g.cz.key
[Sat 14 Mar 2020 08:19:06 PM UTC] Single domain='panel.p4g.cz'
[Sat 14 Mar 2020 08:19:06 PM UTC] Getting domain auth token for each domain
[error] Could not get Let's Encrypt certificate for panel.p4g.cz:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Sat 14 Mar 2020 08:19:05 PM UTC] Creating domain key
[Sat 14 Mar 2020 08:19:06 PM UTC] The domain key is here: /root/.acme.sh/panel.p                                                                                                                               4g.cz/panel.p4g.cz.key
[Sat 14 Mar 2020 08:19:06 PM UTC] Single domain='panel.p4g.cz'
[Sat 14 Mar 2020 08:19:06 PM UTC] Getting domain auth token for each domain
[information] No new certificates or certificates due for renewal found
[information] apache::createIpPort: creating ip/port settings for  89.203.250.53                                                                                                                               :80
[notice] 89.203.250.53:80 :: namevirtualhost-statement no longer needed for apac                                                                                                                               he-2.4
[debug] 89.203.250.53:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  89.203.250.53                                                                                                                               :443
[debug] System certificate file "/etc/apache2/apache2.pem" does not seem to exis                                                                                                                               t. Disabling SSL-vhost for "panel.p4g.cz"
[error] panel.p4g.cz :: empty certificate file! Cannot create ssl-directives
[debug] 89.203.250.53:443 :: inserted vhostcontainer
[information] apache::createVirtualHosts: creating vhost container for domain 3,                                                                                                                                customer n00b
[information] apache::createVirtualHosts: creating vhost container for domain 2,                                                                                                                                customer frox
[information] apache::createVirtualHosts: creating vhost container for domain 1,                                                                                                                                customer n00b
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\Apache::reload: reloading Froxlor\Cron\Http\Apac                                                                                                                               he
[notice] Checking system's last guid
 

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, CZPortal4Gamers said:

[debug] System certificate file "/etc/apache2/apache2.pem" does not seem to exist

The system wide fallback does not exist. Create a selfsigned certificate for that

Share this post


Link to post
Share on other sites
  • 0

Yeah, seems to be working now. Thank you very much for your help :) I have last question. How to do DNS for "customer" domain, if i do have only one ip adress. Is there option for port forwarding or something?

Share this post


Link to post
Share on other sites
  • 0

An ip address can be used by many domains....

Share this post


Link to post
Share on other sites
  • 0

What do you mean how? You set the A record for every domain to the servers ip...this is basic knowledge you should have when administrating a server. 

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, CZPortal4Gamers said:

So i should have only  ip with 2 ports for non ssl, ssl and thats should be fine for multiple domains?

Yes

3 minutes ago, CZPortal4Gamers said:

Because i still dont know if one domain needs their ports or there is better way. Idk how to redirect that domain to right path otherwise without port

I don't even know what you mean here. There is nothing like "one port for each domain". Your Webserver responses on port 80 for non-ssl and on port 443 for SSL connections

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...