Jump to content
Froxlor Forum
  • 0

Einige LE Zertifikate fehlen nach Update


xep22
 Share

Question

ich habe folgendes Problem, ich habe gerade froxlor upgedatet. danach waren bei Konfiguration -> SSL Zertifikate keine Zertifikate mehr gelistet. sie sind aber noch in /etc/ssl/froxlor/. daher habe ich einfach mal den froxlor-Cronjob laufen lassen :

/usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Nacheinander kamen dann die zertifikate wieder, in der Konsole waren teils aber auch fehlermeldungen.  für eine Domain und eine Subdomain fehlen die Zertifikate jetzt aber noch, ich habe die Haken für SSL in den Domain-Einstellungen rausgenommen und wieder rein gemacht,bei einer Domain half das und das Zert. wurde generiert, bei der letzten geht das jetzt aber nicht... folgender Fehler kommt bei der Domain wenn ich den froxlor-Cronjob neu ausführe :

root@root:/var/www# /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
[error] Could not get Let's Encrypt certificate for EXAMPLE.de:
[Fr 6. Mär 11:09:31 CET 2020] Domains not changed.
[Fr 6. Mär 11:09:31 CET 2020] Skip, Next renewal time is: Di 5. Mai 10:01:16 UTC 2020
[Fr 6. Mär 11:09:31 CET 2020] Add '--force' to force to renew.
root@root:/var/www# /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
[error] Could not get Let's Encrypt certificate for EXAMPLE.de:
[Fr 6. Mär 11:11:01 CET 2020] Domains not changed.
[Fr 6. Mär 11:11:01 CET 2020] Skip, Next renewal time is: Di 5. Mai 10:01:16 UTC 2020
[Fr 6. Mär 11:11:01 CET 2020] Add '--force' to force to renew.

wo soll ich denn das --force anhängen ? Kann jemand helfen ? Debug ausgabe:

Spoiler

root@root:/var/www# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug
[information] Requesting/renewing Let's Encrypt certificates
[information] Creating certificate for EXAMPLE.de
[information] Adding SAN entry: EXAMPLE.de
[information] Adding SAN entry: www.EXAMPLE.de
[information] Checking for LetsEncrypt client upgrades before renewing certificates:
[Fr 6. Mär 11:28:44 CET 2020] Already uptodate!
[Fr 6. Mär 11:28:44 CET 2020] Upgrade success!
[Fr 6. Mär 11:28:44 CET 2020] Removing cron job
[Fr 6. Mär 11:28:44 CET 2020] Lets find script dir.
[Fr 6. Mär 11:28:44 CET 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Fr 6. Mär 11:28:44 CET 2020] _script='/root/.acme.sh/acme.sh'
[Fr 6. Mär 11:28:44 CET 2020] _script_home='/root/.acme.sh'
[Fr 6. Mär 11:28:44 CET 2020] Using default home:/root/.acme.sh
[Fr 6. Mär 11:28:44 CET 2020] Using config home:/root/.acme.sh
[Fr 6. Mär 11:28:44 CET 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Fr 6. Mär 11:28:44 CET 2020] Running cmd: issue
[Fr 6. Mär 11:28:44 CET 2020] _main_domain='EXAMPLE.de'
[Fr 6. Mär 11:28:44 CET 2020] _alt_domains='www.EXAMPLE.de'
[Fr 6. Mär 11:28:44 CET 2020] Using config home:/root/.acme.sh
[Fr 6. Mär 11:28:44 CET 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Fr 6. Mär 11:28:44 CET 2020] DOMAIN_PATH='/root/.acme.sh/EXAMPLE.de'
[Fr 6. Mär 11:28:44 CET 2020] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory
[Fr 6. Mär 11:28:44 CET 2020] _init api for server: https://acme-v02.api.letsencrypt.org/directory
[Fr 6. Mär 11:28:44 CET 2020] GET
[Fr 6. Mär 11:28:44 CET 2020] url='https://acme-v02.api.letsencrypt.org/directory'
[Fr 6. Mär 11:28:44 CET 2020] timeout=
[Fr 6. Mär 11:28:44 CET 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header  -g '
[Fr 6. Mär 11:28:44 CET 2020] ret='0'
[Fr 6. Mär 11:28:45 CET 2020] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change'
[Fr 6. Mär 11:28:45 CET 2020] ACME_NEW_AUTHZ
[Fr 6. Mär 11:28:45 CET 2020] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order'
[Fr 6. Mär 11:28:45 CET 2020] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct'
[Fr 6. Mär 11:28:45 CET 2020] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert'
[Fr 6. Mär 11:28:45 CET 2020] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf'
[Fr 6. Mär 11:28:45 CET 2020] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce'
[Fr 6. Mär 11:28:45 CET 2020] ACME_VERSION='2'
[Fr 6. Mär 11:28:45 CET 2020] Le_NextRenewTime='1588586476'
[Fr 6. Mär 11:28:45 CET 2020] _saved_domain='EXAMPLE.de'
[Fr 6. Mär 11:28:45 CET 2020] _saved_alt='www.EXAMPLE.de'
[debug] https://github.com/acmesh-official/acme.sh
v2.8.6
[Fr 6. Mär 11:28:45 CET 2020] Domains not changed.
[Fr 6. Mär 11:28:45 CET 2020] Skip, Next renewal time is: Di 5. Mai 10:01:16 UTC 2020
[Fr 6. Mär 11:28:45 CET 2020] Add '--force' to force to renew.
[error] Could not get Let's Encrypt certificate for EXAMPLE.de:
https://github.com/acmesh-official/acme.sh
v2.8.6
[Fr 6. Mär 11:28:45 CET 2020] Domains not changed.
[Fr 6. Mär 11:28:45 CET 2020] Skip, Next renewal time is: Di 5. Mai 10:01:16 UTC 2020
[Fr 6. Mär 11:28:45 CET 2020] Add '--force' to force to renew.
[information] No new certificates or certificates due for renewal found
[notice] Checking system's last guid
 

 

Link to comment
Share on other sites

Recommended Posts

  • 0
6 minutes ago, xep22 said:

was mir noch auffällt, das ist die einzige Domain die ich teilweise mit Großbuchstaben eingetragen habe in froxlor... ob es daran liegt??

Das sagst du jetzt...ja das liegt daran, eigentlich sollte der code das alles konvertieren...das war ein bekanntes problem von acme.sh

Link to comment
Share on other sites

  • 0

@d00pAber noch eine Frage, seit dem großen Update erhalte ich nach dem Root-Login per putty diese Zeile angezeigt von acme:

. /root/.acme.sh/acme.sh.env
root@root:~#

wieso ? kann man das deaktivieren?

Edit: gefunden, wurde in die .profile eingetragen...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...