Jump to content
Froxlor Forum
  • 0
Heiner Sietas

Invalid command 'SSLSessionTickets' nach Froxlor Update

Question

Hilfe!

Nachdem ich froxlor von einer 0.9.x Version auf 0.10.13-1 (und PHP 5.6 auf 7.4.2) aktualisiert habe , kommt Apache2 mit den  *froxlor*.conf in site-enabled nicht mehr zurecht.

Apache2 ist 2.4.10-10+deb8u16.

Beim restart vom Apache wird "Invalid command 'SSLSessionTickets'" ausgegeben. Das wird wohl nur bei Apache2 <2.4.11 unterstützt.

Nun kann man wohl in Einstellungen-SSL TLS_Sessiontickets ausschalten, bei mir ist das Feld aber ausgegraut und ich kann den Standard Wert True nicht ändern.

Wie bekomme ich für meinen Apache wieder brauchbare conf Dateien ohne auf SSL (Let's Encrypt) zu verzichten.

Derzeit sind die ganzen Sites dadurch nicht erreichbar, drängt also zeitlich etwas und ich würde mich riesig über ein Lösung freuen.

Gruß,

Heiner

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Ich sehe das Problem, ich schränke die Sichtbarkeit zu sehr ein, du hast vermutlich für den froxlor-vhost (IPs und Ports Einstellungen) die Option "Erstelle vHost-Container" nicht aktiviert, das sollte natürlich für diese Einstellung kein Requirement sein, das ist korrekt, werde ich in der nächsten Version ändern. Wenn du jetzt den vHost-Container auch nicht aktivieren willst, führe folgendes in der Froxlor-Datenbank aus:

UPDATE `panel_settings` SET `value`='0' WHERE `varname` = 'sessionticketsenabled';

Ein anschließender manueller start des Cronjobs sollte die webserver-configs korrigieren:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

 

Share this post


Link to post
Share on other sites
  • 0

Super!

Danke für die schnelle Lösung, hat geklappt.

Habe jetzt auch gesehen, dass bei jeder Domain die Einstellung nicht ausgegraut in der individuellen SSL Einstellung existiert. Hier muss man aber wohl erst SSL komplett deaktivieren um tatsächlich auch die sessiontickets loszuwerden.

Gruß,

Heiner

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Heiner Sietas said:

Hier muss man aber wohl erst SSL komplett deaktivieren um tatsächlich auch die sessiontickets loszuwerden.

Nicht das ich wüsste...Wenn es global in den Einstellungen deaktiviert ist, erstellt er auch keine SSLSessionTickets Direktive. Du meinst wohl eher rein "optisch" loswerden

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...