Jump to content
Froxlor Forum
  • 0
Anachon

Verzeichnisschutz awstats Ordner

Question

Hallo,

wenn ich in Froxlor für die Statistik (awstats) einen Verzeichnisschutz in Froxlor anlege wird der ignoriert.

Gibt es da eine Idee?

LG V.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
20 minutes ago, Anachon said:

40_ exisitieren nicht.

sollte es aber, denn dort stehen die verzeichnisschutz-sachen drin.  Schau mal nach, was in den Webserver-Einstellungen unter "Webserver diroptions configuration file/dirname" steht, ich schätze mal ein falsches Verzeichnis, default wäre für apache hier "/etc/apache2/sites-enabled/" genau wie die vhosts

Share this post


Link to post
Share on other sites
  • 0

Froxlor legt doch standardmäßig für den verwendeten Statistik-Ordner einen Verzeichnis-Schutz an. Den solltest du als Kunden auch im Menüpunkt "Verzeichnisschutz" sehen. Und bitte poste etwas mehr Infos und Details, einfach nur "geht nicht" ist nicht sehr hilfreich bei der Fehlersuche.

- welcher webserver?

- wie sieht der vhost der betroffenen domain aus?

- werden die configs korrekt und am korrekten ort erstellt?

- etc-etc-etc

Share this post


Link to post
Share on other sites
  • 0

Hallo d00p,

in Froxlor erscheint für awstats auch der Eintrag unter Verzeichnisschutz. Erstmal -da hast Du Recht- die Eckdaten:

apache 2.4.29
Ubuntu 18.04

Sonst rennt alles bei Froxlor!

Hier noch die vhost:

<VirtualHost xxx.yyy.rrr.ttt:80>
  ServerName XXXXXX
  ServerAdmin XXXXXXX
  <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge
    RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [R=301;L,NE]
  </IfModule>
  <IfModule !mod_rewrite.c>
    Redirect 301 / https://XXXXXXXXXX/
  </IfModule>
</VirtualHost>

 

 

Share this post


Link to post
Share on other sites
  • 0

Das ist der http redirect vhost...bitte den SSL vhost Posten und die entsprechende 40_*.conf dazu

Share this post


Link to post
Share on other sites
  • 0

<VirtualHost XXXXXX:443>
  ServerName XXXX
  ServerAdmin XXXXX
  SSLEngine On
  SSLProtocol -ALL +TLSv1 +TLSv1.2
  SSLCompression Off
  SSLSessionTickets on
  SSLHonorCipherOrder off
  SSLCipherSuite XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
  SSLVerifyDepth 10
  SSLCertificateFile /etc/apache2/ssl/XXX.crt
  SSLCertificateKeyFile /etc/apache2/ssl/XXX.key
  SSLCACertificateFile /etc/apache2/ssl/XXX_CA.pem
  SSLCertificateChainFile /etc/apache2/ssl/XXX_chain.pem
  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=0"
  </IfModule>
  DocumentRoot "/var/kunden/webs/forum/"
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f XXXXXXXX"
  php_admin_value open_basedir "/var/kunden/webs/forum:/tmp"
  Alias /awstats "/var/kunden/webs/forum/awstats/XXXX"
  Alias /awstats-icon "/usr/share/awstats/icon/"
  LogLevel warn
  ErrorLog "/var/kunden/logs/forum-error.log"
  CustomLog "/var/kunden/logs/forum-access.log" combined
</VirtualHost>
 

 

 

 

40_ exisitieren nicht.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...