Jump to content
Froxlor Forum
  • 0
MeinerEiner

Php-Fpm Writes wrong config files

Question

Hello,

System:

Debian Buster with Froxlor 0.10.12, PHP7.3 and activated php-fpm

Settings php-fpm:

Process manager control (pm): dynamic

The number of child processes: 1 

The number of child processes created on startup: 20

The desired minimum number of idle server processes: 5

The desired maximum number of idle server processes: 35

Requests per child before respawning: 0

Idle Timeout: 30

 

Now rebuild config for domains and the files in /etc/php/7.3/fpm/pool.d contains following php-fpm settings:

pm = dynamic
pm.max_children = 1
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 1
pm.max_requests = 0
request_terminate_timeout = 60s
request_slowlog_timeout = 5s

 

so the values are not the configured ones. Did i do something wrong? Php-fpm values are not overriden in custom php-config for domains.

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Did you adjust these values in "PHP-FPM Versions" or in "PHP Configuration"? If the latter, then I bet you forgot to check "Override FPM-daemon settings (pm, max_children, etc.)"

Share this post


Link to post
Share on other sites
  • 0

Hello,

PHP-FPM versions: System default -> default froxlor as described above (No overide deamon settings possible)

PHP-CONFIGURATIONS: PHP-FPM config: System default

Add "-pass-header Authorization" / "CGIPassAuth On" to vhosts: is deactivated

Override FPM-daemon settings (pm, max_children, etc.): is activated

Process manager control (pm): dynamic

The number of child processes: 1 

The number of child processes created on startup: 20

The desired minimum number of idle server processes: 5

The desired maximum number of idle server processes: 35

Requests per child before respawning: 0

Idle Timeout: 30

Share this post


Link to post
Share on other sites
  • 0

Ah okay, this is due to "wrong" settings, for example, if pm is set to dynamic and number of child processes is smaller then child processes at startup, the latter is set to the value of number of child processes etc. This is a failsafe to keep the settings sane or else fpm will not work. See https://github.com/Froxlor/Froxlor/blob/master/lib/Froxlor/Cron/Http/Php/Fpm.php#L148

Point taken: the interface should check and explain this and not even make the saving of such values possible, you can open an issue on github if you like

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...