Jump to content
Froxlor Forum
  • 0

503 Service Unavailable mit PHP-FPM 7.3


Go to solution Solved by d00p,

Question

Liebe Leute!

Meine Installation: Debian 9 mit Apache/mpm_event und php7.3-fpm. Auf dem Server laufen gerade zwei Wordpress-Seiten produktiv.

Aus für mich nicht ersichtlichen Gründen liefert der Aufruf der Webseiten von Zeit zu Zeit einen 503 Service Unavailable Error. Im dazu passenden vHost-error-log steht:

[Tue Feb 04 13:52:52.651498 2020] [proxy:error] [pid 2510:tid 139659873113856] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-vHost-Name-php-fpm.socket (*) failed
[Tue Feb 04 13:52:52.651552 2020] [proxy_fcgi:error] [pid 2510:tid 139659873113856] [client xxx.xxx.xxx.xxx:56984] AH01079: failed to make connection to backend: httpd-UDS, referer: https://www.vHost-Domain.at/

Ein Restart von Apache und php7.3-fpm löst das Problem zeitweilig. Ich hab jetzt den LogWarn-Level auf debug hochgedreht, vielleicht ist da mehr ersichtlich.

Der Error deutet auf ein Rechteproblem hin, das kann ich allerdings nicht nachvollziehen. Alle Sockets in dem Directory haben die korrekten User-Rechte lr. froxlor-Einstellungen.

Die PHP-FPM Einstellung lauten:

pm = static
pm.max_children = 100
pm.max_requests = 1000


Fragen:

  • Ist das Socket-Verzeichnis /var/lib/apache2/fastcgi/ bei der Verwendung von php-fpm überhaupt korrekt?
  • In meinen Logwatch-Meldung ist gelegentlich zu sehen, dass versucht wurde meinen FPM-Proxy zu missbrauchen, könnten daher die Rechte-Fehler kommen? Wie kann ich den Proxy-Missbrauch verhindern?
  • PHP 7.3 FPM dürfte noch ein paar Bugs haben. Könnte ev. ein Downgrade auf PHP 7.2 oder 7.1 helfen?
  • Soll ich mal auf PHP-FPM pfeifen und auf mod_php zurückstellen?
  • Ev. von mpm_event auf mpm_worker umstellen?

 

Wo und wie kann ich da weiter nachforschen? Hilfe!


 

 

 

 

 

 

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Static und 100 children? Ich glaub du frisst dir einfach deine server-resourcen auf damit xD der spawnt ja immer sofort 100 children pro prozess....Versuchs mal mit pm=dynamic und etwas humaneren zahlen

Link to post
Share on other sites
  • 0
17 minutes ago, chrisiwien said:

PHP 7.3 FPM dürfte noch ein paar Bugs haben. Könnte ev. ein Downgrade auf PHP 7.2 oder 7.1 helfen?

7.3 ist das aktuelle stable....kannst schon mal langsam mit 7.4 anfangen :)

Link to post
Share on other sites
  • 0

Was? 7.3 war gestern doch noch neu! 😀

Hast Du eine Idee mit der Fehlermeldung?

Übrigens danke für die rasche Rückmeldung. Ich weiß schon, das Thema ist etwas offtopic-froxlor, allerdings muss ich Verbesserungen wenn dann genau dort vornehmen...

Link to post
Share on other sites
  • 0
1 minute ago, chrisiwien said:

I Kipfl hab übrigens die php7.3-fpm.conf nicht enabled (a2enconf). 😁  

Alles gut, brauchste auch nicht, hab ich noch nie gemacht, froxlor regelt das ja

4 minutes ago, chrisiwien said:

Was? 7.3 war gestern doch noch neu! 😀

Wenn du damit dezember 2018 meinst, dann ja :P  Siehe https://www.php.net/supported-versions.php

5 minutes ago, chrisiwien said:

Hast Du eine Idee mit der Fehlermeldung?

Da steht ein permission denied...wüsste jetzt nicht woher das kommen sollte, da froxlor das intern ja alles regelt mit den usern. Wenn da alles nach froxlor konfiguration aufgesetzt wurde passt das auch alles. Aber wenn du schon sagst das kommt nur hin und wieder mal vor, tippe ich erstmal auf schlechte config udn das teil verschluckt sich und deswegen hilft dann auch der restart des dienstes

Link to post
Share on other sites
  • 0

Ok! Danke für Deine Antworten! Super Hilfestellung!

Zusatz: nach enablen der php7.3-fpm.conf rennen die beiden Webseiten gefühlt schneller? (Noch vor der FPM-Werteumstellung) Hat ev. doch einen Einfluss??

Die Gaudi fängt erst an, da ich auf nginx umstellen werden. Keine Panik, habe ich gestern bei einem anderen RootServer gemacht.

Und ich liebe nginx bisher - die strukturierten Config-Dateien haben im Vergleich zu Apache auf alle Fälle die Nase vorn!

Link to post
Share on other sites
  • 0
41 minutes ago, chrisiwien said:

Zusatz: nach enablen der php7.3-fpm.conf rennen die beiden Webseiten gefühlt schneller? (Noch vor der FPM-Werteumstellung) Hat ev. doch einen Einfluss??

Nein, das bildest du dir ein. Die apache config da ist lediglich für den "default-gebrauch" gedacht, da sie auch auf das Socket /run/php/php7.3-fpm.sock zugreift. Froxlor erstellt ja pro domain/pool-config ein eigenes Socket. 

42 minutes ago, chrisiwien said:

Und ich liebe nginx bisher - die strukturierten Config-Dateien haben im Vergleich zu Apache auf alle Fälle die Nase vorn!

Ja, Möglichkeiten bietet nginx viele...aber du wirst dann sicher auch das ein oder andere vermissen :P Je nachdem was du so nutzt

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...