Jump to content
Froxlor Forum
  • 0
j4mb4l4j4

Curl Error 28 bei Wordpress - bei unterschiedlichen Froxlor Server

Question

Hi, ich habe mal eine Frage.

Ich habe zwei Froxlor Installationen, jeweils auf einem 16.04 mit php-fpm und auf einem 18.04 mit php-fpm.

Auf beiden läuft soweit alles super, nur habe ich bei Wordpress bei mehreren Plugins das Problem (z.b auch bei Jetpack) das ich folgenden Fehler bekomme:

The blog cannot autotrigger the internal scheduler, if an external trigger is used this could not be a real problem.
Error: cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received
Url: https://domain.de/wp-cron.php

Das Problem hab ich auf meinem NICHT Froxlor Server nicht.

Ich wollte deshalb mal fragen ob dies irgendwie im Zusammenhang mit Froxlor ist oder ich was falsch mache beim Server oder vergessen habe.

Oder Ihr eine Idee habt wie ich debuggen könnte.

Meine php.ini zeigt mir curl enabled und auch alles andere funktioniert mit Curl.

php.ini:

allow_call_time_pass_reference = Off
allow_url_fopen = On
asp_tags = Off
disable_classes =
disable_functions = curl_multi_exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system
display_errors = Off
display_startup_errors = Off
enable_dl = Off
error_reporting = E_ALL & ~E_NOTICE
expose_php = Off
file_uploads = On
cgi.force_redirect = 1
gpc_order = "GPC"
html_errors = Off
ignore_repeated_errors = Off
ignore_repeated_source = Off
include_path = ".:{PEAR_DIR}"
log_errors = On
log_errors_max_len = 1024
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
max_execution_time = 360
max_input_time = 60
memory_limit = 2048M
output_buffering = 4096
post_max_size = 4096M
precision = 14
register_argc_argv = Off
register_globals = Off
report_memleaks = On
sendmail_path = "/usr/sbin/sendmail -t -i -f {CUSTOMER_EMAIL}"
session.auto_start = 0
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.cache_expire = 180
session.cache_limiter = nocache
session.cookie_domain =
session.cookie_lifetime = 0
session.cookie_path = /
session.entropy_file = /dev/urandom
session.entropy_length = 16
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.gc_probability = 1
session.name = PHPSESSID
session.referer_check =
session.save_handler = files
session.save_path = "{TMP_DIR}"
session.serialize_handler = php
session.use_cookies = 1
session.use_trans_sid = 0
short_open_tag = On
suhosin.mail.protect = 1
suhosin.simulation = Off
track_errors = Off
upload_max_filesize = 4096M
upload_tmp_dir = "{TMP_DIR}"
variables_order = "GPCS"
;mail.add_x_header = On
;mail.log = "/var/log/phpmail.log"
opcache.restrict_api = ""

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Curl Version:

curl 7.58.0 (x86_64-pc-linux-gnu) libcurl/7.58.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.2.0 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Release-Date: 2018-01-24
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp
Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz TLS-SRP HTTP2 UnixSockets HTTPS-proxy PSL

 

Share this post


Link to post
Share on other sites
  • 0
Operation timed out after 5001 milliseconds with 0 bytes received

Sofern du ggfls. die standard php-fpm einstellungen für den processmanager hast (static, max_children 1) stell das mal um auf folgende settings:

fpm-dynamic.png

Share this post


Link to post
Share on other sites
  • 0

OMG, d00p, du bist DOPE !!!!

Der Hammer, es hat direkt geholfen 😀

Solltest du jemals nach Hannover kommen sag Bescheid dann lad ich dich auf 2-10 Bier ein.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...