Jump to content
Froxlor Forum
  • 0

It is recommended to install socat first


hk@

Question

today we suddenly got this:

/usr/bin/php /var/www/html/scripts/froxlor_master_cronjob.php --tasks --debug
[information] TasksCron: Searching for tasks to do
[information] Running Let's Encrypt cronjob prior to regenerating webserver config files
[information] Requesting/renewing Let's Encrypt certificates
[information] Updating certificate for xxx.server.local
[Tue Dec 31 15:47:09 CET 2019] It is recommended to install socat first.
[Tue Dec 31 15:47:09 CET 2019] We use socat for standalone server if you use standalone mode.
[Tue Dec 31 15:47:09 CET 2019] If you don't use standalone mode, just ignore this warning.
[information] Checking for LetsEncrypt client upgrades before renewing certificates:
[Tue Dec 31 15:47:08 CET 2019] Installing from online archive.
[Tue Dec 31 15:47:08 CET 2019] Downloading https://github.com/Neilpang/acme.sh/archive/master.tar.gz
[Tue Dec 31 15:47:09 CET 2019] Extracting master.tar.gz
[Tue Dec 31 15:47:09 CET 2019] Installing to /root/.acme.sh
[Tue Dec 31 15:47:09 CET 2019] Installed to /root/.acme.sh/acme.sh
[Tue Dec 31 15:47:09 CET 2019] Good, bash is found, so change the shebang to use bash as preferred.
[Tue Dec 31 15:47:10 CET 2019] OK
[Tue Dec 31 15:47:10 CET 2019] Install success!
[Tue Dec 31 15:47:10 CET 2019] Upgrade success!
[Tue Dec 31 15:47:10 CET 2019] Removing cron job
 

the box is ubuntu buster/sid after a bit of digging into the issue "apt install socat" did the trick. please add it to the required packages.

 

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
4 minutes ago, hk@ said:

[Tue Dec 31 15:47:09 CET 2019] We use socat for standalone server if you use standalone mode.
[Tue Dec 31 15:47:09 CET 2019] If you don't use standalone mode, just ignore this warning.

not required/needed for us

Link to post
Share on other sites
  • 0
1 minute ago, d00p said:

not required/needed for us

well, the acme.sh is reporting this on a 5-minute-basis because of the --tasks job and to get rid of this had to install it but any other "get rid of this" solutions would be welcome.

Link to post
Share on other sites
  • 0

well, don't call the "normal" cronjob with "--debug" flag, default from the generated /etc/cron.d/froxlor file is:

*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null

 

Link to post
Share on other sites
  • 0
3 minutes ago, d00p said:

well, don't call the "normal" cronjob with "--debug" flag, default from the generated /etc/cron.d/froxlor file is:


*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null

 

uhm, that's exactly what is (and was) running on this box, yet we got lots of mails reporting about socat.

Link to post
Share on other sites
  • 0

hm weird, so they are putting that on the stderr output (not redirected with 1> that way). Basically, yes, we could recommend socat in the debian package for exampe, but I think it's kind of wrong since we neither rely on it nor is it recommended for our use - so it would just be wrong.

On the other hand, on a plain debian, the default mysql-server is (currently) mariadb-server-10.3 which depends on socat and should install it anyway (that's why I got it installed and not getting any messages)

Link to post
Share on other sites
  • 0

and sorry for taking the wrong forum, obviously should have posted in german here, maybe you can move this thread to the international one. thank you again.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...