Jump to content
Froxlor Forum
  • 0
goudi

{gelöst} Fehler php cURL extension to be installed - ist aber da

Question

Hallo,

ich erhalte alle 5 Minuten folgenden Fehler:

Let's Encrypt requires the php cURL extension to be installed

php curl ist aber installiert und wird auch sinnvollerweise von Froxlor unter PHP info angezeigt:

 

cURL support enabled
cURL Information 7.47.0
Age 3

 

was ist da falsch? Ich hoffe mir kann jemand weiterhelfen.

Ich habe noch die Version 0.9.40.1 (DB: 201809280)

Die Frage aus meinem anderen Post ist obsolet, da ich aufgrund zu vieler Fehler eine Sicherung zurück gespielt habe.

Edited by goudi
Ursprungsfrage ist gelöst

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
1 minute ago, goudi said:

Wieso habe ich php 7.3 in der Konsole und der Rest läuft auf 7.2.25???

naja, das solltest du als sysadmin aber wissen!? Hast du das nicht installiert? Default ist nur eine PHP-Version verfügbar.

2 minutes ago, goudi said:

Ist das das Problem, dass ich eine falsch oder unterschiedliche php Versionen habe?

Nein absolut nicht

 

Um das jetzt einfach abzuschließen:

sudo apt-get install php7.3-curl

Und damit sollte es dann auch auf der konsole tun. Alternativ kannst du auch mit update-alternatives die entsprechend gewünschte php-version für CLI festlegen

Share this post


Link to post
Share on other sites
  • 0

das eine ist mod_php / fcgid / php-fpm (für websachen), console ist wieder was anderes, was sagt denn da "php -v" ? Wenns nicht die gleiche version ist, fehlt dir da für die andere version vllt php-curl

Share this post


Link to post
Share on other sites
  • 0

Hier die Antwort von php -v:

PHP 7.3.12-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Nov 28 2019 07:36:56) ( NTS )

Copyright (c) 1997-2018 The PHP Group

Zend Engine v3.3.12, Copyright (c) 1998-2018 Zend Technologies

    with Zend OPcache v7.3.12-1+ubuntu16.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

 

... hilft das weiter?

Share this post


Link to post
Share on other sites
  • 0

Bedingt, nutzt du denn php-7.3.12 auch im Froxlor interface wo curl vermeitlich installiert ist? Oder steht da im admin-dashboard vielleicht eine andere version? ich kenne dein setup nicht. Aber wenn man php-curl installiert dann ist das normal für alle SAPI's verfügbar - ergo bleibt nur, dass du auf der CLI eine andere php-version einsetzt als für Web

Share this post


Link to post
Share on other sites
  • 0

ehrlich gesagt bin ich mit der Frage etwas überfordert.

Ich habe mehrere Kunden angelegt, die unterschiedliche php.ini Angaben haben.

Ich dachte dass ich php für den Server zentral installiere und bereit stelle?

Mein Kunde "Nextcloud" macht mir auch ansonsten super viel Ärger - da geht im Moment mega wenig....

Im Post 1 habe ich die Angaben aus dem Dashboard genommen. Ist die php curl Version die gleiche, wie die php Gesamtversion? Ich habe jetzt keine Möglichkeit gefunden, auf der Konsole die Versionsnummer von php curl zur anzeige zu bringen.

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, goudi said:

. Ist die php curl Version die gleiche, wie die php Gesamtversion?

nein

2 minutes ago, goudi said:

Ich habe jetzt keine Möglichkeit gefunden, auf der Konsole die Versionsnummer von php curl zur anzeige zu bringen.

das nicht, aber du kannst prüfen ob es verfügbar ist:

php -m | grep curl

Steht dann bei dem Befehl in der nächsten Zeile "curl" hast du curl, steht da nix, hast du es nicht.

Außerdem kannst du doch bitte im Froxlor Dashboard einfach die PHP version ablesen und sagen, ob es die gleiche ist wie hier:

10 minutes ago, goudi said:

Hier die Antwort von php -v:

PHP 7.3.12-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Nov 28 2019 07:36:56) ( NTS )

 

Share this post


Link to post
Share on other sites
  • 0

ok nun bin ich baff.

Gemäß Befehl steht kein curl  - also ist es nicht installiert.

Ich hatte gestern versucht, php curl zu installieren - 

sudo apt-get install php7.2-curl

ich habe das bash bereits geschlossen, aber die Meldung lautete so ungefähr: curl ist bereits verfügbar...

Im Dashboard steht, dass ich php Version 7.2.25-1 habe.

Nextcloud läuft auch auf php 7.2.25 gemäß Webfrontend

nun bin ich erstaunt. Wieso habe ich php 7.3 in der Konsole und der Rest läuft auf 7.2.25???

Ist das das Problem, dass ich eine falsch oder unterschiedliche php Versionen habe?

Edited by goudi
was vergessen

Share this post


Link to post
Share on other sites
  • 0
vor 1 Minute schrieb d00p:

naja, das solltest du als sysadmin aber wissen!? Hast du das nicht installiert? Default ist nur eine PHP-Version verfügbar.

... Da hast Du wiederum recht- Installiert habe ich php 7.2

Etwas verwirrt bin ich - und da bin ich eben erst drüber gestolpert, dass ich php 7.3 auf dem System habe. Ich würde gerne einen (wenn er denn existieren sollte) Versionskauderwelch vermeiden, und dann auch gleich auf 7.4 umschwenken - aber das ist ein anderes Thema. 

Ist es schlau, o.g. php7.3-curl zu installieren? Ich habe ja auch noch nen ganzen Berg voll Fehlermeldungen auf Nextcloud - die ich vor ein paar Tagen auf Version 17 gezogen habe

vorher habe ich ubuntu mit "update und upgrade" (ohne Dist-Upgrade) auf Stand gebracht

- seitdem ist überall gängbäng.

Share this post


Link to post
Share on other sites
  • 0

Was sinnvoll ist und was nicht entscheidest DU, du bist doch der admin dieses systems. Auch du solltest wissen wieso und woher da php-7.3 kommt. Schau doch einfach via "dpkg -l | grep php" nach was du da alles an PHP installiert hast. Und dann entscheide was davon du behälst und irgendwo einsetzt/einsetzen willst und was nicht.

 

Share this post


Link to post
Share on other sites
  • 0

Ich habe gestern den fehlende php-curl installiert - seitdem ist mehr ruhe.

Dieser Teil ist erledigt - vielen Dank für die Unterstützung, nun muss ich nur noch die vielen php Versionen loswerden.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...