Jump to content
Froxlor Forum
  • 1

Invalid IP address - unable to add additional ip/port


PMO

Question

Hello,
I recently installed Froxlor and even got through php-fpm but I it seems for some reason
that I can't add second IP/Port pair - got "Invalid IP address" error.

I have only one default entry with local IP and port 80.
I wanted to add another entry for ssl. I've enabled ssl and lets encrypt in settings.

I don't know if it is right, but event when I try to edit existing entry i got the same error.

i also don't know where to check detailed logs from gui operation so i'm stuck...

 

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
On 2/8/2020 at 1:34 PM, d00p said:

Froxlor is not meant to be run in a LAN environment...

Hello,

We have control over our private and public network (servers and network equipment) and we would like to run froxlor behind a (hardware) firewall.

Is there any technical reason why do you not allow private networks to be used for running froxlor?

Currently we are running IIS web-server with private network setup inside and ip address translation via firewall to public network on the outside.

Also if you add to the virtual machine private network and setup web server to install froxlor it will allow you to complete the installation with private ip but you will not be able to add any additional private addresses. Maybe you need to add some additional checks while doing preinstall prerequisites if you do not want to allow private networks to be used with froxlor.

Thank you for the answer. I have some other questions that I will ask in another topic.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...