September 7, 20197 yr Hey, mein Mailserver (Postfix & Dovecot) mit SSL-Zertifikat und konfiguriertem DKIM und SPF empfängt ohne Probleme Mails und versendet diese auch (Port 25 und Port 587 versenden beide mit TLS, Port 465 funktioniert nicht). Allerdings funktioniert das bisher nur vom Server selbst aus bisher mit PHPMailer. Über den MailClient Thunderbird empfange ich zwar die alle Mails, kann aber selbst kein versenden. Die Einstellungen in Thunderbird für den SMTP Server: Quote Port 587 (25 und 465 bereits probiert) Verbindungssicherheit: SSL/TLS Authentifizierungsmethode: Passwort, normal Email-Adresse mit Konto ist in Froxlor beim Kundenaccount angelegt. In Froxlor Admin Panel sind DomainKey-Einstellungen und Domain-SPF-Einstellungen nicht aktiviert. Beim Versuch eine Mail zu versenden erhalte ich nach etwa 30 Sekunden einen Timeout. Die mail.log: Quote Sep 7 10:21:43 abc postfix/submission/smtpd[21509]: connect from isp.de[1.1.1.1] Sep 7 10:23:24 abc postfix/submission/smtpd[21509]: lost connection after UNKNOWN from isp.de[1.1.1.1] Sep 7 10:23:24 abc postfix/submission/smtpd[21509]: disconnect from isp.de[1.1.1.1] Beim erfolgreichen Versenden einer Mail über phpMailer steht das in der mail.log: Quote Sep 7 10:33:12 abc postfix/submission/smtpd[21614]: connect from localhost[127.0.0.1] Sep 7 10:33:12 abc postfix/submission/smtpd[21614]: connect from localhost[127.0.0.1] Sep 7 10:33:12 abc postfix/submission/smtpd[21614]: Anonymous TLS connection established from localhost[127.0.0.1]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits) Sep 7 10:33:12 abc postfix/submission/smtpd[21614]: C82DBA06B2: client=localhost[127.0.0.1], sasl_method=LOGIN, sasl_username=info@abc.de Sep 7 10:33:12 abc postfix/cleanup[21619]: C82DBA06B2: message-id=<YVcY2ITeOJP5poWL9sMn6y0bgWWbE5nwu76k6UwEs@abc.de> Sep 7 10:33:12 abc postfix/qmgr[20350]: C82DBA06B2: from=<info@abc.de>, size=1235, nrcpt=2 (queue active) Sep 7 10:33:12 abc postfix/submission/smtpd[21614]: disconnect from localhost[127.0.0.1] Sep 7 10:33:12 abc dovecot: lda(info@abc.de): msgid=<YVcY2ITeOJP5poWL9sMn6y0bgWWbE5nwu76k6UwEs@abc.de>: saved mail to INBOX Sep 7 10:33:12 abc postfix/pipe[21621]: C82DBA06B2: to=<info@abc.de>, relay=dovecot, delay=0.09, delays=0.06/0.01/0/0.02, dsn=2.0.0, status=sent (delivered via dovecot service) Sep 7 10:33:13 abc postfix/smtp[21622]: C82DBA06B2: to=<test@gmail.com>, orig_to=<info@abc.de>, relay=gmail-smtp-in.l.google.com[173.194.76.26]:25, delay=0.44, delays=0.06/0.01/0.09/0.28, dsn=2.0.0, status=sent (250 2.0.0 OK 1567845193 p12si5792920wma.100 - gsmtp) Sep 7 10:33:13 abc postfix/qmgr[20350]: C82DBA06B2: removed
September 7, 20197 yr Author postconf -n alias_maps = $alias_database append_dot_mydomain = no biff = no broken_sasl_auth_clients = yes command_directory = /usr/sbin config_directory = /etc/postfix daemon_directory = /usr/lib/postfix data_directory = /var/lib/postfix debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5 dovecot_destination_recipient_limit = 1 html_directory = no inet_protocols = ipv4 local_transport = local mailbox_size_limit = 0 mailq_path = /usr/bin/mailq manpage_directory = /usr/share/man message_size_limit = 52428800 milter_default_action = accept milter_protocol = 6 mydomain = v123456.alternativedomainfrommyhost.de myhostname = $mydomain mynetworks = 127.0.0.0/8 newaliases_path = /usr/bin/newaliases non_smtpd_milters = local:opendkim/opendkim.sock readme_directory = /usr/share/doc/postfix sample_directory = /usr/share/doc/postfix sendmail_path = /usr/sbin/sendmail setgid_group = postdrop smtp_tls_note_starttls_offer = yes smtp_tls_security_level = may smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unknown_client_hostname smtpd_helo_required = yes smtpd_milters = local:opendkim/opendkim.sock smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unauth_pipelining, reject_non_fqdn_recipient smtpd_relay_restrictions = smtpd_sasl_auth_enable = yes smtpd_sasl_local_domain = $myhostname smtpd_sasl_path = private/auth smtpd_sasl_type = dovecot smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated, reject_unknown_helo_hostname, reject_unknown_recipient_domain, reject_unknown_sender_domain smtpd_tls_cert_file = /etc/apache2/ssl/mailCert.crt smtpd_tls_key_file = /etc/apache2/ssl/privkey.pem smtpd_tls_loglevel = 1 smtpd_tls_received_header = yes smtpd_tls_security_level = may smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtpd_use_tls = yes unknown_local_recipient_reject_code = 550 virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf virtual_gid_maps = static:2000 virtual_mailbox_base = / virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf virtual_mailbox_limit = 0 virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf virtual_transport = dovecot virtual_uid_maps = static:2000 postconf -M smtp inet n - - - - smtpd submission inet n - - - - smtpd -o syslog_name=postfix/submission -o smtpd_tls_security_level=encrypt -o smtpd_sasl_auth_enable=yes smtps inet n - - - - smtpd -o syslog_name=postfix/smtps -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes pickup unix n - - 60 1 pickup cleanup unix n - - - 0 cleanup qmgr unix n - n 300 1 qmgr tlsmgr unix - - - 1000? 1 tlsmgr rewrite unix - - - - - trivial-rewrite bounce unix - - - - 0 bounce defer unix - - - - 0 bounce trace unix - - - - 0 bounce verify unix - - - - 1 verify flush unix n - - 1000? 0 flush proxymap unix - - n - - proxymap proxywrite unix - - n - 1 proxymap smtp unix - - - - - smtp relay unix - - - - - smtp showq unix n - - - - showq error unix - - - - - error retry unix - - - - - error discard unix - - - - - discard local unix - n n - - local virtual unix - n n - - virtual lmtp unix - - - - - lmtp anvil unix - - - - 1 anvil scache unix - - - - 1 scache maildrop unix - n n - - pipe flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} uucp unix - n n - - pipe flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient) ifmail unix - n n - - pipe flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient) bsmtp unix - n n - - pipe flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient scalemail-backend unix - n n - 2 pipe flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension} mailman unix - n n - - pipe flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py ${nexthop} ${user} dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient}
September 7, 20197 yr Author mydestination = localhost Diese Zeile in main.cf hat das Problem gelöst Edited September 7, 20197 yr by 2asdfdas
September 9, 20197 yr On 9/7/2019 at 10:37 AM, 2asdfdas said: In Froxlor Admin Panel sind DomainKey-Einstellungen und Domain-SPF-Einstellungen nicht aktiviert. Das ist sowieso nur relevant wenn du selbst den nameserver betreibst On 9/7/2019 at 11:06 PM, 2asdfdas said: mydestination = localhost Diese Zeile in main.cf hat das Problem gelöst dann hast du aber rumgefummelt, default ist: mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
Archived
This topic is now archived and is closed to further replies.