Jump to content
Froxlor Forum

2asdfdas

Members
  • Content Count

    27
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 2asdfdas

  • Rank
    Froxie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. mydestination = localhost Diese Zeile in main.cf hat das Problem gelöst
  2. postconf -n alias_maps = $alias_database append_dot_mydomain = no biff = no broken_sasl_auth_clients = yes command_directory = /usr/sbin config_directory = /etc/postfix daemon_directory = /usr/lib/postfix data_directory = /var/lib/postfix debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5 dovecot_destination_recipient_limit = 1 html_directory = no inet_protocols = ipv4 local_transport = local mailbox_size_limit = 0 mailq_path = /usr/bin/mailq manpage_directory = /usr/share/man message_size_limit = 52428800 milter_default_action = accept milter_protocol = 6 mydomain = v123456.alternativedomainfrommyhost.de myhostname = $mydomain mynetworks = 127.0.0.0/8 newaliases_path = /usr/bin/newaliases non_smtpd_milters = local:opendkim/opendkim.sock readme_directory = /usr/share/doc/postfix sample_directory = /usr/share/doc/postfix sendmail_path = /usr/sbin/sendmail setgid_group = postdrop smtp_tls_note_starttls_offer = yes smtp_tls_security_level = may smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unknown_client_hostname smtpd_helo_required = yes smtpd_milters = local:opendkim/opendkim.sock smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unauth_pipelining, reject_non_fqdn_recipient smtpd_relay_restrictions = smtpd_sasl_auth_enable = yes smtpd_sasl_local_domain = $myhostname smtpd_sasl_path = private/auth smtpd_sasl_type = dovecot smtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cf smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated, reject_unknown_helo_hostname, reject_unknown_recipient_domain, reject_unknown_sender_domain smtpd_tls_cert_file = /etc/apache2/ssl/mailCert.crt smtpd_tls_key_file = /etc/apache2/ssl/privkey.pem smtpd_tls_loglevel = 1 smtpd_tls_received_header = yes smtpd_tls_security_level = may smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtpd_use_tls = yes unknown_local_recipient_reject_code = 550 virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf virtual_gid_maps = static:2000 virtual_mailbox_base = / virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf virtual_mailbox_limit = 0 virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf virtual_transport = dovecot virtual_uid_maps = static:2000 postconf -M smtp inet n - - - - smtpd submission inet n - - - - smtpd -o syslog_name=postfix/submission -o smtpd_tls_security_level=encrypt -o smtpd_sasl_auth_enable=yes smtps inet n - - - - smtpd -o syslog_name=postfix/smtps -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes pickup unix n - - 60 1 pickup cleanup unix n - - - 0 cleanup qmgr unix n - n 300 1 qmgr tlsmgr unix - - - 1000? 1 tlsmgr rewrite unix - - - - - trivial-rewrite bounce unix - - - - 0 bounce defer unix - - - - 0 bounce trace unix - - - - 0 bounce verify unix - - - - 1 verify flush unix n - - 1000? 0 flush proxymap unix - - n - - proxymap proxywrite unix - - n - 1 proxymap smtp unix - - - - - smtp relay unix - - - - - smtp showq unix n - - - - showq error unix - - - - - error retry unix - - - - - error discard unix - - - - - discard local unix - n n - - local virtual unix - n n - - virtual lmtp unix - - - - - lmtp anvil unix - - - - 1 anvil scache unix - - - - 1 scache maildrop unix - n n - - pipe flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} uucp unix - n n - - pipe flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient) ifmail unix - n n - - pipe flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient) bsmtp unix - n n - - pipe flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient scalemail-backend unix - n n - 2 pipe flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension} mailman unix - n n - - pipe flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py ${nexthop} ${user} dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient}
  3. Hey, mein Mailserver (Postfix & Dovecot) mit SSL-Zertifikat und konfiguriertem DKIM und SPF empfängt ohne Probleme Mails und versendet diese auch (Port 25 und Port 587 versenden beide mit TLS, Port 465 funktioniert nicht). Allerdings funktioniert das bisher nur vom Server selbst aus bisher mit PHPMailer. Über den MailClient Thunderbird empfange ich zwar die alle Mails, kann aber selbst kein versenden. Die Einstellungen in Thunderbird für den SMTP Server: Email-Adresse mit Konto ist in Froxlor beim Kundenaccount angelegt. In Froxlor Admin Panel sind DomainKey-Einstellungen und Domain-SPF-Einstellungen nicht aktiviert. Beim Versuch eine Mail zu versenden erhalte ich nach etwa 30 Sekunden einen Timeout. Die mail.log: Beim erfolgreichen Versenden einer Mail über phpMailer steht das in der mail.log:
  4. Ach den Debug Mode Diese Zeilen finden sich aber den ganzen Tag über auch ohne Loginversuche von meinem Thunderbird. Ich schätze das sind Bots die versuchen Logins zu bruten. Meine öffentliche IP habe ich in den Logs zu 1.1.1.1 abgeändert und die Domain zu abc und isp.de Ich glaube das war der default Wert. Habe es aber explizit eingetragen und restartet. Ohne Erfolg
  5. Der Loginversuch geschah mit diesen Einstellungen. Nach wie vor weiß ich nicht, ob die Auswahl bei Authentifizierung korrekt ist und ob der Port der richtige ist bei SMTP
  6. In Froxlor habe ich die neue Domain abc.de angelegt unter den IPs 1.1.1.1:80 und 1.1.1.1:443 Im Kunden habe ich dann eine Email-Adresse zu abc.de angelegt. Bei Konto steht auch Ja (84.0000 KiB) Ich weiß nicht welche Infos noch relevant sind, die ich noch nicht gepostet habe. Lass es mich wissen ich stell hier alles rein. Danke!
  7. Ja, hab ich ja weiter oben schon einen Auszug gepostet. Bezüglich meiner öffentlichen IP finde ich darin nur: Ansonsten ist die LogFile voll mit Verbindungsversuchen mir unbekannter Adressen:
  8. BTW auch ohne SSL über Port 143 konnte keine Verbindung mit dem mail-Server aufgebaut werden, da sie verweigert wurde (laut Thunderbird) Von welcher server-log sprichst du?
  9. In Froxlor hatte ich SSL aktiviert. Ansonsten: In der postfix main.cf: In der dovecot 10-ssl.conf: 10-master.conf: Ich schätze das sind alle Stellen bzgl SSL
  10. Vor der Passwort-Überprüfung kommt folgendes Popup
  11. Leider nicht. Ich bin jetzt nochmal der Anleitung von Froxlor zur Konfiguration des Mailservers gefolgt. Die Datenbank scheint schon eingerichtet zu sein. Ich vermute das Problem liegt wohl an den Einstellungen, die ich beim Einrichten im MailClient angebe. Eigentlich bin ich mir bei allen Feldern recht unsicher. Server-Adresse müsste stimmen, da das die Adresse ist, die in der Main.cf bei Postfix angegeben ist: bei den anderen Werten kenne ich die "Locations" nicht zum gegenchecken. Bei IMAP sind die Ports so in der config angegeben (/etc/dovecot/conf.d/10-master.conf) service imap-login { inet_listener imap { #port = 143 } inet_listener imaps { port = 993 ssl = yes } Für SMTP weiß ich nicht genau, wo ich nachschauen muss, aber netstat zeigt mir 587, 22 und auch 465 bei LISTEN an. Das sind die, die man hier bei Thunderbird auswählen kann. Bei SSL weiß ich nicht, ob SSL/TLS oder STARTTLS und bei Authentifizierung bin ich mir auch nicht sicher., Hier gibt es noch "Veschlüsseltes Passwort", "Kerberos" und "NTLM" Das Passwort wird übrigens schon minutenlang getestet. Ich vermute es gibt einen Timeout Wert. In der mail.log sehe ich nichts dazu, außer
  12. Achso das meintest du. Naja ich bin hier ziemlich aufgeschmissen und möchte den MailClient Login so schnell wie möglich zum Laufen bringen. Was empfiehlst du mir denn zu tun? Vielleicht über Konfiguration einen neuen Mailserver zu konfigurieren?
  13. Wo finde ich denn "Installation"? Im Admin-Panel sehe ich da nichts.
×
×
  • Create New...