Jump to content
Froxlor Forum
  • 0
2asdfdas

Seit Froxlor Änderung - Connection Refused

Question

Bei "IP und Ports" im Admin Panel war meine IP mit Port 80 bereits eingetragen.

Ich habe einen weiteren Eintrag (meine IP und Port 443) hinzugefügt und dann bei meinem Kunden bei der Domain die nun entstandene zweite Checkbox auch aktiviert. 

Nach dieser Änderung kann ich meinen Webserver nicht mehr erreichen, also auch nicht in Froxlor einloggen. 

Außerdem hat sich die config File in /etc/apache2/sites-enabled verändert. Zuvor waren dort MeineIP:80 und meine MeineIP:443 als zwei VirtualHosts seperat eingetragen und hatten jeweils SSL-Verweise auf die Zertifikate.

 

Übrig geblieben ist hier nur der VirtualHost Eintrag MeineIP:80 ohne SSL.

Habe schon ein wenig rumprobiert aber komme einfach nicht mehr auf den Webserver. 

 

Danke!

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 1
9 minutes ago, 2asdfdas said:

Woran erkennst du denn, dass "create listen statement" aktiviert ist bzw. wo kann ich das ändern?

 

52 minutes ago, 2asdfdas said:

[Sun Aug 25 22:00:01.497085 2019] [mpm_prefork:notice] [pid 2010] AH00171: Graceful restart requested, doing restart (98)Address already in use: AH00072: make_sock: could not bind to address 1.1.1.1:443 [Sun Aug 25 22:00:01.563088 2019] [mpm_prefork:alert] [pid 2010] no listening sockets available, shutting down

Daran erkennt man das. Er kann nicht auf 443 binden, weil er da schon drauf gebunden ist. Zum einen löscht du jetzt das:

53 minutes ago, 2asdfdas said:

Listen 1.1.1.1:443

Aus dem SSL-Vhost. Und aus dem nicht-ssl vhost (port 80) löschst du folgende Zeilen:

54 minutes ago, 2asdfdas said:

     SSLEngine On    
     SSLCertificateFile /etc/apache2/ssl/www_mydomain.crt
     SSLCertificateKeyFile /etc/apache2/ssl/www_mydomain.pem
    SSLCertificateChainFile /etc/apache2/ssl/mailCert.crt

Dann mit "service apache2 restart" den webserver neustarten, dann sollte es wieder gehen.

Dann in froxlor IP/Port bearbeiten, bei Port 80 deaktivierst du bitte "SSL IP" und bei der IP/Port für port 443 entfernst du das Häkchen bei "Erstelle Listen-Eintrag"

Share this post


Link to post
Share on other sites
  • 0

Was steht denn in der Apache Error Log? Wie sehen die die entsprechenden vhosts aus?

Share this post


Link to post
Share on other sites
  • 0

In der error.log:

[Sun Aug 25 21:21:39.881177 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/datas.php' not found or unable to stat
[Sun Aug 25 21:21:40.125693 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/aojiao.php' not found or unable to stat
[Sun Aug 25 21:21:40.379400 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/guipu.php' not found or unable to stat
[Sun Aug 25 21:21:40.604748 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/zhui.php' not found or unable to stat
[Sun Aug 25 21:21:41.974932 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/ji.php' not found or unable to stat
[Sun Aug 25 21:21:43.967014 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/xing.php' not found or unable to stat
[Sun Aug 25 21:21:44.908377 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/c.php' not found or unable to stat
[Sun Aug 25 21:21:45.160085 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/c.php' not found or unable to stat
[Sun Aug 25 21:21:45.370816 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/test.php' not found or unable to stat
[Sun Aug 25 21:21:47.853578 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/laobiao.php' not found or unable to stat
[Sun Aug 25 21:21:48.073868 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/sample.php' not found or unable to stat
[Sun Aug 25 21:21:52.576414 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/shell.php' not found or unable to stat
[Sun Aug 25 21:21:53.072978 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/12.php' not found or unable to stat
[Sun Aug 25 21:21:53.705705 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/ecmsmod.php' not found or unable to stat
[Sun Aug 25 21:21:56.502362 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/index.php' not found or unable to stat
[Sun Aug 25 21:21:59.894610 2019] [autoindex:error] [pid 2801] [client 106.1.1.2:62283] AH01276: Cannot serve directory /var/www/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive
[Sun Aug 25 21:22:00.110924 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/user.php' not found or unable to stat, referer: 554fcae493e564ee0dc75bdf2ebf94caads|a:3:{s:2:"id";s:3:"'/*";s:3:"num";s:141:"*/ union select 1,0x272F2A,3,4,5,6,7,8,0x7b247b24524345275d3b6469652f2a2a2f286d6435284449524543544f52595f534550415241544f5229293b2f2f7d7d,0--";s:4:"name";s:3:"ads";}554fcae493e564ee0dc75bdf2ebf94ca
[Sun Aug 25 21:22:00.324661 2019] [:error] [pid 2801] [client 106.1.1.2:62283] script '/var/www/index.php' not found or unable to stat
[Sun Aug 25 21:54:57.813273 2019] [mpm_prefork:notice] [pid 2087] AH00169: caught SIGTERM, shutting down
[Sun Aug 25 21:55:11.025201 2019] [ssl:warn] [pid 1997] AH01906: v123.luckysrv.de:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Aug 25 21:55:11.025630 2019] [ssl:warn] [pid 1997] AH01909: v123.luckysrv.de:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 25 21:55:11.274464 2019] [ssl:warn] [pid 2010] AH01906: v123.luckysrv.de:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Aug 25 21:55:11.274491 2019] [ssl:warn] [pid 2010] AH01909: v123.luckysrv.de:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 25 21:55:11.289142 2019] [mpm_prefork:notice] [pid 2010] AH00163: Apache/2.4.10 (Debian) OpenSSL/1.0.1t configured -- resuming normal operations
[Sun Aug 25 21:55:11.289188 2019] [core:notice] [pid 2010] AH00094: Command line: '/usr/sbin/apache2'
[Sun Aug 25 22:00:01.497085 2019] [mpm_prefork:notice] [pid 2010] AH00171: Graceful restart requested, doing restart
(98)Address already in use: AH00072: make_sock: could not bind to address 1.1.1.1:443
[Sun Aug 25 22:00:01.563088 2019] [mpm_prefork:alert] [pid 2010] no listening sockets available, shutting down
[Sun Aug 25 22:00:01.563092 2019] [:emerg] [pid 2010] AH00019: Unable to open logs, exiting

Versucht hier einer Dateien zu finden? ? 

Und ja in /var/www/ liegt momentan keine Index. Das war aber schon von Anfang an so und kann nicht die Ursache sein. Direkter Zugriff auf meine Domain müsste einen 403 auslösen, und im test directory würde man eine index finden.

An den Zertifikaten habe ich nichts verändert.

 

Die Connection wird aber Domain-weit abgelehnt.

ls /etc/apach2/sites-enabled/

000-default.conf

05_froxlor_dirfix_nofcgid.conf

10_froxlor_ipandport_1.1.1.1.80.conf

10_froxlor_ipandport_1.1.1.1.443.conf

28_froxlor_normal_vhost_adminKunde.v123.luckysrv.de.conf

35_froxlor_normal_vhost_mydomain.de.conf

40_froxlor_diroption_4a14d56d7644ccc1232326.conf

default-ssl.conf

 

Das hier sind wohl die 3 interessanten Dateien:

# 10_froxlor_ipandport_1.1.1.1.80.conf
# Created 25.08.2019 22:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost 1.1.1.1:80>

    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/www_mydomain.crt
    SSLCertificateKeyFile /etc/apache2/ssl/www_mydomain.pem
    SSLCertificateChainFile /etc/apache2/ssl/mailCert.crt

DocumentRoot "/var/www/"
 ServerName v123.luckysrv.de
</VirtualHost>
# 10_froxlor_ipandport_1.1.1.1.443.conf
# Created 25.08.2019 22:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

Listen 1.1.1.1:443
<VirtualHost 1.1.1.1:443>

    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/www_mydomain.crt
    SSLCertificateKeyFile /etc/apache2/ssl/www_mydomain.pem
    SSLCertificateChainFile /etc/apache2/ssl/mailCert.crt
DocumentRoot "/var/www/"
 ServerName v123.luckysrv.de
</VirtualHost>
# 35_froxlor_normal_vhost_mydomain.conf
# Created 25.08.2019 22:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 2 - CustomerID: 1 - CustomerLogin: adminKunde
<VirtualHost 1.1.1.1:80 1.1.1.1:443>
    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/www_mydomain.crt
    SSLCertificateKeyFile /etc/apache2/ssl/www_mydomain.pem
    SSLCertificateChainFile /etc/apache2/ssl/mailCert.crt

  ServerName mydomain
  ServerAlias *.mydomain
  ServerAdmin info@mydomain
  DocumentRoot "/var/www/"
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f info@mydomain"
  php_admin_value open_basedir "/var/www:/tmp"
  Alias /webalizer "/var/customers/webs/adminKunde/webalizer"
  ErrorLog "/var/customers/logs/adminKunde-error.log"
  CustomLog "/var/customers/logs/adminKunde-access.log" combined
</VirtualHost>

 

Die SSL Einträge habe ich selbst hinzugefügt. Die Domain v123.luckysrv.de (hier umbenannt) wollte ich eigentlich an allen Stellen noch mit meiner neu gekauften Domain mydomain ersetzen, aber das sollte ja erstmal keine Rolle spielen, da sie beide auf die selbe IP zeigen.

Share this post


Link to post
Share on other sites
  • 0

Die ssl IP ist das Problem, du hast "create listen statement" aktiviert, obwohl dein Apache schon auf Port 443 hört. Und du hast auch deine Port 80 IP anscheinend zu einer ssl IP gemacht, das wird nix. 

Share this post


Link to post
Share on other sites
  • 0

Woran erkennst du denn, dass "create listen statement" aktiviert ist bzw. wo kann ich das ändern? Komme ja schließlich nicht mehr ins Panel.

Quote

Und du hast auch deine Port 80 IP anscheinend zu einer ssl IP gemacht, das wird nix. 

Du spielst sicher auf die SSL Zeilen in der 10_froxlor_ipandport_1.1.1.1.80.conf an. Ich habe nur viel rumprobiert. Habe ich wieder entfernt.

Share this post


Link to post
Share on other sites
  • 0

Okay danke. Weißt du welchen Einfluss der ServerName Eintrag in den Host-Dateien hat? Da steht nämlich überall noch die v123.luckysrv.de Domain drin. 

Share this post


Link to post
Share on other sites
  • 0

ServerName gibt an für welche Domain der Vhost ist. wenn da v123.luckysrv.de drinsteht in den 10_*.conf vhosts ist das wohl die Domain die du bei Installation von Froxlor angegeben hast.

Share this post


Link to post
Share on other sites
  • 0

Zwei Probleme gibt es jetzt:

 

Irgendeine Anwendung editiert ständig (alle paar Minuten) meine SSL-Einträge aus der 443er vHost Datei, was dann dazu führt, dass ich die Seite nicht mehr über https aufrufen kann.  Der Servername wird auch ständig zur v123.... zurückgesetzt. 

Da in Froxlor unter SSL-Zertifikate nichts gefunden wurde, habe ich in den Einstellungen im Panel SSL aktiviert und die Pfade zum Zertifikat und Key angegeben. Gefunden wird nach wie vor, auch nach Neustart nichts. 

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, 2asdfdas said:

Irgendeine Anwendung editiert ständig (alle paar Minuten) meine SSL-Einträge aus der 443er vHost Datei, was dann dazu führt, dass ich die Seite nicht mehr über https aufrufen kann.  Der Servername wird auch ständig zur v123.... zurückgesetzt

ich hab dir doch gesagtz woher das kommt, froxlor setzt seinen eigenen hostname da natürlich ein, den du bei der installation angegeben hast. Du kannst natürlich alternativ das häkchen bei "servername eintrag" entfernen und in die eigenen vhost-container einstellungen dann "ServerName wunschdomain.tld" schreiben

13 minutes ago, 2asdfdas said:

Da in Froxlor unter SSL-Zertifikate nichts gefunden wurde, habe ich in den Einstellungen im Panel SSL aktiviert und die Pfade zum Zertifikat und Key angegeben. Gefunden wird nach wie vor, auch nach Neustart nichts. 

Naja, es gibt verschiedene Stellen und Wege dafür. Einmal in den Einstellungen (global) unter SSL, da kann ein Systemweites SSL Zertifikat angegeben werden. Dann pro IP/Port kann du eigene Zertifikate angeben und dann nochmal pro Domain entweder via Let's Encrypt oder halt als Kunde selbst im Domain-SSL-Editor

Share this post


Link to post
Share on other sites
  • 0

Naja ich habe es an allen erdenklichen Stellen angegeben, gefunden wird dennoch nichts. Also das Zertifikat wird von Browsern erkannt, hat mich nur gewundert warum in Froxlor nichts auftaucht. Parallel dazu habe ich ja eine Zertifkats Problem des Mailservers. Dachte nur das könnte womöglich damit zusammenhängen

Share this post


Link to post
Share on other sites
  • 0

Zertifikate die du in den Einstellungen oder IP/Port angibst (Pfad + Datei) taucht das nicht in der Liste der Zertifikate auf. Dort lesen wir nur die die in der Datenbank hinterlegt sind (let's encrypt und von Kunden hinterlegte Zertifikatsdaten) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...