Jump to content
Froxlor Forum
  • 0
s20

Apache startet nicht mehr nach Upgrade auf Debian Buster

Question

Hallo,

ich habe gerade ein Upgrade auf debian buster durchgeführt. Nach dem reboot startet leider der Apache nicht mehr mit der alten Config und wirft folg. Fehler:

 

Aug 16 11:14:49 server.de apachectl[4046]: (98)Address already in use: AH00072: make_sock: could not bind to address 123.456.789.111:443
Aug 16 11:14:49 server.de apachectl[4046]: no listening sockets available, shutting down
Aug 16 11:14:49 server.de apachectl[4046]: AH00015: Unable to open logs
Aug 16 11:14:49 server.de apachectl[4046]: Action 'start' failed.
Aug 16 11:14:49 server.de apachectl[4046]: The Apache error log may have more information.
Aug 16 11:14:49 server.de systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Aug 16 11:14:49 server.de systemd[1]: apache2.service: Failed with result 'exit-code'.

 netstat -pltn zeigt nichts auf port 80 oder 443

Muss ich in der Config vom froxlor ggf etwas anpassen?

Danke für Hilfe.

-->

ich habe soeben die Files :

sites-enabled/10_froxlor_ipandport_* aus dem Ordner entfernt. Danach startet der apache und läuft. Was muss ich denn in der Config anpassen, damit die nicht mehr erzeugt werden?

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
3 minutes ago, s20 said:

(98)Address already in use: AH00072: make_sock: could not bind to address 123.456.789.111:443

es läuft halt schon was auf 443 - hast du vllt ein doppeltes "Listen 443" irgendwo?

Normal, wenn man a2enmod ssl macht hört apache automatisch auf 443, ggfls hast du beim anlegen der IP in froxlor ausversehen noch das häkchen bei "create listen statement" gesetzt? Einfach mal grep -r "Listen" /etc/apache2/sites-enabled/ 

Share this post


Link to post
Share on other sites
  • 0

ich habe soeben die Files :

sites-enabled/10_froxlor_ipandport_*

aus dem Ordner entfernt. Danach startet der apache und läuft. Was muss ich denn in der Config anpassen, damit die nicht mehr erzeugt werden?

Share this post


Link to post
Share on other sites
  • 0

ich habe den Hacken bei create listen bei den ips entfernt, die config neu geschrieben und der apache läuft wieder. danke

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...