Jump to content
Froxlor Forum
  • 0
Eventomaxx

nscd hängt sich auf

Question

Hey,

wir haben ab uns zu mal das Problem, dass sich nscd aufhängt.
Das Ganze äußert sich so, dass der nscd Prozess 1-2 CPU Kerne zu 100% auslastet und auf nichts mehr reagiert, bis man den Service neustartet.
Das hat dann natürlich zur Folge, dass der froxlor cronjob nicht mehr läuft und teilweise liefern Kundenseiten dann nur noch 403 Fehler, wenn man sie aufruft.

Der cronjob hängt bei dem Punkt:

Writing 70 entries to shadow file


Im nscd.log hängt es dann bei den folgenden Zeilen:

considering GETBYNAME entry "www-data", timeout 1564393743
Reloading "www-data" in group cache


Auf dem Server läuft Ubuntu 18.04 und es ist froxlor 0.9.40.1 installiert. Wir benutzen PHP-FPM und libnss-extrausers ist konfiguriert und aktiviert.
Grundsätzlich würde ich sagen, dass es nicht direkt an einer falschen Konfiguration liegt, da es die meiste Zeit fehlerfrei läuft. Alle paar Wochen bleibt er dann aber mal stecken.

Bei Google findet man ähnliche Fehler meist nur in Verbindung mit libnss-ldap und alle Fehler die ich hier im Forum gefunden habe, waren auf fehlerhafte Konfigurationen zurückzuführen.

Dieser Thread kommt der Sache glaube ich am Nächsten, allerdings scheint mir das trotzdem nicht der selbe Fehler zu sein.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Bei Extrausers braucht man Ansich kein nscd, schmeiß runter den Müll ;)

Share this post


Link to post
Share on other sites
  • 0
29 minutes ago, d00p said:

Bei Extrausers braucht man Ansich kein nscd, schmeiß runter den Müll ;)

Na das war einfach, danke!
Allerdings steht jetzt im cronjob "sh: 1: nscd: not found". Kann ich das ignorieren?

Share this post


Link to post
Share on other sites
  • 0

In 0.10.0 ist das bereits soweit behoben - folgende Änderungen sollten das auch in 0.9.41 beheben:

https://github.com/Froxlor/Froxlor/blob/0.9.x/scripts/froxlor_master_cronjob.php#L92 und https://github.com/Froxlor/Froxlor/blob/0.9.x/scripts/jobs/cron_tasks.php#L179 jeweils:

- if (Settings::Get('system.mod_fcgid') == 1 || (int)Settings::Get('phpfpm.enabled') == 1) {
+ if ((Settings::Get('system.mod_fcgid') == 1 || (int) Settings::Get('phpfpm.enabled') == 1) && Settings::Get('system.nssextrausers') == 0) {

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, d00p said:

In 0.10.0 ist das bereits soweit behoben - folgende Änderungen sollten das auch in 0.9.41 beheben:

https://github.com/Froxlor/Froxlor/blob/0.9.x/scripts/froxlor_master_cronjob.php#L92 und https://github.com/Froxlor/Froxlor/blob/0.9.x/scripts/jobs/cron_tasks.php#L179 jeweils:


- if (Settings::Get('system.mod_fcgid') == 1 || (int)Settings::Get('phpfpm.enabled') == 1) {
+ if ((Settings::Get('system.mod_fcgid') == 1 || (int) Settings::Get('phpfpm.enabled') == 1) && Settings::Get('system.nssextrausers') == 0) {

 

Damit funktioniert's. Nochmal vielen Dank.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...