Jump to content
Froxlor Forum
  • 0
MasterOfDeath

froxlor fgcid help needed

Question

Hello all,

I deleted my old debian 7 and updated everything to new versions. However some problems exists and i cannot access my webpages.

I did everything according to wiki pages and froxlor configurations but still some errors exists in below and not showing pages properly - only froxlor default page shown

● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: active (running) (Result: exit-code) since Tue 2019-04-16 23:48:14 +03; 53min ago
  Process: 4850 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS)
  Process: 5958 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=1/FAILURE)
  Process: 4858 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
 Main PID: 4862 (apache2)
    Tasks: 13 (limit: 4915)
   CGroup: /system.slice/apache2.service
           ├─4862 /usr/sbin/apache2 -k start
           ├─4863 /usr/sbin/apache2 -k start
           ├─4864 /usr/sbin/apache2 -k start
           ├─4867 /usr/sbin/apache2 -k start
           ├─4868 /usr/sbin/apache2 -k start
           ├─4869 /usr/bin/php-cgi -c /var/www/php-fcgi-scripts/froxlor.panel/v22000.local/
           ├─4874 /usr/sbin/apache2 -k start
           ├─4877 /usr/sbin/apache2 -k start
           ├─4878 /usr/sbin/apache2 -k start
           ├─4879 /usr/sbin/apache2 -k start
           ├─4880 /usr/sbin/apache2 -k start
           ├─4940 /usr/sbin/apache2 -k start
           └─5740 /usr/sbin/apache2 -k start

Apr 16 23:48:14 v2201412723521843 systemd[1]: Started The Apache HTTP Server.
Apr 17 00:33:51 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] rebuild configfiles due to changed setting
Apr 17 00:34:45 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] added user 'kaptan'
Apr 17 00:35:16 v2201412723521843 Froxlor[4869]: [Administrator Action admin] [information] added domain 'kaptan.xyz'
Apr 17 00:36:28 v2201412723521843 systemd[1]: Reloading The Apache HTTP Server.
Apr 17 00:36:29 v2201412723521843 apachectl[5958]: AH00543: apache2: bad user name kaptan
Apr 17 00:36:29 v2201412723521843 apachectl[5958]: Action 'graceful' failed.
Apr 17 00:36:29 v2201412723521843 apachectl[5958]: The Apache error log may have more information.
Apr 17 00:36:29 v2201412723521843 systemd[1]: apache2.service: Control process exited, code=exited status=1
Apr 17 00:36:29 v2201412723521843 systemd[1]: Reload failed for The Apache HTTP Server.
ls -al /var/customers/webs/
total 1494612
drwxr-xr-x 9 root  root        4096 Apr 17 00:36 .
drwxr-xr-x 6 root  root        4096 Apr 13 11:00 ..
-rw-r--r-- 1 root  root  1530439729 Apr 12 20:09 all_backup.zip
drwxr-x--- 3 10009 10009       4096 Apr 17 00:39 kaptan
drwxr-x--- 7 10002 10002       4096 Apr 13 18:41 kaptans
drwxr-xr-x 8 root  root        4096 Apr 13 18:55 NOTactiveWEB
drwxr-x--- 3 10007 10007       4096 Apr 14 19:24 test

 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

forgot to setup/configure libnss-mysql or libnss-extrausers?

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, MasterOfDeath said:

libnss-extrausers configured as per direction in system>configuration

and also activated explicitly in the settings? Froxlor needs to know whether you are using libnss-extrausers or not...

Share this post


Link to post
Share on other sites
  • 0
31 minutes ago, d00p said:

and also activated explicitly in the settings? Froxlor needs to know whether you are using libnss-extrausers or not...

just activated from system>settings>system settings

 

fgcid0.JPG

fgcid1.JPG

fgcid2.JPG

fgcid3.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By tmuecksch
      Guten Tag,
      ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000.
      Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen.
       
      Liebe Grüße
      tmuecksch
    • By veto
      have now successfully a default froxlor + apache2 + mod_apache + php7  running.
      the problem is now that some php webapps are not supporting php7.
      i read the debian9 can run multiple php version 
      and i installed php 5.6 with
      apt-get install apt-transport-https curl https://packages.sury.org/php/apt.gpg | apt-key add - echo 'deb https://packages.sury.org/php/ stretch main' > /etc/apt/sources.list.d/deb.sury.org.list apt-get update https://pehapkari.cz/blog/2017/03/27/multiple-php-versions-the-easy-way/
      the manual is for nginx.
      i want now to run all virtual host with the default mod_php apache2 setting from froxlor but for some virtualhosts
      use another php handler like  php5.6-cgi or php5.6-fmp.
      there so many different setting possible and with the decaying search quality it difficult to find a staring point
       
       
       




×
×
  • Create New...