Jump to content
Froxlor Forum
  • 0
pquerner

Cannot bind to :443 (or :80)

Question

Hey,

 

I am running Ubuntu 16.x with froxlor v0.9.40.1 (DB: 201809280) and recently updated apache2 from 2.4.18 to 2.4.38 with ppa:ondrej/apache2. (Because I wanted to support http2 for my sites)
Since then whenever the apache config files are rewritten, I get the issue that apache cannot bind to :80 or :443, because of a duplicate "Listen" command in a config file:

 

cat apache2/sites-enabled/10_froxlor_ipandport_xxx.conf
# 10_froxlor_ipandport_xxx.conf
# Created 13.03.2019 23:01
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

#Listen xxxx:80
<VirtualHost xxx:80>
DocumentRoot "/var/www/html/"
 ServerName xxx
Options -Indexes
</VirtualHost>

 

(I manually disabled that Listen command, so apache can restart in both port 80 and 443 .conf files)

I enabled "HTTP2" , does that have something to do with that, perhaps? Is there a way to disable that behaviour?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Login as admin, edit IP/Port entries and uncheck "Create Listen" :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...