Jump to content
Froxlor Forum

pquerner

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About pquerner

  • Rank
    Froxie
  1. Damn that was fast. I was just looking at the wrong end. Thank you.
  2. Hey, I am running Ubuntu 16.x with froxlor v0.9.40.1 (DB: 201809280) and recently updated apache2 from 2.4.18 to 2.4.38 with ppa:ondrej/apache2. (Because I wanted to support http2 for my sites) Since then whenever the apache config files are rewritten, I get the issue that apache cannot bind to :80 or :443, because of a duplicate "Listen" command in a config file: cat apache2/sites-enabled/10_froxlor_ipandport_xxx.conf # 10_froxlor_ipandport_xxx.conf # Created 13.03.2019 23:01 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. #Listen xxxx:80 <VirtualHost xxx:80> DocumentRoot "/var/www/html/" ServerName xxx Options -Indexes </VirtualHost> (I manually disabled that Listen command, so apache can restart in both port 80 and 443 .conf files) I enabled "HTTP2" , does that have something to do with that, perhaps? Is there a way to disable that behaviour?
  3. Mh, das finde ich etwas blöde. Denkst du es wäre möglich PHP-FPM auch die Multiconf beizubringen (wie fcgid)?
  4. Wo würde ich den Custom FPM Reload Command dann angeben? In den FPM Einstellungen gibt es ja nur ein Feld dazu, und das gilt gleich "global" ?
  5. Laut dem Blogeintrag hier: https://www.thomaschristlieb.de/mehrere-php-versionen-auf-einem-linux-server-mit-php-fpm/ geht das. Nur ginge das einfacher mit Templates o,ä, (oder halt PHP Konfiguration), wo ich den SetHandler selbst setzen kann. Leider setzt Froxlor ja direkt den Socket in die VHOST Datei, also dürfte das nicht automatisch funktionieren. (Nur wenn ich das manuell nachkonfiguriere)
  6. Hallo, ich habe nach angepasster Anfrage (https://github.com/Froxlor/Froxlor/wiki/apache2-with-php-fpm) und einigen Foreneinträgen es hinbekommen, PHP-FPM zu installieren. Nun verstehe ich allerdings nicht, wie ich pro VHOST Konfigurieren kann, welche PHP Version zu benutzen ist. Als Admin sehe ich im Dashboard den Menueintrag "PHP-Konfiguration" und dort die "PHP-Binary". Allerdings ist diese nicht für mich einstellbar. Das Feld taucht beim erstellen und beim editieren einer Konfiguration nicht auf und wird wohl dann auf den Standardwert "/usr/bin/php-cgi" gesetzt. Mein Dashboard läuft auf PHP7-fpm und meine Kundendomains auf PHP5.6-fpm. (Einer soll auch auf PHP5.6 laufen, die anderen können ruhig auf PHP7.1 sein) Froxlor-Version: 0.9.38.7 (DB: 201612110) -Pascal
  7. @doop you should add to the announcement that php5-curl is absolutely needed for Lets Encrypt. Might save some support threads in the future?
  8. Think of the Magento Shop Event System. In some classes you'll find the Event Dispatcher, which dispatches a current event (say "customer_logged_in" (example, may not exist)) and with it, it'll ship the current context with it. (probably the class itself $this). The event dispatcher iterates through configurated plugins/modules/extensions (whatever name you want to use) and executes their logic. Pros - multiple extensions can use the hook/xclass/event - ... Cons - first come, first serve. Second in line will get already altered data. (Magento will allow you to specify dependencies in your modules configuration so you may be loaded before/after module XY) - ...
  9. Okay, doofer Zufall. Danke. Gru?
  10. Moin, teilweise habe ich Probleme die Seite zu erreichen. Ein Ping habe ich noch nicht abgesetzt, ob ?berhaupt was durchgeht. Betroffen ist dann aber das Wiki, das Forum, der Bugtracker und die Hauptseite. Liegt das Problem bei mir? Gru?
  11. Hello, I have an app in /var/customers/webs/<customer>/<some-app>/web/app.php and I'd like to subdomain that dir to someapp.domain.com. However, when I edit the path to that subdomain to the app.php, Froxlor always adds a trailing slash and therefore it thinks that app.php is a directory. Cronjob output mkdir: cannot create directory `/var/customers/webs/c/c.de/app/web/app_dev.php/': File exists cp: accessing `/var/customers/webs/c/paskl.de/app/web/app_dev.php/': Not a directory chown: cannot access `/var/customers/webs/c/c.de/app/web/app_dev.php/': Not a directory Reproduce: 1) Add subdomain 2) Upload app do that dir 3) Change path of that subdomain to change path to /web/app.php 4) Save When in the dashboard (after save) again, you'll already see the slash behind app.php Froxlor is version 0.9.32-1+squeeze1 I'm running it on a Ubuntu Server 12.04 Apache is 2.4.10 Thanks
  12. Es lag wohl an einem manuellem Eintrag in meiner crontab Datei. Dort hatte ich die Cron-php mit dem Parameter --force aufrufen lassen..
  13. Hey, I see in error.log of apache2 that it tries to restart every minute (which I dont think should be, as I only rewrite config files every 5 minutes and why would one want to restart apache2 that often? Whats the upside if in the middle of the night no config changes were apply. I think it should only be forced to restart when some config files actually have been changed (md5 hash?))) and often times collapse. By that I mean that when the config files are yet to be written (froxlor cron to rewrite configs) and apache2 tries to restart: it cannot find some files (meaning some *.conf files in */sites-available) and therefore dies silently. After that, apache is dead and never tries to restart again. How may I patch this behaviour? (Do I have to set up manually an cronjob on every 10 minutes which restarts apache?) Thanks! -- Hey, im error.log von apache2 sehe ich h?ufig, dass versucht wird den Apache2 jede Minute neu zu starten. (Hier glaube ich schon, dass dies unn?tig ist, da ich jede 5 Minuten Konfigurationsdateien schreiben lasse und: warum sollte man den Apache2 so h?ufig neustarten wollen? (Es seidenn es hat sich wirklich was an den Konfigurationsdateien ver?ndert: md5 hash?!)) Wenn nun Apache2 neugestartet werden m?chte/wird/soll und der Cron von Froxlor anspringt und Konfigurationsdateien neu schreibt --> findet apache manchmal irgendwelche *.conf Dateien nicht und stirbt weg. (Und versucht sich dadurch nicht erneut neu zustarten) Wie kann ich dieses Problem l?sen (evtl. mit einem eigenen Cron der Apache alle 10 Minuten neustartet?! (Siehe Problem von oben))? Gru? Log:
×
×
  • Create New...