Jump to content
Froxlor Forum
  • 0
stefjoe

<VirtualHost> directive requires additional arguments

Question

Hallo,

nachdem ich Letsencrypt versucht habe einzurichten, erhalte ich folgende Meldung, nach einem Apache restart:

<VirtualHost> directive requires additional arguments

 

Es fehlt die IP in der normalen .conf

 

<VirtualHost >
  ServerName api.XXX.de
  ServerAlias *.api.XXX.de
  ServerAdmin XXXXXXX
  DocumentRoot "/var/customers/webs/XXX/api/public/"
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f XXXXXXX"
  php_admin_value open_basedir "/var/customers/webs/XXX/api/public:/tmp"
  Alias /webalizer "/var/customers/webs/XXX/webalizer"
  ErrorLog "/var/customers/logs/XXX-error.log"
  CustomLog "/var/customers/logs/XXX-access.log" combined
</VirtualHost>

 

Jetzt habe ich auf nichts mehr Zugriff. Muss ich in der DB die IP irgendwo eintragen? Wenn ja wo?

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

K.a. was du da getrieben hast, aber nach einer Standard Installation ist das was du da zeigst gar nicht Möglich - du hast mindestens eine IP 

Share this post


Link to post
Share on other sites
  • 0

Wüsste nicht in welchem Part dieses howtos auf einmal die IP Adressen ausm vhost verschwinden...

11 minutes ago, stefjoe said:

Die Apache logs sind leer.

Sorry, aber das bezweifel ich stark...

Ausgabe von "systemctl status apache2"

Share this post


Link to post
Share on other sites
  • 0
vor einer Stunde schrieb d00p:

Wüsste nicht in welchem Part dieses howtos auf einmal die IP Adressen ausm vhost verschwinden...

Sorry, aber das bezweifel ich stark...

Ausgabe von "systemctl status apache2"

Gibt mir sowas aus:

 

● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2019-03-10 17:24:37 CET; 2h 50min ago
  Process: 20946 ExecStop=/usr/sbin/apachectl stop (code=exited, status=1/FAILURE)
  Process: 20892 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=1/FAILURE)
  Process: 21513 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
 Main PID: 20219 (code=exited, status=0/SUCCESS)

Mär 10 17:24:37 v22019027810883731 systemd[1]: Starting The Apache HTTP Server...
Mär 10 17:24:37 v22019027810883731 apachectl[21513]: AH00526: Syntax error on line 6 of /etc/apache2/sites-enabled/30_froxlor_normal_vhost_api.geccom-media.de.conf:
Mär 10 17:24:37 v22019027810883731 apachectl[21513]: <VirtualHost> directive requires additional arguments
Mär 10 17:24:37 v22019027810883731 apachectl[21513]: Action 'start' failed.
Mär 10 17:24:37 v22019027810883731 apachectl[21513]: The Apache error log may have more information.
Mär 10 17:24:37 v22019027810883731 systemd[1]: apache2.service: Control process exited, code=exited status=1
Mär 10 17:24:37 v22019027810883731 systemd[1]: Failed to start The Apache HTTP Server.
Mär 10 17:24:37 v22019027810883731 systemd[1]: apache2.service: Unit entered failed state.
Mär 10 17:24:37 v22019027810883731 systemd[1]: apache2.service: Failed with result 'exit-code'.

 

Share this post


Link to post
Share on other sites
  • 0

Ja dann hast du wohl - wie auch immer - keine IP Adressen in deiner froxlor Installation. Du hättest ja ohne IPs niemals eine Domain anlegen können. Lösche alle froxlor generierten vhost Dateien aus /etc/apache2/sites-enabled/ und starte Apache neu, dann solltest du via http://IP/froxlor wieder auf froxlor kommen und deine IPs da anlegen. Musst natürlich dann alle domains Noch anpassen das das wieder stimmt.

 

Share this post


Link to post
Share on other sites
  • 0

Ok, das habe ich alles hinbekommen. Zertifikat is valid, aber ich erhalte jetzt. Crons habe ich durchlaufen lassen und bekomme keine Fehlermeldungen. SSL ist auch aktiviert a2enmod ssl , Logs sind leer

ERR_SSL_PROTOCOL_ERROR

 Das habe ich auch schon versucht, Fehlermeldung bleibt aber

 

// private key und csr erstellen

openssl req -new -newkey rsa:4096 -nodes -sha256 -out server-name.csr -keyout server-name.key
 

// selbst-signiertes cert erstellen

openssl x509 -req -days 3650 -in server-name.csr -signkey server-name.key -out server-name.crt

 

root@v22019027810883731:~# cat /etc/apache2/ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80

<IfModule ssl_module>
	Listen 443
</IfModule>

<IfModule mod_gnutls.c>
	Listen 443
</IfModule>

 

Share this post


Link to post
Share on other sites
  • 0

Hast du denn auch eine IP mit Port 443 und aktiviertem SSL erstellt? Und wenn, auch der Domain zugewiesen? Hast du denn Mal gegoogelt was die Meldung überhaupt bedeutet? 

Und ohne vhost-posts und vllt sogar mal einer Domain die es betrifft ist es einfach schwer ordentlich zu helfen...

Share this post


Link to post
Share on other sites
  • 0

Daran soll es nicht scheitern:

<VirtualHost 37.120.187.174:443>
  ServerName support.geccom-media.de
  ServerAlias www.support.geccom-media.de
  ServerAdmin XXX
  SSLEngine On
  SSLProtocol -ALL +TLSv1 +TLSv1.2
  SSLCompression Off
  SSLHonorCipherOrder On
  SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128
  SSLVerifyDepth 10
  SSLCertificateFile /etc/ssl/froxlor-custom/support.geccom-media.de.crt
  SSLCertificateKeyFile /etc/ssl/froxlor-custom/support.geccom-media.de.key
  SSLCACertificateFile /etc/ssl/froxlor-custom/support.geccom-media.de_CA.pem
  SSLCertificateChainFile /etc/ssl/froxlor-custom/support.geccom-media.de_chain.pem
  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=0"
  </IfModule>
  DocumentRoot "/var/customers/webs/geccom/support/public/"
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f XXX"
  Alias /webalizer "/var/customers/webs/geccom/webalizer"
  ErrorLog "/var/customers/logs/geccom-error.log"
  CustomLog "/var/customers/logs/geccom-access.log" combined
</VirtualHost>

 

 

<VirtualHost 37.120.187.174:80>
  ServerName support.geccom-media.de
  ServerAlias www.support.geccom-media.de
  ServerAdmin XXX
  <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge
    RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [R=301;L,NE]
  </IfModule>
  <IfModule !mod_rewrite.c>
    Redirect 301 / https://support.geccom-media.de/
  </IfModule>
</VirtualHost>

ssl1.jpg

ssl2.jpg

Share this post


Link to post
Share on other sites
  • 0

Wieso aktivierst du bei beiden IPs das Listen Statement? Deine Ports.conf macht das schon alles....

Share this post


Link to post
Share on other sites
  • 0

Habe ich rausgenommen und die Zeile in vhost geändert, jetzt läuft es:

 

<VirtualHost _default_:443>

 

Mir ist aber nicht ganz klar, ob das ein guter Weg ist, es läuft jetzt und das ist schonmal gut ?

Share this post


Link to post
Share on other sites
  • 0

Nö ist falsch und Quatsch, denn froxlor generiert die vhosts ja bei der nächsten Änderung oder neuen Domain neu...dann sind manuelle Änderungen weg. Ich verstehe auch nicht wieso da jetzt irgendwo _default_ steht. Du solltest doch IPs in froxlor eintragen....also irgendwas fummelst du da rum was ein helfen echt fast unmöglich macht. Sorry.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...