Jump to content
Froxlor Forum
  • 0
Pierre

Verzeichnisschutz für Kunden ist wo?

Question

Hallo,

wo finde ich den Verzeichnisschutz, sprich die .htaccess / htpasswd für ein Verzeichniss z.B. für die Kundendomain: 1234567.de/OpenIstZu?

Ich habe einen Verzeichnisschutz angelegt und komme seitdem nicht mehr als Froxlor Admin (nicht als Kunde) rein.

Ich kann mir leider auch keine neues Admin Pass zusenden lassen, da verweigert wird mit:

Fehler: unbekannter Benutzer

Eingabe für Benutzer und Email stimmen jedoch.

Vielen Dank für schnelle Hilfe

Pierre

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Verzeichnisschutz wird direkt mit in den vhost der Domain geschrieben.

Ich wüsste jetzt allerdings gern, was das anlegen eines verzeichnisschutzes und dem nicht mehr als Admin anmelden können zu tun haben soll...? 

Share this post


Link to post
Share on other sites
  • 0

Erst einmal Danke für die schnelle Rückmeldung und Antwort.

Was das mit dem Froxlor Admin zu tun haben soll, wüßte ich eben auch gerne.

Nur seit ich 2 Verzeichnisschutze angelegt habe, verweigert Froxlor und nun bin ich erst einmal für 900 Sek. gesperrt.

Share this post


Link to post
Share on other sites
  • 0

Also Verzeichnisschutz legst du als Kunde an, daher hat das schon Mal absolut null mit dem Admin zu tun. Und selbst wenn sorgt es sicher nicht dafür das du dich auf einmal nicht mehr einloggen kannst 

Share this post


Link to post
Share on other sites
  • 0

Du kannst direkt in der Datenbank ja das Passwort neusetzen, z.b.

UPDATE `panel_admins` SET `password` = MD5('neues-passwort') WHERE `adminid`=1;

Solltest du in den Einstellungen eine andere Hash Methode ausgewählt haben (Std. Ist SHA256) dann konvertiert froxlor das beim ersten Login

Share this post


Link to post
Share on other sites
  • 0

Guten Morgen,

wie bekomme ich die DB raus, die Froxlor auf dem gemieteten Dez.-Server (Apache2) nutzt, so dass ich via phpMyAdmin einen neuen Admin mit SQL-Befehl anlegen kann?

LG 

Share this post


Link to post
Share on other sites
  • 0

Warum solltest du das wollen? Du kannst via froxlor neue admins/reseller anlegen, rumspielen direkt in der datenbank ist niemals eine gute idee

Share this post


Link to post
Share on other sites
  • 0

Du erinnerst dich, bei mir hat es den Froxlor-Admin gelöscht (siehe oben), ich will sicher nicht spielen.

Nur der Hoster von dem ich den Dez.-Apache2-Server gemietet habe, will mir die DB nicht sagen die für Froxlor verwendet wird, er will Froxlor für 180,00 EUR updaten und das ist mir echt zu teuer.

Deshalb meine Frage an dich, wie ich raus bekomme, wie der DB-Name und der DB-User lauten, die Froxlor verwendet, so dass ich dann via phpMyAdmin über SQL-Befehl (der da wäre?) eine Admin anlegen kann?

Brauch ich, sonst kann ich keine neuen Kunden und Domains einrichten.

Merci !

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Pierre said:

Nur der Hoster von dem ich den Dez.-Apache2-Server gemietet habe, will mir die DB nicht sagen die für Froxlor verwendet wird, er will Froxlor für 180,00 EUR updaten und das ist mir echt zu teuer

LOL - na ich würde mal ganz schnell den Hoster wechseln....

1) die Datenbank und die dazugehörigen ZUgangsdaten stehen in froxlor/lib/userdata.inc.php

2) Froxlor updaten kannst du selbst, entweder via autoupdate ausm interface heraus oder auf shellebene -> https://github.com/Froxlor/Froxlor/wiki/Updating-Froxlor

3) Wieso phpMyAdmin? Hast du etwa keinen shell-zugang zu deinem Server??? Das solltest du aber definitiv wenn du da was betreiben willst

Share this post


Link to post
Share on other sites
  • 0

Hallo d00p,

jepp das sollte ich, die wenn 2 Min. am Dez.-Server was machen, wollen Sie schon 80,00 Euronen 😞

Also ich habe:  var/www/html/froxlor/lib/userdata.inc.php

brauch ich das normale SQL pass oder das root SQL pass?

Hast für mich bitte auch einen SQL-Befehl via phpMyAdmin damit ich den verlorenen Admin in der DB anlegen kann?

Besten Dank!

Share this post


Link to post
Share on other sites
  • 0

So leicht ist das jetzt nicht....hast du denn garkeinen admin-user mehr? Also ist wirklich der admin mit der id=1 gelöscht? Wie auch immer das passieren sollte wenn da nicht jemand seine finger im spiel hatte...das klingt mir alles sehr sehr sehr dubios

Share this post


Link to post
Share on other sites
  • 0

Also ich habe mir jetzt die DB via phpMyAdmin geschnappt und der Froxlor admin mit ID 1 ist doch noch vorhanden.

Habe dann den SQL-Befehl:

UPDATE `panel_admins` SET `password` = MD5('neues-passwort') WHERE `adminid`=1;

mit neuem bzw. dem alten Passwort ausgeführt, allerdings ohne Änderung und nun bin ich erst mal wieder für 900 Sek. gesperrt.

Keine Ahnung was das Teil hat, immer Fehler: unbekannter Benutzer

Share this post


Link to post
Share on other sites
  • 0

Kann ja schlecht sein, gibts du auch 100% den benutzernamen aus der tabelle ein? Also irgendwie machst du hier ganz merkwürdige sachen oder jemand spielt da an deinem froxlor code rum - so kann ich dir jedenfalls nicht wirklich helfen

Share this post


Link to post
Share on other sites
  • 0

Ich bekommen nach dem SQL-Befehl via phpMyAdmin folgende Meldung:

0 Datensätze betroffen. (Die Abfrage dauerte 0.0009 Sekunden.)

 

Share this post


Link to post
Share on other sites
  • 0

Ehm die meldung "unbekannter benutzer" erscheint nur beim PASSWORT VERGESSEN - bist du vllt garnicht im korrekten Login-Fenster????

Share this post


Link to post
Share on other sites
  • 0

Doch, Server-IP / froxlor

so bin ich immer rein.

Ich glaube das Teil hat Probleme den Benutz zu erkennen, sprich den adminid1 = admin

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Pierre said:

Ich bekommen nach dem SQL-Befehl via phpMyAdmin folgende Meldung:

 

sorry - ohne zu sehen was da sache ist kann ich nicht helfen....du machst komische sachen und dieser ganze server scheint mir sehr dubios 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Pierre said:

Doch, Server-IP / froxlor

 so bin ich immer rein.

Ich glaube das Teil hat Probleme den Benutz zu erkennen, sprich den adminid1 = admin

Glaub eher da sind ganz andere Ursachen das Problem....sorry, k.A. was du da treibst, aber ein standard setup ist das nicht und helfen kann ich dir mit so wenig info schon garrnicht

Share this post


Link to post
Share on other sites
  • 0

Hmmm… also ich habe von Hoster seinerzeit für den Froxlor Admin Login via Browser http://serverip/froxlor bekommen.

Ging ja auch bis vor eine paar Tagen immer. Plötzlich meckert Froxlor beim Benutzet und/oder Passwort.

Kann  ich dir vertraulich die Serverdaten wohin mailen? 

Share this post


Link to post
Share on other sites
  • 0
vor 2 Minuten schrieb d00p:

Glaub eher da sind ganz andere Ursachen das Problem....sorry, k.A. was du da treibst, aber ein standard setup ist das nicht und helfen kann ich dir mit so wenig info schon garrnicht

Also ich treibe nichts, nur deinen SQL UPDATE Befehl via phpMyAdmin eingeben, aber Froxlor mag nicht.

Share this post


Link to post
Share on other sites
  • 0

Also noch ist keine mail angekommen...willst du jetzt hilfe oder nicht?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...