Jump to content
Froxlor Forum
  • 0
princeofnaxos

Forced SSL on subdomain?

Question

Hi, 

I have a domain that is using SSL. Now I created a subdomain on this domain and created a redirect for it. The master cronjob now throws an error: "empty certificate file! Cannot create ssl-directives". Looking in the virtual host files, I see that there is a file called "29_froxlor_ssl_vhost_[mysubdomain].conf". Since the subdomain is a pure redirection, it should not use SSL. There is no need for it.

It seems as if subdomains automatically are marked to use SSL, if the main domain is. Since there is no way to add certificates to the subdomain other than via Let's Encrypt, I think that this is wrong. Or they should be added to the SANs automatically.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

1) exact steps to reproduce

2) nopaste of all corresponding vhosts

We need info for help... it's hard to reproduce without info. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...