Jump to content
Froxlor Forum
  • 0
Cr4zyFl1x

Froxlor neuinstalliert. | Was nun?

Question

Hallo,

ich habe nun Froxlor neu auf meinem Debian 8 System (ebenfalls neuinstallation) installiert. Ich habe den Installationsassistenten erfolgreich abgeschlossen (Da wo man die MySQL Verbindung angeben muss.).

Was muss ich nun noch alles machen damit ich Mehrere Vhosts anlegen kann und ich E-mails versenden kann?

LG Florian.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

Dann poste doch bitte noch was du gemacht hast, damit auch andere was davon haben

Share this post


Link to post
Share on other sites
  • 0

Bei einer solchen Reaktion würde ich fast dazu raten die Administration eines Servers einem Sys-Admin zu überlassen....du solltest schon wissen was du da tust. Und ganz ehrlich, da steht du sollst erst Einstellungen anpassen, DANN die Befehle ausführe...das ganze hab ich dir 3 minuten vor deiner Antwort geschrieben - sorry, du hast dir sicher nicht die Einstellungen anständig angeguckt...

Share this post


Link to post
Share on other sites
  • 0

Alles klar. Ich habe nun alles durchgelesen und Apache mit FCGID installiert. Bevor ich einen Shell Befehl aus 'Configuration' ausgeführt habe. 

Mit:

Zitat

Now copy and paste the actual configuration files from the Froxlor panel and apply them to your file system. You'll need the to create or update the following files (templates in your Froxlor panel in menu: "Configuration"):

ist doch jetzt aber gemeint, die Shell befehle aus "Configuration > Others > libnss-mysql" auszuführen oder? Und wenn brauche ich doch "libnss-extrausers" nicht mehr zu installieren oder?

Ich hoffe ich hab das jetzt nach mehrmaligem durchlesen verstanden.

Share this post


Link to post
Share on other sites
  • 0

Du brauchst einen Webserver, einen FTP Server, wenn aktiviert einen Nameserver, einen SMTP einen POP3/IMAP Server und dazu libnss-mysql ODER libnss-extrausers (wenn in den einstellungen aktiviert), sowie FCGID wenn du es nutzen willst

Share this post


Link to post
Share on other sites
  • 0

Alles das habe ich bis auf den Nameserver. Aber der ist in den Einstellungen auch deaktiviert. Also kann ich die Shell Befehle ausführen?

Share this post


Link to post
Share on other sites
  • 0

...nein? wieso willst du den einrichten wenn er doch deaktiviert ist und du ihn nicht nutzt?! Bisschen mitdenken, du ist sysadmin...

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, d00p said:

Du brauchst einen Webserver, einen FTP Server, wenn aktiviert einen Nameserver, einen SMTP einen POP3/IMAP Server und dazu libnss-mysql ODER libnss-extrausers (wenn in den einstellungen aktiviert), sowie FCGID wenn du es nutzen willst

genau lesen...und nochmal: mitdenken

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, d00p said:

sowie FCGID wenn du es nutzen willst

lesn und mitdenken, lesen und mitdenken, lesen und mitdenken....du willst FCGID -> daführ gibts die config-templates

Share this post


Link to post
Share on other sites
  • 0

Ja ich habe aber das Problem, dass die Domain, die standardmäßig vergeben wird nicht funktioniert. Also user.example.com müsste dann ja die seite des Kunden sein. Jedoch erscheint nur das Ordnerindex mit den Ordnern froxlor & webalizer

Share this post


Link to post
Share on other sites
  • 0

Da hast du wohl was falsch gemacht, das ist keine default webserver config mehr oder du hast deine Einstellungen nicht ordentlich vorgenommen.

Share this post


Link to post
Share on other sites
  • 0

Nun habe ich ein neues Problem. Ich habe den Smpt sowie IMAP/POP3 Server konfiguriert und eine E-Mail Addresse hinzugefügt MX Record der Domain stimmt soweit. Jedoch wenn ich versuche mich anzumelden bekomme ich immer die Fehlermeldung, dass das Passwort falsch sei.

Share this post


Link to post
Share on other sites
  • 0
Feb 26 16:43:26 VM01 dovecot: master: Error: systemd listens on port 993, but it's not configured in Dovecot. Closing.
Feb 26 16:49:23 VM01 dovecot: master: Error: systemd listens on port 993, but it's not configured in Dovecot. Closing.
Feb 26 17:14:15 VM01 dovecot: master: Error: systemd listens on port 993, but it's not configured in Dovecot. Closing.
Feb 26 17:19:11 VM01 dovecot: master: Error: systemd listens on port 993, but it's not configured in Dovecot. Closing.
Feb 27 12:24:46 VM01 dovecot: master: Error: systemd listens on port 993, but it's not configured in Dovecot. Closing.
Feb 27 12:30:16 VM01 dovecot: master: Error: systemd listens on port 993, but it's not configured in Dovecot. Closing.

Das ist der Error log.

Share this post


Link to post
Share on other sites
  • 0

Ja, jedoch haben mir die Seiten nicht weitergeholfen. Das es wahrscheinlich etwas mit der Konfiguration zu tun hat ist ja naheliegend, jedoch ist das Problem nicht gelöst worden.

 

Share this post


Link to post
Share on other sites
  • 0

Naja, ich hab schon einiges an Debian VMs mit Froxlor aufgesetzt...das ist ne Sache von 15 min und alles läuft. Also verstehe bitte, dass ich den Fehler nicht vorranging bei Froxlor und unseren Configs suche.

So, ich weiss zwar nicht was du gegoogelt hast, aber das erste ergebnis hilft doch schon. Nopaste bitte mal deine /etc/dovecot/conf.d/10-ssl.conf

Share this post


Link to post
Share on other sites
  • 0

Die /etc/dovecot/conf.d/10-ssl.conf:

##
## SSL settings
##

# SSL/TLS support: yes, no, required. <doc/wiki/SSL.txt>
ssl = no

# PEM encoded X.509 SSL/TLS certificate and private key. They're opened before
# dropping root privileges, so keep the key file unreadable by anyone but
# root. Included doc/mkcert.sh can be used to easily generate self-signed
# certificate, just make sure to update the domains in dovecot-openssl.cnf
#ssl_cert = </etc/dovecot/dovecot.pem
#ssl_key = </etc/dovecot/private/dovecot.pem

# If key file is password protected, give the password here. Alternatively
# give it when starting dovecot with -p parameter. Since this file is often
# world-readable, you may want to place this setting instead to a different
# root owned 0600 file by using ssl_key_password = <path.
#ssl_key_password =

# PEM encoded trusted certificate authority. Set this only if you intend to use
# ssl_verify_client_cert=yes. The file should contain the CA certificate(s)
# followed by the matching CRL(s). (e.g. ssl_ca = </etc/ssl/certs/ca.pem)
#ssl_ca =

# Require that CRL check succeeds for client certificates.
#ssl_require_crl = yes

# Directory and/or file for trusted SSL CA certificates. These are used only
# when Dovecot needs to act as an SSL client (e.g. imapc backend). The
# directory is usually /etc/ssl/certs in Debian-based systems and the file is
# /etc/pki/tls/cert.pem in RedHat-based systems.
#ssl_client_ca_dir =
#ssl_client_ca_file =

# Request client to send a certificate. If you also want to require it, set
# auth_ssl_require_client_cert=yes in auth section.
#ssl_verify_client_cert = no

# Which field from certificate to use for username. commonName and
# x500UniqueIdentifier are the usual choices. You'll also need to set
# auth_ssl_username_from_cert=yes.
#ssl_cert_username_field = commonName

# DH parameters length to use.
#ssl_dh_parameters_length = 1024

# SSL protocols to use
#ssl_protocols = !SSLv2

# SSL ciphers to use
#ssl_cipher_list = ALL:!LOW:!SSLv2:!EXP:!aNULL

# Prefer the server's order of ciphers over client's.
#ssl_prefer_server_ciphers = no

# SSL crypto device to use, for valid values run "openssl engine"
#ssl_crypto_device =

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...