Jump to content
Froxlor Forum
  • 0
wXXX

Froxlor VirtualHost Einstellungen lassen sich nicht speichern

Question

Hallo,
 
bekomme folgende
 
Fehlermeldung:
Unknown Error (not in option): system_mod_fcgid_defaultini_ownvhost
 
wenn ich die Froxlor VirtualHost Einstellungen speichern will.
 
Weiss nicht ab wann das nicht mehr geht,
denke ungefähr seit Einführung der Let's Encrypt für den Froxlor Vhost" Option.
Da wollte ich nämlich diese Einstellungen seit langem wieder speichern.
 
Einstellungen siehe Screenshot:
 
5a85f49de0a51_screencapture-de-admin_settings-php-1518727336155_LI(2).thumb.jpg.2ec40441fe6c7607301465a13dee044a.jpg
 
  • Froxlor version: 0.9.39.5
  • Web server: nginx
  • OS/Version: Ubuntu 16.04

 

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Hm, ja, du hattest wohl mal von fcgid auf php-fpm gewechselt, da hätte froxlor beim wechsel dafür sorgen müssen, dass das häkchen bei "Verwende fcgid im Froxlor-Vhost" verschwindet.

Quick-Fix: cron stoppen, häckchen bei "Verwende php-fpm im Froxlor-Vhost" rausnehmen (sonst bekommst du das gleiche Problem gleich beim Umstellen), fix nochmal auf FCGID umstellen, häkchen "Verwende FCGID im Froxlor-Vhost" rausnehmen, wieder auf php-fpm umstellen, Häkchen bei "Verwende php-fpm im Froxlor-Vhost" wieder rein und sollte auch speicherbar sein.

Wäre schön, wenn du mir da nen issue im github bugtracker aufmachst, dann fix ich das für die kommende version.

PS: um gottes willen stell das theme auf "Sparkle" :P Dieser uralt-schinken von "Classic/froxlor" theme ist schrecklich

Share this post


Link to post
Share on other sites
  • 0

Wie es gibt ein neues Theme? :rolleyes:

 

Das funktioniert leider nicht. Das Feld mit dem Haken bei "Verwende FCGID im Froxlor-Vhost"  ist ausgegraut/deaktiviert.

Kann da nichts umstellen.

Kann ich evtl. in der MySQL direkt an den Einstellungen was ändern?

Share this post


Link to post
Share on other sites
  • 0

Natürlich ist der ausgegraut, weil du php-fpm aktiv hast und nicht mehr fcgid...was glaubst du wieso ich dir so umständlich geschrieben habe wie du es ändern kannst?

Aber gut, dann halt per SQL:

UPDATE `panel_settings` SET `value` = '0' WHERE `settinggroup` = 'system' AND `varname`='mod_fcgid_ownvhost';

 

Share this post


Link to post
Share on other sites
  • 0

Danke, der Haken ist nun weg. Die Fehlermeldung bleibt.

Unknown Error (not in option): system_mod_fcgid_defaultini_ownvhost

 

Hat wohl was mit der default ini zu tun.

Hab da schon alle möglichen kombinationen durchprobiert eben.

Share this post


Link to post
Share on other sites
  • 0
SELECT id, description FROM panel_phpconfigs WHERE id='2';

kommt da was raus?

Share this post


Link to post
Share on other sites
  • 0

Default für das Feld ist id=2 (Froxlor Vhost default), froxlor sollte aber natürlich disabled-settings garnicht validieren, dazu kannst du mir bitte auch ein issue unter github aufmachen

Was du als temp. Lösung versuchen kannst, in der Datei actions/admin/settings/122.froxlorvhost.php zeile 140, aus der 2 eine 1 (oder 5 oder 6) machen schauen obs dann geht

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, schnudeldudel said:

Das gleich Problem hatte ich auch... 

Und hat es mit dem Fix auch geklappt? Bzw. vllt hast du ja sogar die aktuelle git-version getestet, da sollte das auch nicht mehr vorkommen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...