Jump to content
Froxlor Forum
  • 0
caroman

Konfiguration APACHE2.4

Question

Der Apache 2.4 in der neuen Debian Stretch Version bringt leider Änderungen mit sich, die in der vhost nachvollzogen werden müssen. Die beiden  'alten' Standardeinträge unter dem Tag   </FilesMatch> führen dazu, dass meine Rechte zur Darstellung der Webseite nicht mehr ausreichen, vgl. https://httpd.apache.org/docs/current/upgrading.html.

Da muss statt dessen ein 'Require all granted' rein. Wie ich Änderungen in Gestalt der Ergänzung des vhost files vornehme ist klar, nur, wie kann ich das Default-Template abändern, so dass die Änderung innerhalb des  <Directory "/var/customers/webs/007/meinedomain/">... </Directory> erfolgt?

Vielen Dank für die Antwort im Voraus ....

 

# 29_froxlor_normal_vhost_www.007.conf
# Created 12.12.2017 10:55
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 87 - CustomerID: 7 - CustomerLogin: 007
<VirtualHost xx.xxx.xx.40:80>
  ServerName www.domain.de
  ServerAlias *.www.meinedomain.de
  ServerAdmin mail@meinedomain.de
  DocumentRoot "/var/customers/webs/007/meinedomain/"
  FcgidIdleTimeout 30
  SuexecUserGroup "007" "007"
  <Directory "/var/customers/webs/007/meinedomain/">
    <FilesMatch "\.(php)$">
      SetHandler fcgid-script
      FcgidWrapper /var/www/php-fcgi-scripts/007/www.meinedomain.de/php-fcgi-starter .php
      Options +ExecCGI
    </FilesMatch>
    Order allow,deny
    allow from all

  </Directory>
  Alias /awstats "/var/customers/webs/007/awstats/www.meinedomain.de"
  Alias /awstats-icon "/usr/share/awstats/icon/"
  ErrorLog "/var/customers/logs/007-error.log"
  CustomLog "/var/customers/logs/007-access.log" combined
</VirtualHost>

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Na wie wärs dann wenn du in den Webserver-Einstellungen "Use modifications for Apache 2.4" aktivierst? Froxlor kann nicht wissen welchen Apache du nutzt :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...