Jump to content
Froxlor Forum
  • 0

Ansilbe Froxlor update


DaSilva
 Share

Question

Hey Leute,

gibt es eine Möglichkeit über Ansilbe bzw. generell über die Datenbank oder Dateien die Meldung

"Version of file doesn't match version of database. Exiting...

Possible reason: Froxlor update"

zu umgehen?

Derzeit ändere ich alle Server von der Apt repo zur Git repo und werde nach der Installation von Froxlor darum gebeten "Enable usage of libnss-extrausers?" zu definieren. Kann man dies auch anderweitig als über die Web Maske regeln?

 

Des weiteren wollte ich fragen ob es eine Möglichkeit gibt die Apt oder git repo voneinander zu unterscheiden, so dass nicht immer wieder ein clone, sondern ein pull ausgeführt wird, wenn schon git statt apt vorhanden ist.

Vielen Dank!

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 1
1 hour ago, DaSilva said:

gibt es eine Möglichkeit über Ansilbe bzw. generell über die Datenbank oder Dateien die Meldung

"Version of file doesn't match version of database. Exiting...

Possible reason: Froxlor update"

zu umgehen?

Macht keinen Sinn, denn die Datenbank benötigt ein Update...Datum ja die Meldung. 

1 hour ago, DaSilva said:

Derzeit ändere ich alle Server von der Apt repo zur Git repo und werde nach der Installation von Froxlor darum gebeten "Enable usage of libnss-extrausers?" zu definieren. Kann man dies auch anderweitig als über die Web Maske regeln?

Du kannst in den Einstellungen ein automatisches Update der DB via Cronjob aktivieren, ich rate allerdings ausdrücklich davon AB. Er nutzt so nur die von uns gewählten defaults die nicht zwingend auf dein System passen und im schlimmsten Fall dafür sorgen das nichts mehr geht!

 

1 hour ago, DaSilva said:

Des weiteren wollte ich fragen ob es eine Möglichkeit gibt die Apt oder git repo voneinander zu unterscheiden, so dass nicht immer wieder ein clone, sondern ein pull ausgeführt wird, wenn schon git statt apt vorhanden ist.

Git wird IMMER neuer oder mindestens gleich dem apt-paket/letzten release sein. Du solltest nicht beides nutzen. Entweder nimmst du git und machst halt immer mal wieder ein git pull (oder scriptest dir was - wie auch immer du lust hast) oder du verlässt dich ganz auf releases und nimmst immer das debian paket. Da kommt das update dann von allein. In jedem Fall solltest du dich nach einem Update der Dateien als admin in Froxlor einloggen und das Update durchführen

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...