Jump to content
Froxlor Forum
  • 0
yuuka

SSL deaktivieren

Question

Hallo, ja ich weiß, ich verwende eine alte Version und zwar "0.9.33.1".

Da mein SSL Zertifikat abgelaufen ist und Chrome nun nur noch Probleme mit meiner Seite macht, würde ich gerne SSL deaktivieren, für alle Webseiten und das Panel an sich.

Deaktiviere ich jedoch SSL in den Einstellungen, ist nach der Config Neuerstellung nichts mehr erreichbar.

Die alten Datein unter apache2/sites-enabled sind immer noch da und selbst nach manuellem löschen versucht froxlor immer noch über https aufgerufen zu werden.

Selbst mit einem selbst erstellten Cert lässt mich chrome nicht mehr auf die Seite, deswegen möchte ich dies ganz abstellen aber es scheint nicht zu funktionieren.

ich bitte um Hilfe >.<

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

als erstes mal: updaten

dann: "nichts mehr erreichbar" -> genaue fehlermeldung bitte

Share this post


Link to post
Share on other sites
  • 0

ich weiß, ich möchte nur vorher alles zum laufen bringen bevor ich update ;)

zum update, wenn ich wie gewohnt via aptiitude update ran gehe sagt er mir, dass der froxlor server nicht gefunden wurde um sich pakete zu ziehen, gibt es dafür eine neue ip / domain?

Zur fehlermeldung, es lässt sich die seite nicht aufrufen, da SSL aus is, da ich automatisch auf die https version geleitet werde egal von welchem brwoser aus.

Jedoch werde ich wenn SSL wieder an ist jedes mal auf https://froxlor.domain.de geleiteet und kann nicht via http://froxlor.domain.de zugreifen.

Share this post


Link to post
Share on other sites
  • 0

die frage ist, WIE mache ich den raus ;) selbst wenn ich ssl in den einstellungen ausmache leitet es mich weiterhin auf https >.<

Share this post


Link to post
Share on other sites
  • 0

Im Zweifel:

- crond stoppen

- alle von Froxlor generierten Webserver configs löschen

- Webserver neustarten

- via IP/froxlor auf froxlor zugreifen

Share this post


Link to post
Share on other sites
  • 0

naja aber du meintest, dass es geht  denredirect rauszunehmen und ich denke, das irgendwas bei froxlor (evtl. in ner config) das automatisch auf https weiterleitet

Share this post


Link to post
Share on other sites
  • 0

Dann Folge doch bitte einfach dem was ich geschrieben habe - dann kannst du alle Einstellungen in froxlor anpassen die du möchtest...

Share this post


Link to post
Share on other sites
  • 0

ich kann auf dfas panel zugreifen, da der internetexplorer nicht so streng mit self signed ssl certs ist ;) aber ich finde die option nirgends

Share this post


Link to post
Share on other sites
  • 0

Wenn du von Froxlor selbst redest: da gibt es kein Häkchen für den SSL Redirect, das warst du dann wohl selbst (.htaccess oder "eigene vhost einstellungen" o.Ä.). Ansonsten die entsprechende Domain bearbeiten und "SSL Redirect" deaktivieren

Share this post


Link to post
Share on other sites
  • 0

Das ist sehr merkwürdig, zumal ich keine .htaccess datei im froxlor ordner liegen habe.

Ich habe eine andere domain angelegt, die in das verzeichnis leitet, diese wird ebenfalls auf https redirected -.-

Share this post


Link to post
Share on other sites
  • 0

Dann schau doch bitte mal durch deine Configs, gib und mal ein paar Infos zum Arbeiten, vhosts, logs, irgendwas

Share this post


Link to post
Share on other sites
  • 0

so also ich habe eine .htaccess datei im verzeichnis gefunden, welche via shell nicht sichtbar war -.-

Ich bin nun in der lage das interface via dem Internet Explorer aufzurufen, jedoch wenn ich nur cp.domain.de aufrufe werde ich trotzdem auf https weitergeleitet, verwende ich jedoch z.b. so etwas "cp.domain.de/index.php?s=47f4a3ef025aeb547777831119bad1d9&script=admin_index.php&qrystr=s%3D47f4a3ef025aeb547777831119bad1d9" dann funktioniert es. jedoch leitet mich chrome direkt wieder auf https weiter -.- egal was ich eingebe. ich frage mich einfach nur warum? ssl ist im panel deaktiviert, in sites-enabled sind keine ssl vhosts mehr, ssl ip gelöscht und panel auf den neusten stand geupdatet.

Nach dem update des panels hatte ich folgendes in der shell:

http://<YOURIP>/froxlor/
Trigger für libapache2-mod-php5 werden verarbeitet ...
Action 'configtest' failed.
The Apache error log may have more information.
Your apache2 configuration is broken, so we're not restarting it for you.

Apache2 war jedoch trotzdem gestartet.

Wenn du logs möchtest, sag mir bitte in welchen ich anhaltspunkte dazu finde :)

 

Was mir auch noch aufgefallen ist, wenn ich die seite via ip aufrufe, geht es nun mit chrome, jedoch nicht mit der domain.

Und Problem gelöst ... wenn man beim löschen der browserdaten mal genauer hinschauen würde, würde man merken, dass chrome auf daten von vor einer stunde eingestellt war -.- 

Share this post


Link to post
Share on other sites
  • 0

so also ich habe eine .htaccess datei im verzeichnis gefunden, welche via shell nicht sichtbar war -.-

Das Zauberwort auf der shell heisst:

ls -la 
Jedenfalls kommt die nicht von Froxlor, wir legen keine .htaccess im Froxlor verzeichnis ab.

 

Nach dem update des panels hatte ich folgendes in der shell:

http://<YOURIP>/froxlor/
Trigger für libapache2-mod-php5 werden verarbeitet ...
Action 'configtest' failed.
The Apache error log may have more information.
Your apache2 configuration is broken, so we're not restarting it for you.
Apache2 war jedoch trotzdem gestartet.

 

Das apache noch läuft ist ja okay, wenn er aber nicht neustartet musst du halt mal in die Syslog und/oder apache-error.logs gucken warum das so ist

 

Was mir auch noch aufgefallen ist, wenn ich die seite via ip aufrufe, geht es nun mit chrome, jedoch nicht mit der domain.

http://domain.tld/froxlor müsste gehen - du hast ja alle vhosts gelöscht, alles zeigt auf /var/www/, genau wie die IP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...