Jump to content
Froxlor Forum
  • 0
Netsurfer

PHP-Konfigurationen und OPcache Einstellungen

Question

Hallo zusammen!
 
Bevor ich ggf. eine Bugmeldung verfasse, wollte ich erst mal nachhören, ob es sich wirklich um einen allgemeinen Bug handelt, oder ob nur bei mir etwas falsch läuft?
Und zwar werden bei mir Einstellungen zum OPcache, die ich in den PHP-Konfigurationen vornehme, (teilweise) nicht übernommen.
 
Ich habe installiert:
Froxlor 0.9.36 (war auch vorher mit 0.9.35-1 schon so)

FPM-FCGI
PHP: 5.5.33-1~dotdeb+7.1

 

Auszug aus der PHP-Konfiguration:

variables_order = "GPCS"
opcache.interned_strings_buffer = 16M
opcache.restrict_api = "{DOCUMENT_ROOT}"

Auszug aus der betreffenden php.ini:

php_admin_value[variables_order] = "GPCS"
php_admin_value[opcache.restrict_api] = "/var/www/froxlor/"

Gilt für alle PHP-Konfigurationen bei mir.

 

Aktuell habe ich den Wert in der Master php.ini entsprechend gesetzt.

 

Kann das jemand so nachvollziehen, oder habe ich bei mir einen "Fehler im System"?

 

Gruß

Gunther

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Müsst ich genauer nachschauen, normal holt er sich als wert dafür ja den kunden-docroot

Share this post


Link to post
Share on other sites
  • 0

Nein, Missverständnis.

 

Der Eintrag mit dem Docroot wird übernommen. Aber der andere (opcache.interned_strings_buffer = 16M) nicht.

Share this post


Link to post
Share on other sites
  • 0

Ah, DAS meintest du, ja das liegt daran das ich das nicht hinterlegt habe für fpm, wenn du mir sagst was du da alles so brauchst kann ich das gerne einfügen

Share this post


Link to post
Share on other sites
  • 0

Hi!

Ich habe mich zwar noch nicht bis ins Letzte mit OPcache auseinandergesetzt, aber momentan denke ich, dass insbesondere die Eigenschaften, die tatsächlich u.a. von der Größe (Anzahl Files) der jeweiligen Domain abhängen, besonders wünschenswert sind.
Hier eine kurze Liste:

opcache.revalidate_freq=
opcache.validate_timestamps=
opcache.max_accelerated_files=
opcache.memory_consumption=
opcache.interned_strings_buffer=
opcache.fast_shutdown=

Ach ja, und ob er überhaupt aktiviert sein soll oder nicht.

Also auch noch:

opcache.enable=

Besten Dank!

 

Wenn dir noch eine sinnvolle und hilfreiche Einstellung einfällt ...

Share this post


Link to post
Share on other sites
  • 0

Am besten auch als Feature-request in den bugtracker, das geht sonst unter hier

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...