Jump to content
Froxlor Forum
  • 0
xgamer224

The domains I add go to the root web server directory

Question

Every time I add a domain,

It will load up the root directory of apache (/var/www/web) It also wont even make a new directory for the website..

any ideas? 

 

 

il0zULK.png

 

 

Im assuming it has something to do with permissions..

 

thanks for your help!

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
 
I did set up cron.

I just attempted to force the cronjob script to run by typing: 

/usr/bin/php5 /var/www/froxlor/scripts/froxlor_master_cronjob.php --force 

but after i ran this, I got a "refused to connect" error when attempting to access any part of my website.

I assumed I just had a configuration issue so i just reinstalled the OS and started from scratch.

I reconfigured everything again by following this tutorial. I recreated the domain just like i did last time.

it still went to my base directory. (/var/www/)

so i decided to try to force the cronjob again.

Now im getting a "refused to connect" error yet again.

 

 

When I try to restart apache2, i get the following:

 * Restarting web server apache2                                                (98)Address already in use: AH00072: make_sock: could not bind to address 192.210.140.251:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

nothing relevant in logs (because the service cant open the log file.

ran netstat to see what processes are listening on my ports:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      2781/mysqld
tcp        0      0 192.210.140.251:53      0.0.0.0:*               LISTEN      9013/named
tcp        0      0 192.210.140.250:53      0.0.0.0:*               LISTEN      9013/named
tcp        0      0 127.0.0.2:53            0.0.0.0:*               LISTEN      9013/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      9013/named
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      562/sshd
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      12907/master
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      9013/named
tcp6       0      0 :::21                   :::*                    LISTEN      13250/proftpd: (acc
tcp6       0      0 :::53                   :::*                    LISTEN      9013/named
tcp6       0      0 :::22                   :::*                    LISTEN      562/sshd
tcp6       0      0 :::25                   :::*                    LISTEN      12907/master
tcp6       0      0 ::1:953                 :::*                    LISTEN      9013/named
udp        0      0 192.210.140.251:53      0.0.0.0:*                           9013/named
udp        0      0 192.210.140.250:53      0.0.0.0:*                           9013/named
udp        0      0 127.0.0.2:53            0.0.0.0:*                           9013/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                           9013/named
udp6       0      0 :::53                   :::*   

nothing is running on port 80

 

any ideas?

Share this post


Link to post
Share on other sites
  • 0

You are missing a "Listen" in your apache configs (either globally in apache2.conf "Listen 80" or check the "Create Listen-Statement" checkbox when editing the ip/port in froxlor)

Share this post


Link to post
Share on other sites
  • 0

I check the "Create Listen-Statement"

but still the same!

Did the cronjob run and update the vhost files? What is the exact error message?

Share this post


Link to post
Share on other sites
  • 0

Yes, i run by typing cronjob script: /usr/bin/php5 /var/www/froxlor/scripts/froxlor_master_cronjob.php --force 

In the folder /etc/apache2/sites-enabled contain the file of this domain  automatically created for the cronjob script

and I check the "Create Listen-Statement"

 

but when i enter in the domain, launch de message Error 404!

like no connection with the domain.

 

I just enter 2 new domains and do the same

Share this post


Link to post
Share on other sites
  • 0

404 means "not found"...nothing else. Did you configure froxlor correclty? Adjust settings then follow the configuration templates for all used services.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...