Jump to content
Froxlor Forum
  • 0
v3ng

Probleme mit Froxlor

Question

Hallo,

 

Seit heute Nacht bekomme ich Emails von meinem Server mit folgendem Inhalt:

chown: ?ndern des Eigent?mers von ?/var/www/php-fcgi-scripts/Thunderbyte/Thunderbyte.domain.de/php-fcgi-starter?: Die Operation ist nicht erlaubt
chattr: Datei oder Verzeichnis nicht gefunden beim Auslesen des Status von /var/www/php-fcgi-scripts/Username/Username.domain.de/php-fcgi-starter
Hat jemand eine Idee wodurch das verursacht sein k?nnte und wie ich das beheben kann?

 

Vielen Dank! :)

 

EDIT: ich habe gestern ein paar Pakete entfernt, die eigentlich aber nichts mit Froxlor zu tun haben. Eventuell wurde da ja dennoch eine Wichtige Abh?ngigkeit entfernt. Nur wei? ich nicht, wenn ja, welche

 

EDIT 2: ich bekomme solche Meldungen zu jedermann meiner Kunden in den Mails.

Edited by Thunderbyte

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Aus dem Kopf kann ich dir nicht sagen was genau du vielleicht gel?scht haben k?nntest. ?berpr?fe die Logs deines Package-Managers ob du etwas gel?scht hast was mit php-fcgi zu tun hat. Eventuell wurde auch einfach durch das deinstallieren von irgendeinem Paket ein config-File ver?ndert.

Share this post


Link to post
Share on other sites
  • 0

Postfix wurde gestern mit Deinstalliert, das habe ich aber gleich wieder installiert und die Configs dementsprechend wieder erstellt.

Aber danke f?r den Tipp, ich werde mal nachschauen.

Share this post


Link to post
Share on other sites
  • 0

Ich habe vermutlich folgende Pakete entfernt: 

apt-get purge proxmox-ve-2.6.32 ntp ssh lvm2 postfix ksm-control-daemon vzprocps open-iscsi bootlogd

Share this post


Link to post
Share on other sites
  • 0

LOG: 

Log started: 2015-08-28  01:45:44
(Lese Datenbank ... 56821 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von bsd-mailx ...
L?schen der Konfigurationsdateien von bsd-mailx ...
Entfernen von vzctl ...
Stopping OpenVZ: ..done
L?schen der Konfigurationsdateien von vzctl ...
Entfernen von pve-manager ...
L?schen der Konfigurationsdateien von pve-manager ...
dpkg: Warnung: W?hrend Entfernens von pve-manager ist Verzeichnis ?/var/lib/pve-manager? nicht leer, wird daher nicht gel?scht
dpkg: Warnung: W?hrend Entfernens von pve-manager ist Verzeichnis ?/var/lib/vz/template/cache? nicht leer, wird daher nicht gel?scht
dpkg: Warnung: W?hrend Entfernens von pve-manager ist Verzeichnis ?/var/log/pveproxy? nicht leer, wird daher nicht gel?scht
Entfernen von qemu-server ...
L?schen der Konfigurationsdateien von qemu-server ...
Entfernen von libpve-storage-perl ...
Entfernen von clvm ...
L?schen der Konfigurationsdateien von clvm ...
Entfernen von lvm2 ...
L?schen der Konfigurationsdateien von lvm2 ...
Entfernen von postfix-mysql ...
Entfernen von postfix ...
Stopping Postfix Mail Transport Agent: postfix.
L?schen der Konfigurationsdateien von postfix ...
Trigger f?r man-db werden verarbeitet ...
Trigger f?r pve-firewall werden verarbeitet ...
Restarting Proxmox VE firewall: pve-firewall.
Log ended: 2015-08-28  01:46:11

Share this post


Link to post
Share on other sites
  • 0

Sagt halt alles nichts zu php-fcgi aus. W?re intressant, WANN die Meldung kommt. Alle 5 Minuten? Dann ist's der Froxlor-Cron. Ansonsten hat's mit Froxlor wohl her nix zu tun.

Share this post


Link to post
Share on other sites
  • 0

Wenn du die Fehlermeldung per Mail bekommst wird doch noch was im Betreff und als Absender stehen nehm ich an?

Share this post


Link to post
Share on other sites
  • 0

Ach tut mir leid, hatte ich ganz vergessen mit anzuh?ngen. Scheint aber wohl doch der Froxlor Cron zu sein

Cron <root@web> /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Share this post


Link to post
Share on other sites
  • 0

1) Wieso hast du scheinbar im Cronfile den Cronjob mit --force eingerichtet? Wie sieht deine /etc/cron.d/froxlor ansonsten so aus?

 

3) Kontrollier bitte nochmal alle deine config-files und und setz zur Sicherheit auch die Verzeichnisrechte lt. Froxlor neu.

Share this post


Link to post
Share on other sites
  • 0
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null
0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null
7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null
10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null
0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null

Das war mein Fehler, ich hatte, als ich mal etwas getestet habe den Cronjob nochmal manuell in crontab eingetragen, der jede Minute ausgef?hrt wird. 

Hatte ich wohl vergessen anschlie?end wieder zu l?schen.

Share this post


Link to post
Share on other sites
  • 0

Bis jetzt scheinbar noch nicht. Scheint zu funktionieren. Danke schonmal :)
Aber irgend einen Grund hat es ja, dass er mir das Meldet. 

 

Ich nutzte Apache 2.2 + PHP 5.5 + FCGID. 
Welche Pakete werden denn daf?r alle ben?tigt? Eventuell fehlt ja eins.

Die Pakete, die im Interface unter FCGID angegeben sind, sind alle installiert.

Share this post


Link to post
Share on other sites
  • 0

Alle oben genannten Pakete waren schon installiert. 

Hmm das kann sein, w?re aber komisch, dass es genau jetzt passiert. Und die Fehlermeldung deutet in meinen Augen auch nicht darauf hin.

Share this post


Link to post
Share on other sites
  • 0

Fakt ist, dass die Meldung nicht mehr kommt. Wieso die aufgetreten ist kann ich dir nicht erkl?ren. Froxlor funktioniert ja sonst normal oder?

Share this post


Link to post
Share on other sites
  • 0

Ok, doch. Es gab probleme mit der Bind Namensaufl?sung. Neue Kunden wurden beim Aufruf ihrer Subdomain auf den Documentroot des Hostsystems weitergeleitet. 

Konnte ich aber durch eine Neuinstallation von Bind und Neugenerieren der Konfigs l?sen.

 

Btw: Was macht eigentlich die Option --force bei dem Cronjob?

Share this post


Link to post
Share on other sites
  • 0

"--force" einsetzen und nicht mal wissen was es macht. Jajaja ;)

 

--force macht im Prinzip das Fleiche wie wenn du im Panel auf "Configs neu schreiben" klickst. Es erstellt alle Files neu. Darum sollte das auch nicht standardm??ig so im Cron stehen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...