Jump to content
Froxlor Forum
  • 0

Invalid command 'php_admin_value'


3tlam

Question

Hallo zusammen,

 

ich wollte gerade einen neuen Kunden anlegen und testen, da sehe ich, dass nicht die standard Froxlor index.html angezeigt wird. Googlen hat mich zum testen von apache2ctl -S gebracht, mit folgendem (schon bestehenden Kunden) Ergebnis:

Syntax error on line 25 of /etc/apache2/sites-enabled/22_froxlor_normal_vhost_**domain**.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration
Action '-S' failed.
The Apache error log may have more information.

Zeile 25 hat folgendes in der .conf:

php_admin_value open_basedir "/var/customers/webs/**kunde**/**example.com**/:/var/customers/tmp/**kunde**/:/tmp/:/usr/share/php/:/usr/share/php:/usr/share/php5"

Ich habe in Froxlor unter Domains -> Kundendomain -> Eigene vHost-Einstellungen folgende Zeile enthalten:

php_admin_value open_basedir "/var/customers/webs/**kunde**/**domain**/:/var/customers/tmp/(**kunde**/:/tmp/:/usr/share/php/:/usr/share/php:/usr/share/php5"

Leider weiss ich jetzt nicht wirklich weiter..

 

Die Seite des Kunden mit dem Fehler geht ohne Probleme und alles l?uft wie gew?nscht

 

Google konnte mir nicht wirklich weiterhelfen und ich denke es sollte alles richtig sein...?
 

Froxlor l?uft (offensichtlich) mit Apache und PHP-FPM

Gruss

Link to post
Share on other sites

6 answers to this question

Recommended Posts

Wieso schreibst du diese Zeile denn auch in die eigenen vHost settings? Du verwendest php-fpm, d.h. "php_admin_value" gibt es nicht, das ist mod_php. Und au?erdem k?mmert sich froxlor um Open-Basedir...was genau willst du erreichen?

Link to post
Share on other sites

ok sorry das wusste ich nicht.

Die Webseite benutzt Silverlight und ich brauche (damit es keinen Fehler wirft) noch Zugang zu dem Pfad /usr/share/php (auch wenn der Ordner gar nicht existiert)

 

//edit sagt: Hammer wie schnell du reagierst! Wirklich wirklich cool!

Link to post
Share on other sites

Ah ich seh meinen Fehler...

Wenn php_admin_value eh nicht akzeptiert wird, dann kann ich es auch einfach l?schen...

 

Wie genau m?sste ich denn vorgehen, wenn ich den open_basedir Pfad erweitern m?chte?

Oder ein ?quivalent zu php_admin_value brauche?

 

(habe das Problem l?sen k?nnen, indem ich die Zeile einfach entfernt habe; nun geht alles mit dem neuen Kunden wie gew?nscht)

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...