Jump to content
Froxlor Forum
  • 0

MySQL-DB anlegen fehlgeschlagen


MrServer

Question

Guten Morgen.

 

Seit dem Update ist mir folgender Fehler aufgefallen:

 

Wenn ein Kunde eine neue MySQL-Datenbank anlegen m?chte und das vorgeschlagene Kennwort nimmt erscheint folgende Meldung:

 

 

A database error occured

SQLSTATE[HY000]: General error: 1827 The password hash doesn't have the expected format. Check if the correct password algorithm is being used with the PASSWORD() function.

 

#0 /var/www/froxlor/lib/classes/database/class.Database.php(72): PDOStatement->execute(Array)
#1 /var/www/froxlor/lib/classes/database/manager/class.DbManagerMySQL.php(74): Database::pexecute(Object(PDOStatement), Array)
#2 /var/www/froxlor/lib/classes/database/class.DbManager.php(98): DbManagerMySQL->grantPrivilegesTo('KUNDEsql1', 'HmCxr8b2', '127.0.0.1')
#3 /var/www/froxlor/customer_mysql.php(179): DbManager->createDatabase('KUNDE', 'HmCxr8b2', '0')
#4 {main}

 

Das Passwort lautet: HmCxr8b2

und entspricht den Vorgaben die gesetzt wurden

 

Im Kundenmen? ist die Datenbank nicht ersichtlich, in phpmyadmin allerdings schon.

 

Wenn ich nun wieder versuche die Datenbank zu erstellen erscheint die Meldung:

 

 

A database error occured

SQLSTATE[HY000]: General error: 1007 Can't create database 'KUNDEsql1'; database exists

 

Welchen l?sungsansatz k?nnte ich nun gehen?

Link to post
Share on other sites

14 answers to this question

Recommended Posts

Das ist ja das was Froxlor bisher immer hatte...da verstehe ich den Fehler nun erst recht nicht. Hast du irgendwelche MySQL Einstellungen vorgenommen die damit ggfls etwas zu tun haben k?nnten? Tritt der Fehler auch auf, wenn du von MD5 z.b. auf SHA256 umstellst und versuchst die Datenbank anzulegen?

Link to post
Share on other sites

Auch mit SHA-256 habe ich diesen Fehler.

 

Ich habe an den MySQL-Einstellungen nichts ge?ndert.

 

Komischetrweise wird die Datenbank ja angelegt, aber Froxlor "erf?hrt" davon nichts und denkt Sie w?re NICHT vorhanden.

Link to post
Share on other sites

Das liegt halt daran, dass der Fehler beim setzen des Kunden-Passwortes passiert und Froxlor dann seine "arbeiten" nicht beenden kann und entsprechend keine Eintragungen in seiner Datenbank ?ber diese hat.

 

Ich kann dir leider nicht sagen, was da bei dir kaputt ist, ich habe das auf einem frischen Debian Wheezy getestet und es geht...mit MD5 und SHA256.

Link to post
Share on other sites

Also, liegt nicht an Froxlor's HASH-Einstellung, die hat damit gar nix zu tun. Das Passwort wird allein von MySQL via PASSWORD() funktion gehashed und da fehlt dir wohl derjenige den du irgendwo in den Einstellungen hast. Bitte poste deine my.cnf und sag uns welches System du hast usw.usw.usw.

Link to post
Share on other sites

Guten Morgen.

 

 

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port        = 3306
socket        = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket        = /var/run/mysqld/mysqld.sock
nice        = 0

[mysqld]
#
# * Basic Settings
#
user        = mysql
pid-file    = /var/run/mysqld/mysqld.pid
socket        = /var/run/mysqld/mysqld.sock
port        = 3306
basedir        = /usr
datadir        = /var/lib/mysql
tmpdir        = /tmp
lc-messages-dir    = /usr/share/mysql
skip-external-locking

# F?r DNS-Zentrale
old_passwords=1

#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address        = 127.0.0.1
#
# * Fine Tuning
#
max_allowed_packet    = 16M
thread_stack        = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover-options  = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit    = 1M
query_cache_size        = 32M
tmp_table_size        = 32M
max_heap_table_size    = 32M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#slow_query_log = 1
#slow_query_log_file = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id        = 1
#log_bin            = /var/log/mysql/mysql-bin.log
expire_logs_days    = 10
max_binlog_size         = 100M
#binlog_do_db        = include_database_name
#binlog_ignore_db    = include_database_name
#
# basic loggin
log-error        = /var/log/mysql/error.log
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# It seems that we need this for successful mysql-5.1 -> mysql-5.6 upgrade
innodb_data_file_path=ibdata1:10M:autoextend

#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet    = 16M

[mysql]
#no-auto-rehash    # faster start of mysql but no tab completition


[isamchk]
key_buffer        = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/
 

Mein System:

 

Froxlor.png

Link to post
Share on other sites

Das Update ?nderte nichts an der Art und Weise wie f?r MySQL-User Passw?rter gesetzt werden. Ich habe auch von keinem geh?rt, dass er dieses Problem hat...scheint was speziell bei dir zu sein. Google bringt dazu auch nichts wirklich Sinnvolles - ein Froxlor-Problem scheint das aber nicht zu sein.

Link to post
Share on other sites

Richtig.

 

In den letzten Versionen von Froxlor scheint die Funktion f?r old_passwords=1 noch funktioniert zu haben. Inzwischen nicht mehr.

Nun ist das Problem aber behoben. Falls jemand anderes das Problem auch bekommen sollte. Dies tritt augenscheinlich ab MySQL 5.6 + der aktuellen Froxlor Version auf.

Link to post
Share on other sites

Hat dann wohl eher mit MySQL als mit Froxlor zu tun..wir nutzen nur die PASSWORD() funktion und die is laut Doku das was man benutzen soll. Wenn du halt nen config-switch f?r pre-4.1 mysql aktivierst, musst DU wissen warum und wieso und was das bedeutet.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...