Jump to content
Froxlor Forum
  • 0
behrang

Separate Logs not created

Question

Hi

as i understand the creation of separate logs for domains can be controlled via mysql in table panel_domains by flag speciallogfile.

on my froxlor installation this flag doesnt change anything. I have all rows on 1 concerning this flag. Still there is only one log file for the customer and errors are written into this one error.log

greets

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

You should change values only from within the panel, not directly in the database.

Share this post


Link to post
Share on other sites
  • 0

well the point is:

 

i have 3 froxlors on 3 servers, and 20+ domains each. I noticed that all don't have seperate logging. And that the checkbox is on default unselected (which i believe is wrong).

 

so i made a cron setting the speciallogfile to 1 if 0. This totally works on 2 of 3 servers. As i understand froxlor does almost all things by cronjobs. You change something in the panel > froxlor checks by cron > does changes.

 

And as the other 2 servers worked I wondered why it doesn't work fpr the 3rd.

 

is there any way to set the checkbox on selected by default, which is update-resistent (of course i can change template etc)

thx

Share this post


Link to post
Share on other sites
  • 0

ok i see it's not working by cron at all, only partially so you are right.

then: is there any way to set the checkbox on selected by default, which is update-resistent (of course i can change template etc)

Share this post


Link to post
Share on other sites
  • 0

then: is there any way to set the checkbox on selected by default, which is update-resistent (of course i can change template etc)

 

All domain-settings are update-resistent. To change the default to "On" for new domains, use this patch:

diff --git a/lib/formfields/admin/domains/formfield.domains_add.php b/lib/formfields/admin/domains/formfield.domains_add.php
index 12dbae4..a4dd2ea 100644
--- a/lib/formfields/admin/domains/formfield.domains_add.php
+++ b/lib/formfields/admin/domains/formfield.domains_add.php
@@ -132,7 +132,7 @@ return array(
                                                'values' => array(
                                                        array ('label' => $lng['panel']['yes'], 'value' => '1')
                                                ),
-                                               'value' => array()
+                                               'value' => array('1')
                                        ),
                                        'specialsettings' => array(
                                                'visible' => ($userinfo['change_serversettings'] == '1' ? true : false),

Share this post


Link to post
Share on other sites
  • 0

well the point is:

 

i have 3 froxlors on 3 servers, and 20+ domains each. I noticed that all don't have seperate logging. And that the checkbox is on default unselected (which i believe is wrong).

 

so i made a cron setting the speciallogfile to 1 if 0. This totally works on 2 of 3 servers. As i understand froxlor does almost all things by cronjobs. You change something in the panel > froxlor checks by cron > does changes.

 

And as the other 2 servers worked I wondered why it doesn't work fpr the 3rd.

 

is there any way to set the checkbox on selected by default, which is update-resistent (of course i can change template etc)

thx

 

Did you figure out solution to your problem?  I am having similar kind of problem. I have set checkbox by default in other programming language. but this is new so could not figured out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×