Jump to content
Froxlor Forum
  • 0
S204

[solved] Froxlor nicht mehr erreichbar

Question

Hallo Comunity,

 

Ich hab versucht den Froxlor auf n anderen Port zu bringen. Das ging leider schief. Es sollte so werden wie es bei Hetzner mal mit syscp war. 

Schon den einen oder anderen Versuch unternommen es zu reparieren, bekomme es aber nich hin.

Die Inst. is n Vserver von Netcup und ich komme per putty drauf der root ist deaktiviert, nur durch su einschaltbar.

die Webites die unter sites-enabled eingetragen sind sind erreichbar, aber es gibt die Fehler meldungen  im Apache, die auch zum Nichtstarten des Indianers f?hren wenn ich was daran ?ndere.

z.B. port 80 ist schon in Benutzung

wer kann da tipps geben.

Das war einer der Ausgangspunkte, aber da Froxlor schon da war, brauchte ich ja nicht selbst installieren:
http://www.mehr4u.de/item/65-adminpanel_froxlor_installation_alternativ_port_ssh.html

 

Websites der Kunden liegen bei var/customers/webs/.....

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Port 80 schon in benutzung? ich dachte du willst froxlor auf einen anderen Port heben...wenn du der von dir genannten Anleitung gefolgt bist, sollte Port 80 doch gar keine Rolle mehr spielen. Am besten postest du mal ein paar Logs und die entsprechenden Configs und die Vhosts, damit wir mal einen kleinen Einblick bekommen, was genau du da gemacht hast.

Share this post


Link to post
Share on other sites
  • 0

das ist mir schon klar. nur habe ich ja versucht es zur?ckzureparieren.

im var/customers/logs  gibt es das error-log file da steht als letztes drin     ...web/[domain]/froxlor  existiert nicht  was ja richtig ist, denn das Froxlor-Verzeichnis ist ja im Standardpfad geblieben.   Das war aber Freitag. momentan kommt da nix mehr dazu.

Das kann aber auch daran liegen, das ich die erstellte default (aus dem Tutorial) aus dem sites-enabled erst mal entfernt habe. wenns wieder drin ist geht gar nix mehr, keine Website.

 

 

im Froxlot/log steht sql-error.log

|CODE 42000
|MSG SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'd`.`domain` ASC' at line 11
|FILE /var/www/froxlor/lib/classes/database/class.Database.php
|LINE 72
|TRACE
#0 /var/www/froxlor/lib/classes/database/class.Database.php(72): PDOStatement->execute(Array)
#1 /var/www/froxlor/lib/classes/database/class.Database.php(90): Database::pexecute(Object(PDOStatement), Array, true)
#2 /var/www/froxlor/customer_domains.php(254): Database::pexecute_first(Object(PDOStatement), Array)
#3 {main}

 

ports.conf sieht erst aml wieder so aus:

NameVirtualHost *:80
Listen 80
<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>



folglich auch nichts mit port 81 erreichbar.

vhosts.conf ist leer.

 

wenn ich jetzt den port 81 reinnehmen m?chte kommt nach dem Versuch zu starten:

apachectl -k graceful
[sun May 04 09:54:51 2014] [warn] NameVirtualHost 5.45.xxx.xxx:81 has no VirtualHosts

und:

[sun May 04 09:55:12 2014] [warn] NameVirtualHost *:80 has no VirtualHosts
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address 5.45.xxx.xxx:80
no listening sockets available, shutting down
Unable to open logs
Action '-k graceful' failed.




 

Share this post


Link to post
Share on other sites
  • 0

Naja, du hast nichts davon gesagt, dass du es wieder zur?cksetzen willst.

 

?berpr?fe doch die ports.conf. Du hast in Froxlor jetzt alles auf port 81 gestellt. Du solltest also, wenn du das nicht erst manuell in der Datenbank ab?ndern willst, das Listen 81 wieder dort eintragen und den Froxlor-Cronjob manuell anschubsen (php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force).

 

Und dann sagst du mir bitte nicht nur "es geht nix" sondern genau die Fehlermeldung / Logs - anders ist es einfach schwer zu raten wo das Problem sein k?nnte.

Share this post


Link to post
Share on other sites
  • 0

Mein Eindruck ist halt ich mache zur Zeit mehr kaputt als ganz und der Firefox neppt mich die ganze Zeit schon wieder durch den cache. Die Websites sind nicht on.

Also wenn ich es richtig und gesafed machen kann, dann mache ich es richtig, nur dazu brauche ich einen Ausgangspunkt bei dem Froxlor erst mal wieder l?uft.

Share this post


Link to post
Share on other sites
  • 0

Ich glaube du hast da ordentlich was kaputtgespielt. Ich habe dir bereits gesagt, was du tun musst, damit es wieder geht. F?r alles weitere br?uchte ich selbst Zugang oder du wendest dich an https://froxlor.support/

Share this post


Link to post
Share on other sites
  • 0

ja wei? ich.

nu hat der Aufruf mit dem Cronjob keinerlei Effekt mehr (hatte den glaube hier im Forum schon mal gelesen und ausgef?hrt).

der apache startet nich mehr und bringt daher folgende Meldungen:

 apachectl -k start
[Tue May 06 22:23:06 2014] [warn] NameVirtualHost 5.45.xxx.xxx:81 has no VirtualHosts
[Tue May 06 22:23:06 2014] [warn] NameVirtualHost 5.45.xxx.xxx:82 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address 5.45.xxx.xxx:80
no listening sockets available, shutting down
Unable to open logs
Action '-k start' failed.
The Apache error log may have more information.
 

 

kann das auch an berechtigungsfehlern liegen ?  da ich auf der Konsole als su root bin, der root accout aber ansonsten deaktiviert ist ?  

denke da an den user www-data, der ja auch bestimmte zurgiffsrechte braucht ?

Share this post


Link to post
Share on other sites
  • 0

hatte gerade f?r realtiv kurze Zeit Zugriff auf den Froxlor und kann auch nachvollziehen wie und warum:

ich l?sche die einstellungsdateien aus sites-enabled  raus bis auf die  000-default, 05_froxlor_dirfix_nofcgi und 40_froxlor_diroption_.......  geh?rt wohl zum Webalizer  

wenn ich dann froxlor aufrufe l?uft er und ich kann mich einloggen, bis ja vermutlich der cronjob l?uft, denn dann sind die Configs wieder da und weder die Webseiten noch froxlor erreichbar.

die 000-default sieht  z.Zt. so aus:

 

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/froxlor/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/froxlor/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

ist aber auf port 80 so nicht ansprechbar, ich vermut da muss 81 rein das teste ich noch. Auch das funktioniert nicht. sobald er seinen cronjob ausgef?hrt hat, ist nichts mehr erreichbar, werder froxlor noch die Webseiten, welche erreichbar sind, wenn ich die configs von hand zur?ckschreibe. Da der cronjob diese aber ?berschreibt ist sp?testens dann Schlu?.

Share this post


Link to post
Share on other sites
  • 0

ich l?sche die einstellungsdateien aus sites-enabled  raus bis auf die  000-default, 05_froxlor_dirfix_nofcgi und 40_froxlor_diroption_.......  geh?rt wohl zum Webalizer  

 

Sie heissen 05_froxlor_* und 40_froxlor_* - wieso sollten die zu Webalizer geh?ren? :P

 

Also, dein Problem ist im Grunde super simpel zu l?sen, es ist nur schwer zu wissen, was davon du jetzt schon gemacht hast.

 

- Stoppe deinen Cron-Daemon (/etc/init.d/cron stop)

- L?sche alle Froxlor-erzeugten Webserver-Configs aus sites-enabled

- Pr?fe die Tabelle panel_ipsandports der Froxlor-Datenbank, welcher Port ist dort hinterlegt und hat er bei "listen_statement" eine 1? Alternativ falls dein Froxlor wieder erreichbar ist, kannst du das nat?rlich auch dort auslesen

- Pr?fe die Apache-Config (vorallem die ports.conf) - steht dort ein "Listen [port]" mit dem selben Port den du in der Tabelle ist UND du hast dort "listen_statement" = 1, dann setze in der Datenbank bitte das "listen_statement" Feld auf den Wert 0

- Falls in der Apache-Config KEIN Listen-Eintrag f?r den Port vorhanden ist MUSST du in Froxlor das "listen_statement" auf 1 setzen (sonst bekommst du den Fehler: no listening sockets)

 

Falls das nicht klappt, wiederhole ich mich gerne nochmal: schick mir per PM die Zugangsdaten, dann schauen wir uns das gemeinsam an

Share this post


Link to post
Share on other sites
  • 0

Sie heissen 05_froxlor_* und 40_froxlor_* - wieso sollten die zu Webalizer geh?ren? :P

 

der mit 40 beginnende(nur den hatte ich gemeint) hat den webalizer in den Pfadeinstellungen f?r den vhost. 

 

 

"listen_statement" eine 1?

h?tte ich jetzt gern ein Bild hochgeladen geht hier aber nicht, sondern nur per URL.... :-(

 

Ich geh davon aus, das mit listen_statment 1 der Eintrag in Froxlor  bei IP's und Ports  Ja (1) oder Nein(0) gemeint ist. daher habe ich nun bei 80 ja und bei 81 nein stehen.

 

muss nun arbetien gehen also weiteres sp?ter.   Den Cron schalte ich daher noch nicht wieder ein, falls er nich durch das Neustarten des Apachen wieder aktiv wird.

 

dabei kommt leider ne Fehlermeldung:

 

 

[Wed May 07 09:40:59 2014] [warn] VirtualHost 5.45.xxx.xxx:80 overlaps with VirtualHost 5.45.xxx.xxx:80, the first has precedence, perhaps you need a NameVirtualHost directive

[Wed May 07 09:40:59 2014] [warn] NameVirtualHost *:80 has no VirtualHosts

 

 

 

ach so ja es gibt nun einen Umleitungsfehler : 

 

roxlor/froxlor/froxlor/froxlor/

 

beim aufrufen jeder webseite

bis sp?ter.......

 

 

 

Share this post


Link to post
Share on other sites
  • 0

der mit 40 beginnende(nur den hatte ich gemeint) hat den webalizer in den Pfadeinstellungen f?r den vhost.

Bezieht sich immer auf Kunden-Vhosts, kann daher auch gel?scht werden, weil er von froxlor erneut erstellt wird.

 

Ich geh davon aus, das mit listen_statment 1 der Eintrag in Froxlor  bei IP's und Ports  Ja (1) oder Nein(0) gemeint ist. daher habe ich nun bei 80 ja und bei 81 nein stehen.

Und was ist mit der Apache-Config? also der Ports.conf - steht da ein "Listen 80" z.B.? Wenn ja bekommst du nachher wieder den Fehler "addr already in use"

 

[Wed May 07 09:40:59 2014] [warn] VirtualHost 5.45.xxx.xxx:80 overlaps with VirtualHost 5.45.xxx.xxx:80, the first has precedence, perhaps you need a NameVirtualHost directive

[Wed May 07 09:40:59 2014] [warn] NameVirtualHost *:80 has no VirtualHosts

er sagt ja was er haben will - du hast wohl "namevirtualhost" deaktiviert f?r die ip/port kombo - das solltest du wieder aktivieren wenn du mehr als einen kunden bzw. mehr als eine domain hast.

 

ach so ja es gibt nun einen Umleitungsfehler : 

 

roxlor/froxlor/froxlor/froxlor/

 

beim aufrufen jeder webseite

Ich w?sste nicht das Froxlor sowas tut - hast du noch manuell irgendwas in die configs eingef?gt oder so?

Share this post


Link to post
Share on other sites
  • 0

 

Und was ist mit der Apache-Config? also der Ports.conf - steht da ein "Listen 80"

 

da steht Listen 80  und Listen 81, denn die Webseiten der Kunden sollen ja weiterhin ?ber den port 80 erreichbar sein, dachte ich mir so.  

 

Da in dem Tutorial von der localhost-IP ausgegangen wurde, mir aber nicht klar war, wie sich der zusammenhang mit putty und der verbindung auf den Server auswirkt, habe ich auch nicht die 127.0.0.1:81 in den Froxlor eingetragen sondern die gleiche auf die der Port 80 zeigt.

 

 

Ich w?sste nicht das Froxlor sowas tut - hast du noch manuell irgendwas in die configs eingef?gt oder so?

 

Ja so wie es oben in den vorherigen Postings steht (bzw aus dem Tutorial noch vorhanden)   die 000-default auf den port 81 gestellt und anstatt  '/var/www/'  steht jetzt  '/var/www/froxlor/'

 

ich komme an den Froxlor zum Login jetzt mittels <IP-Adresse>:81  sobald ich aber irgendeine domain aufrufe kommt der Umleitungsfehler 

 

 

er sagt ja was er haben will - du hast wohl "namevirtualhost" deaktiviert f?r die ip/port kombo - das solltest du wieder aktivieren wenn du mehr als einen kunden bzw. mehr als eine domain hast.

Ja es ist mehr als eine domain bzw. Kunde ich denke ja es ist auf der IP/:80 deaktiviert

 

in den configs sind ja nur die wieder reinkopiert, die schon da waren, muss ich sicher nachher den Cronjob wieder einschalten und die neu erstellen lassen?

 

Bin aber nicht zuhause, so das ich gerade keinen Zugang habe.

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Momentan bin ich soweit gekommen, das ich den Froxlor ?ber die beiden ports 80 und 81 erreichen kann.  Cron aus, damit keine ip-configs von Froxlor geschrieben werden.

was mir nicht gef?llt ist die Tatsache, das froxlor sofort zum Login springt sobald ich <IP-Adresse>:81 eingegeben und enter gedr?ckt habe. Das h?tte ich lieber anders.

N?chster Schritt:

froxlor nur ?ber Port 81 erreichbar: 

dazu wurde der Port 80  auf das Verzeichnis var/www/default eingestellt, aber nicht mehr mit *  sondern nur f?r die IP des Servers
 

da der cron f?r die configs in froxlor aber aus ist, stehen in sites-enabled jetzt nur 2 Eintr?ge, die der apache auch benutzt:

000-default und

10_froxlor_ipandport ...... 81 mit dem Pfad var/www/froxlor (wohl der Grund f?r den sofortigen start des login)

wenn nun in froxlor der cron wieder eingeschaltet und alle configs neu geschrieben werden w?rden, k?me es wohl zu dem Konflikt auf dem Listen port 80 in der Ports.conf ? 

behelfsm??ig habe ich die froxlor_configs f?r die Webseiten wieder von hand eingef?gt. und die Seiten gehen auch, doch wie l?se ich das Problem der neu zu schreibenden Configs, denn der prot 80 im 000-default  (apache eigene config) und 10_froxlor_ipandPort....80  scheinen sich ja doch zu hacken ?   
 

Share this post


Link to post
Share on other sites
  • 0

wie schon mehrfach nun gesagt: daf?r stellst du in IP/Port das Feld "Listen-Eintrag" einfach auf "nein"

Share this post


Link to post
Share on other sites
  • 0

Das steht bereits auf nein. Also sollte es nun m?glich sein, den cronjob einzuschalten und alles ist fit ? Ich probiere es aus und berichte wieder.

Share this post


Link to post
Share on other sites
  • 0

Jetzt l?uft zwar alles, aber es gibt die Fehlermeldung:

 

 

.........:/home/ms-user# apachectl -k restart
[Thu May 08 08:19:10 2014] [warn] NameVirtualHost 5.45.xxx.xxx:80 has no VirtualHosts
........:/home/ms-user#
 

Da stellt sich mir die Frage woher kommt diese ?

a ) 000-default

 

oder

 

B) 10_froxlor_ipandport_.............80   welche trotz des entfernten Listen-Eintrages von Froxlor erstellt wurde.

 

auch die apache errror.log hilt nicht wirklich weiter.:

(9)Bad file descriptor: apr_socket_accept: (client socket)
[Thu May 08 08:20:01 2014] [warn] NameVirtualHost 5.45.xxx.xxx:80 has no VirtualHosts
[Thu May 08 08:20:01 2014] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u9 configured -- resuming normal operations
 

Share this post


Link to post
Share on other sites
  • 0

Nat?rlich wird eine config f?r die IP erstellt. Nur ob da ein Vhost drin ist oder nicht ist die Frage. Du hast dort vermutlich einen NameVirtualHost Eintrag, aber (noch) keinen Vhost (z.B. von einer Domain) die darauf passt. diese meldung kann getrost ignoriert werden, da ist nichts kaputt.

Share this post


Link to post
Share on other sites
  • 0

ich habe die 10_froxlor nun rausgel?scht und die configs neu schreiben lassen und siehe da es geht !


also kann dieser Tread als erledigt  (solved) markiert werden.

Er wird bestimmt einigen anderen auch helfen und wenn es mir nochmal passiert und ich bis dahin vergessen haben sollte was da war und wie es geht, schaue ich gern hier wieder nach.

 

es geht ja an anderer Stelle mit neuen Treads weiter - SSL und die Geschichte mit dem Einloggen ?ber Putty(aus dem Tutorial), so das ich den Froxlor auf loaclhost setzen kann, habe ich noch nicht wirklich verstanden. 

Share this post


Link to post
Share on other sites
  • 0

Hallo zusammen,

 

ich poste mein Problem auch gleich mal hier drinnen, weil der Thread gerade dazu passt.

 

Folgendes ist mir passiert:

 

Ich habe in Froxlor in der Konfiguration der IPs und Ports das H?kchen bei Listening gesetzt. Kurz darauf komme ich nicht mehr in Froxlor rein (Apache lie? sich nicht mehr starten -> no listening sockets). Mittlerweile nicht mal mehr auf das Standardverzeichnis mit der IP-Adresse. Hier erscheint jetzt anstelle der "It works!"-Seite nur noch ein Hinweis "Froxlor Domain Default Page - This page was generated by Froxlor Server Management Panel.
If you see this page, it means that there is no content on this domain yet.".

 

W?hrend ich oben gelesen habe, habe ich vielleicht etwas zu schnell geschossen und aus sites-available schon die beiden Dateien 10_froxlor*** und 40_froxlor*** raus gel?scht. Der Apache-Server l?sst sich zwar wieder starten allerdings besteht seit dem das Problem das das Standardverzeichnis nicht mehr aufrufbar ist.

Ich habe auch probiert in der Datenbank mittels

ALTER TABLE panel_ipsandports CHANGE listen_statement listen_statement tinyint(1) NULL;

das Listening wieder abzuschalten. Hilft leider auch nichts. Dies habe ich jetzt wieder auf den Urzustand ge?ndert.

 

Gibt es noch eine Hoffnung die Konfiguration zu retten?

 

EDIT: Habe jetzt mit

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

die Config neu schreiben lassen. Jetzt haben wir noch folgendes Problem:

root@*******************:~# service apache2 restart
[....] Restarting web server: apache2(98)Address already in use: make_sock: could not bind to address 37.xxx.xxx.175:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
 failed!

Wie l?sst sich das wieder in den Griff bekommen?

Edited by mpact1984

Share this post


Link to post
Share on other sites
  • 0

Juhu ... habs geschafft:

 

Sorry das ich euch bel?stigt habe :unsure: .

 

Ich schreibe hier auch nochmal die L?sung rein wie ich es geschafft habe, vielleicht hilft sie ja jemandem.

 

Als erstes habe ich in der Datei 10_froxlor*** die Zeile

Listen xxx.xxx.xxx.xxx:80

auskommentiert.

 

Nun l?sst sich der Apache2 Server starten.

 

Dann schnell ins Froxlor eingeloggt, bevor der Cron ausgef?hrt wird. Das "Listening"-H?kchen in den IP und Port-Konfigs wieder raus gemacht und gespeichert.

 

Kurze Zeit sp?ter wird vom Cron die Datei 10_froxlor*** neu erstellt und die auskommentierte Listening-Zeile verschwindet.

 

 

Und jetzt erstmal nen Kaffee und eine rauchen :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×