S204

Members
  • Content count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About S204

  • Rank
    Froxie
  1. ich habe die 10_froxlor nun rausgel?scht und die configs neu schreiben lassen und siehe da es geht ! also kann dieser Tread als erledigt (solved) markiert werden. Er wird bestimmt einigen anderen auch helfen und wenn es mir nochmal passiert und ich bis dahin vergessen haben sollte was da war und wie es geht, schaue ich gern hier wieder nach. es geht ja an anderer Stelle mit neuen Treads weiter - SSL und die Geschichte mit dem Einloggen ?ber Putty(aus dem Tutorial), so das ich den Froxlor auf loaclhost setzen kann, habe ich noch nicht wirklich verstanden.
  2. Jetzt l?uft zwar alles, aber es gibt die Fehlermeldung: Da stellt sich mir die Frage woher kommt diese ? a ) 000-default oder 10_froxlor_ipandport_.............80 welche trotz des entfernten Listen-Eintrages von Froxlor erstellt wurde. auch die apache errror.log hilt nicht wirklich weiter.: (9)Bad file descriptor: apr_socket_accept: (client socket) [Thu May 08 08:20:01 2014] [warn] NameVirtualHost 5.45.xxx.xxx:80 has no VirtualHosts [Thu May 08 08:20:01 2014] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u9 configured -- resuming normal operations
  3. Das steht bereits auf nein. Also sollte es nun m?glich sein, den cronjob einzuschalten und alles ist fit ? Ich probiere es aus und berichte wieder.
  4. Momentan bin ich soweit gekommen, das ich den Froxlor ?ber die beiden ports 80 und 81 erreichen kann. Cron aus, damit keine ip-configs von Froxlor geschrieben werden. was mir nicht gef?llt ist die Tatsache, das froxlor sofort zum Login springt sobald ich <IP-Adresse>:81 eingegeben und enter gedr?ckt habe. Das h?tte ich lieber anders. N?chster Schritt: froxlor nur ?ber Port 81 erreichbar: dazu wurde der Port 80 auf das Verzeichnis var/www/default eingestellt, aber nicht mehr mit * sondern nur f?r die IP des Servers da der cron f?r die configs in froxlor aber aus ist, stehen in sites-enabled jetzt nur 2 Eintr?ge, die der apache auch benutzt: 000-default und 10_froxlor_ipandport ...... 81 mit dem Pfad var/www/froxlor (wohl der Grund f?r den sofortigen start des login) wenn nun in froxlor der cron wieder eingeschaltet und alle configs neu geschrieben werden w?rden, k?me es wohl zu dem Konflikt auf dem Listen port 80 in der Ports.conf ? behelfsm??ig habe ich die froxlor_configs f?r die Webseiten wieder von hand eingef?gt. und die Seiten gehen auch, doch wie l?se ich das Problem der neu zu schreibenden Configs, denn der prot 80 im 000-default (apache eigene config) und 10_froxlor_ipandPort....80 scheinen sich ja doch zu hacken ?
  5. da steht Listen 80 und Listen 81, denn die Webseiten der Kunden sollen ja weiterhin ?ber den port 80 erreichbar sein, dachte ich mir so. Da in dem Tutorial von der localhost-IP ausgegangen wurde, mir aber nicht klar war, wie sich der zusammenhang mit putty und der verbindung auf den Server auswirkt, habe ich auch nicht die 127.0.0.1:81 in den Froxlor eingetragen sondern die gleiche auf die der Port 80 zeigt. Ja so wie es oben in den vorherigen Postings steht (bzw aus dem Tutorial noch vorhanden) die 000-default auf den port 81 gestellt und anstatt '/var/www/' steht jetzt '/var/www/froxlor/' ich komme an den Froxlor zum Login jetzt mittels <IP-Adresse>:81 sobald ich aber irgendeine domain aufrufe kommt der Umleitungsfehler Ja es ist mehr als eine domain bzw. Kunde ich denke ja es ist auf der IP/:80 deaktiviert in den configs sind ja nur die wieder reinkopiert, die schon da waren, muss ich sicher nachher den Cronjob wieder einschalten und die neu erstellen lassen? Bin aber nicht zuhause, so das ich gerade keinen Zugang habe.
  6. der mit 40 beginnende(nur den hatte ich gemeint) hat den webalizer in den Pfadeinstellungen f?r den vhost. h?tte ich jetzt gern ein Bild hochgeladen geht hier aber nicht, sondern nur per URL.... :-( Ich geh davon aus, das mit listen_statment 1 der Eintrag in Froxlor bei IP's und Ports Ja (1) oder Nein(0) gemeint ist. daher habe ich nun bei 80 ja und bei 81 nein stehen. muss nun arbetien gehen also weiteres sp?ter. Den Cron schalte ich daher noch nicht wieder ein, falls er nich durch das Neustarten des Apachen wieder aktiv wird. dabei kommt leider ne Fehlermeldung: ach so ja es gibt nun einen Umleitungsfehler : roxlor/froxlor/froxlor/froxlor/ beim aufrufen jeder webseite bis sp?ter.......
  7. hatte gerade f?r realtiv kurze Zeit Zugriff auf den Froxlor und kann auch nachvollziehen wie und warum: ich l?sche die einstellungsdateien aus sites-enabled raus bis auf die 000-default, 05_froxlor_dirfix_nofcgi und 40_froxlor_diroption_....... geh?rt wohl zum Webalizer wenn ich dann froxlor aufrufe l?uft er und ich kann mich einloggen, bis ja vermutlich der cronjob l?uft, denn dann sind die Configs wieder da und weder die Webseiten noch froxlor erreichbar. die 000-default sieht z.Zt. so aus: <VirtualHost *:80> ServerAdmin webmaster@localhost DocumentRoot /var/www/froxlor/ <Directory /> Options FollowSymLinks AllowOverride None </Directory> <Directory /var/www/froxlor/> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all </Directory> ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <Directory "/usr/lib/cgi-bin"> AllowOverride None Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch Order allow,deny Allow from all </Directory> ErrorLog ${APACHE_LOG_DIR}/error.log # Possible values include: debug, info, notice, warn, error, crit, # alert, emerg. LogLevel warn CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost> ist aber auf port 80 so nicht ansprechbar, ich vermut da muss 81 rein das teste ich noch. Auch das funktioniert nicht. sobald er seinen cronjob ausgef?hrt hat, ist nichts mehr erreichbar, werder froxlor noch die Webseiten, welche erreichbar sind, wenn ich die configs von hand zur?ckschreibe. Da der cronjob diese aber ?berschreibt ist sp?testens dann Schlu?.
  8. ja wei? ich. nu hat der Aufruf mit dem Cronjob keinerlei Effekt mehr (hatte den glaube hier im Forum schon mal gelesen und ausgef?hrt). der apache startet nich mehr und bringt daher folgende Meldungen: apachectl -k start [Tue May 06 22:23:06 2014] [warn] NameVirtualHost 5.45.xxx.xxx:81 has no VirtualHosts [Tue May 06 22:23:06 2014] [warn] NameVirtualHost 5.45.xxx.xxx:82 has no VirtualHosts (98)Address already in use: make_sock: could not bind to address 5.45.xxx.xxx:80 no listening sockets available, shutting down Unable to open logs Action '-k start' failed. The Apache error log may have more information. kann das auch an berechtigungsfehlern liegen ? da ich auf der Konsole als su root bin, der root accout aber ansonsten deaktiviert ist ? denke da an den user www-data, der ja auch bestimmte zurgiffsrechte braucht ?
  9. Mein Eindruck ist halt ich mache zur Zeit mehr kaputt als ganz und der Firefox neppt mich die ganze Zeit schon wieder durch den cache. Die Websites sind nicht on. Also wenn ich es richtig und gesafed machen kann, dann mache ich es richtig, nur dazu brauche ich einen Ausgangspunkt bei dem Froxlor erst mal wieder l?uft.
  10. das ist mir schon klar. nur habe ich ja versucht es zur?ckzureparieren. im var/customers/logs gibt es das error-log file da steht als letztes drin ...web/[domain]/froxlor existiert nicht was ja richtig ist, denn das Froxlor-Verzeichnis ist ja im Standardpfad geblieben. Das war aber Freitag. momentan kommt da nix mehr dazu. Das kann aber auch daran liegen, das ich die erstellte default (aus dem Tutorial) aus dem sites-enabled erst mal entfernt habe. wenns wieder drin ist geht gar nix mehr, keine Website. im Froxlot/log steht sql-error.log |CODE 42000 |MSG SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'd`.`domain` ASC' at line 11 |FILE /var/www/froxlor/lib/classes/database/class.Database.php |LINE 72 |TRACE #0 /var/www/froxlor/lib/classes/database/class.Database.php(72): PDOStatement->execute(Array) #1 /var/www/froxlor/lib/classes/database/class.Database.php(90): Database::pexecute(Object(PDOStatement), Array, true) #2 /var/www/froxlor/customer_domains.php(254): Database::pexecute_first(Object(PDOStatement), Array) #3 {main} ports.conf sieht erst aml wieder so aus: NameVirtualHost *:80 Listen 80 <IfModule mod_ssl.c> # If you add NameVirtualHost *:443 here, you will also have to change # the VirtualHost statement in /etc/apache2/sites-available/default-ssl # to <VirtualHost *:443> # Server Name Indication for SSL named virtual hosts is currently not # supported by MSIE on Windows XP. Listen 443 </IfModule> <IfModule mod_gnutls.c> Listen 443 </IfModule> folglich auch nichts mit port 81 erreichbar. vhosts.conf ist leer. wenn ich jetzt den port 81 reinnehmen m?chte kommt nach dem Versuch zu starten: apachectl -k graceful [sun May 04 09:54:51 2014] [warn] NameVirtualHost 5.45.xxx.xxx:81 has no VirtualHosts und: [sun May 04 09:55:12 2014] [warn] NameVirtualHost *:80 has no VirtualHosts httpd not running, trying to start (98)Address already in use: make_sock: could not bind to address 5.45.xxx.xxx:80 no listening sockets available, shutting down Unable to open logs Action '-k graceful' failed.
  11. Hallo Comunity, Ich hab versucht den Froxlor auf n anderen Port zu bringen. Das ging leider schief. Es sollte so werden wie es bei Hetzner mal mit syscp war. Schon den einen oder anderen Versuch unternommen es zu reparieren, bekomme es aber nich hin. Die Inst. is n Vserver von Netcup und ich komme per putty drauf der root ist deaktiviert, nur durch su einschaltbar. die Webites die unter sites-enabled eingetragen sind sind erreichbar, aber es gibt die Fehler meldungen im Apache, die auch zum Nichtstarten des Indianers f?hren wenn ich was daran ?ndere. z.B. port 80 ist schon in Benutzung wer kann da tipps geben. Das war einer der Ausgangspunkte, aber da Froxlor schon da war, brauchte ich ja nicht selbst installieren: http://www.mehr4u.de/item/65-adminpanel_froxlor_installation_alternativ_port_ssh.html Websites der Kunden liegen bei var/customers/webs/.....