Jump to content
Froxlor Forum
  • 0

Konfiguration Postfix/Dovecot


Netsurfer

Question

Hallo!

 

Ich richte gerade meinen neuen Server mit Debian 7 (Wheezy) ein. Auf meinem bisherigen ist Debian 6 (Squeeze) im Einsatz.

Leider hat sich die Konfiguration von Dovecot in meinen Augen extrem "verkompliziert".

 

Wenn ich gem?? der Konfigurationseinstellungen in Froxlor vorgehe, lande ich am Ende an dem Punkt, dass ich im mail.err Log folgende Eintr?ge stehen habe:

 

Nov 23 14:44:14 vs1 dovecot: lda(smmsp): Error: user smmsp: Initialization failed: Namespace '': mkdir(/var/lib/sendmail/mail) failed: Permission denied (euid=105(smmsp) egid=110(smmsp) missing +w perm: /var/lib/sendmail, dir owned by 104:110 mode=0751)

Nov 23 14:44:14 vs1 dovecot: lda(smmsp): Fatal: Invalid user settings. Refer to server log for more information.

 

Auch wird das entsprechende Mail-Verzeichnis bspw. unter /var/customers/mail/web1 nicht angelegt, wenn ich eine E-Mail Adresse f?r den Kunden anlege.

 

Ich verwende Postfix + Dovecot.

 

Irgendeinen Tipp/ Hinweis, wo ich mich mal auf die Fehlersuche machen k?nnte?

 

Besten Dank im Voraus!

 

Gru?

Gunther

Link to post
Share on other sites

16 answers to this question

Recommended Posts

Ich sehe in unserer config nix von "smmsp"...wo hast du das her?

Der m?sste vom SpamAssassin herkommen.

Ich verwende sasl, amavis und spamassassin ... (hab' ich bei meiner bisherigen Installation auch so im Einsatz).

 

In meiner bisherigen dovecot.conf habe ich u.a. folgendes stehen:

 

auth default {
mechanisms = plain login
passdb sql {
args = /etc/dovecot/dovecot-sql.conf
}

userdb prefetch {
}

userdb sql {
args = /etc/dovecot/dovecot-sql.conf
}

user = vmail
socket listen {
# Postfix uses the client socket for SMTP Auth
client {
# Assuming the default Postfix $queue_directory setting
path = /var/spool/postfix/private/auth
mode = 0660
# Assuming the default Postfix user and group
user = postfix
group = postfix
}
# Note that we're setting a master socket. SMTP AUTH for Postfix and Exim uses client sockets.
master {
path = /var/run/dovecot/auth-master
mode = 0660
user = vmail
group = vmail
}

}
}

 

Auf dem System gibt es u.a. die beiden folgenden User:

smmta:x:104:109:Mail Transfer Agent,,,:/var/lib/sendmail:/bin/false

smmsp:x:105:110:Mail Submission Program,,,:/var/lib/sendmail:/bin/false

 

 

Schon mal besten Dank f?r deine Hilfe.

 

Gru?

Gunther

Link to post
Share on other sites

Das ist nicht die Froxlor-Config f?r Dovecot unter Debian Wheezy...

Nein, nat?rlich nicht. ;-)

Mit "in meiner bisherigen" war ja auch mein derzeitiger Server mit Debian 6 Squeeze gemeint.

 

Da aber ja unter Wheezy jede Menge neuer Conf-Dateien dazu gekommen sind, stehe ich momentan noch etwas auf dem Schlauch, was denn nun jetzt eigentlich wohin geh?rt ...!

 

Ach ja, hab' gerade nochmal nachgeschaut. Diese beiden neuen User gibt es auf meinem "alten" System auch nicht. Scheint auch eine Neuerung in Dovecot (LDA) zu sein.

Frei nach dem Motto:"Warum einfach, wenn es auch kompliziert geht!".

 

Und dabei hatte ich so geh?fft, ich h?tte einfach meine Einstellungen "kopieren" k?nnen - war wohl nix!

Link to post
Share on other sites

Was heisst hier "Nein, nat?rlich nicht" - wenn du hier reinpostest gehe ich davon aus, dass du nat?rlich die Froxlor configs nutzt. Ansonsten kannst du ja auch die Leute von Dovecot fragen.

Link to post
Share on other sites

Jetzt reden wir aneinander vorbei.

Das nat?rlich nicht bezog sich lediglich auf die Debian Version.

 

Und das ist sehr wohl die Froxlor Konfig unter Squeeze.

Hier nochmal die gesamte /etc/dovecot/dovecot.conf:

 

protocols = imap pop3 imaps pop3s

listen = *

mail_access_groups = vmail

mail_debug = no

## allow Plaintext Logins from foreign IP if the Connection doesn't use TLS

disable_plaintext_auth = no

 

### SSL Settings

### After setting this options, set disable_plaintext_auth to yes (see above)

### and add imaps pop3s to the protocols

#ssl_cert_file = /etc/ssl/server/server1.webservice-pilz.de.pem

#ssl_key_file = /etc/ssl/server/server1.webservice-pilz.de.key

## This is an example with CACerts class3 cert!

#ssl_ca_file = /path/to/cacert.class3.crt

#ssl_cipher_list = ALL:!LOW:!SSLv2

 

protocol imap {

mail_plugins = quota imap_quota

}

 

protocol pop3 {

# leave this uncommented if you are migrating from Courier also see Migration from Courier

pop3_uidl_format = UID%u-%v

mail_plugins = quota

 

}

protocol lda {

# postmaster is the one in charge of the mail system. MUST be set to a valid address!

postmaster_address = <postmaster-address>

auth_socket_path = /var/run/dovecot/auth-master

mail_plugins = quota

sendmail_path = /usr/sbin/sendmail

}

 

auth default {

mechanisms = plain login

passdb sql {

args = /etc/dovecot/dovecot-sql.conf

}

 

userdb prefetch {

}

 

userdb sql {

args = /etc/dovecot/dovecot-sql.conf

}

 

user = vmail

socket listen {

# Postfix uses the client socket for SMTP Auth

client {

# Assuming the default Postfix $queue_directory setting

path = /var/spool/postfix/private/auth

mode = 0660

# Assuming the default Postfix user and group

user = postfix

group = postfix

}

# Note that we're setting a master socket. SMTP AUTH for Postfix and Exim uses client sockets.

master {

path = /var/run/dovecot/auth-master

mode = 0660

user = vmail

group = vmail

}

 

}

}

plugin {

quota = maildir

}

 

 

Nur sieht das Ganze unter Wheezy ja (leider) ziemlich anders aus. Zumal jetzt auch noch neue Benutzer ins Spiel zu kommen scheinen, die es bisher jedenfalls nicht gab ...! :-(

 

Das Verzeichnis /var/lib/sendmail hat folgenden Eigent?mer/Gruppe: smmta [104]/smmsp [110]

Wenn ich Schreibrechte f?r die Gruppe hinzuf?ge, wird das Verzeichnis 'mail' angelegt und darin das Verzeichnis '.imap'.

 

Irgendwie habe ich den Eindruck, dass hier irgendetwas noch nicht ganz stimmt im Bezug darauf, wo die Mails denn nun eigentlich abgelegt werden sollen.

 

In Froxlor habe ich "ganz normal" /var/customers/mail/ und 'Maildir' stehen.

Link to post
Share on other sites

Wheezy hat komplett neue configs in Froxlor. Bitte nicht 1:1 die squeeze config ?bernehmen. Benutze bitte die von Froxlor bereit gestellten configs. sonst kann ich dir nur schwer helfen

Link to post
Share on other sites

Wheezy hat komplett neue configs in Froxlor. Bitte nicht 1:1 die squeeze config ?bernehmen. Benutze bitte die von Froxlor bereit gestellten configs. sonst kann ich dir nur schwer helfen

Ich benutze die von Froxlor bereit gestellten configs.

Und ja, weil die eben komplett anders sind als noch unter Squeeze, stehe ich ja auf dem Schlauch ...!

 

Wenn es hilft, kann ich die Configs genau in den von Froxlor angegebenen Zustand bringen.

Link to post
Share on other sites

Mein Problem ist ja u.a., dass ich das nicht im Live-Betrieb testen kann, da es sich ja um einen Umzug handelt und momentan die Mails noch auf den alten Server laufen.

 

Wenn ich f?r einen Kunden eine Adresse anlege, dann erhalte ich zwar vom System die Mail (an alternative Adresse) "E-Mail-Konto erfolgreich eingerichtet", aber das entsprechende Verzeichnis auf dem Server wird nicht angelegt.

 

Au?erdem fehlt ja in der Standard Konfiguration u.a. auch noch der Login per SSL, die Einbindung von SASL, Amavis und SpamAssassin ...!

 

Jetzt steht im mail.err Log daf?r ein anderer Fehler drin:

Nov 23 16:47:04 vs1 dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-master) failed: Permission denied (euid=2000(vmail) egid=2000(vmail) missing +r perm: /var/run/dovecot/auth-master, dir owned by 0:0 mode=0755)

 

Die Datei auth-master ist aktuell 0 B gro? und geh?rt root mit 0600!?

Link to post
Share on other sites

Nat?rlich wird kein Maildir angelegt, denn dass passiert automatisch beim Empfangen der ersten Nachricht an diese adresse. und wenn das mailsystem auf dem neuen server nicht korrekt eingerichtet ist, kann es auch keine e-mails senden.

Link to post
Share on other sites

Ja, danke. Werd' das wohl mal so machen.

 

Hat hier jemand schon mal (erfolgreich) Postfix und Dovecot mit SSL, SASL, Amavis und SpamAssassin eingerichtet?

 

Ich bin u.a. auf folgenden Hinweis gesto?en: http://der-linux-admin.de/2013/10/debian-wheezy-update-probleme-mit-dovecot/

 

Dort wird ein "nettes" Feature von Dovecot vorgestellt, welches die alte 'dovecot.conf' konvertiert.

Und nur mal zur Info, was im Anschluss an die Konvertierung an Meldungen kam:

 

doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:1: 'imaps' protocol is no longer necessary, remove it

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:1: 'pop3s' protocol is no longer necessary, remove it

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:11: ssl_cert_file has been replaced by ssl_cert = <file

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:12: ssl_key_file has been replaced by ssl_key = <file

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:14: ssl_ca_file has been replaced by ssl_ca = <file

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:35: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:37: passdb sql {} has been replaced by passdb { driver=sql }

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:41: userdb prefetch {} has been replaced by userdb { driver=prefetch }

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:44: userdb sql {} has been replaced by userdb { driver=sql }

doveconf: Warning: Obsolete setting in ./dovecot.conf_sq:48: auth_user has been replaced by service auth { user }

 

Ich frage mich, warum die Macher von Dovecot von einer "?bersichtlichen" Konfig-Datei auf das neue System mit dutzenden einzelner Dateien gewechselt haben?

Aber nun gut - wir m?ssen es halt nehmen, wie es ist.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...