Jump to content
Froxlor Forum
  • 0

Eigent?mer nach FTP Upload


StefanKittel

Question

Hallo,

 

ich habe hier einen Debian 7 Server mit Froxlor (klar) mit Apache2.

 

Am Anfang war das FCGI drauf, welches aber auf Kundenwunsch wieder deaktiviert wurde.

(Spezielle Rewriterules)

 

Nun sind hochgeladene Dateien mit dem Falschen Owner.

Grunds?tzlich ist mir das Problem bekannt und soweit auch die L?sung

 

Bevor ich jetzt rummfummel.

Ist dieses Problem mit Froxlor ohne FCGI irgendwie gel?st was durch dieses Fallback nun defekt ist?

 

Viele Gr??e

 

Stefan

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Moin,

 

ich habe "nur" den Haken bei FCGID rausgenommen und php wieder ge-enabled.

PHP-FPM ist nicht aktiviert. Das ganze System l?uft ?ber "APACHE2HANDLER".

 

Ich habe von Hand den Eigent?mer in "www-data" ge?ndert damit der Apache damit klar kommt.

 

Nat?rlich sind FTP-Upload so gar nicht m?glich oder haben den falschen Eigent?mer.

 

Was kann ich hier machen ohne alles neu installieren zu m?ssen?

 

Es geht einfach um Rewrite-Rules die mit FastCGI anders funktionieren als ohne. Egal ob FPM oder FCGI.

Ein Kundensystem funktioniert mit beiden nicht. Wir haben es ausprobiert (index? statt index, etc) und es ist auch in diversen Foren dokumentiert.

 

Ich entnehmen Deiner Aussage aber, dass es grunds?tzlich auch ohne FPM oder FCGI mit den Benutzern und Uploads funktioniert oder?

 

Viele Gr??e

Stefan

Link to comment
Share on other sites

Nur www-data als owner ist nat?rlich auch nicht korrekt, so k?nnen deine Kunden ja nicht mehr an Ihre Daten.

 

Gem?? Froxlor Struktur solltest du unter /var/customers/webs/ f?r jeden Customer einen Ordner haben. Versuche folgendes Script, um die Berechtigungen zu korrigieren (libnss muss eingerichtet sein, da die Usernames aus der froxlor Datenbank gelesen werden!):

 

(keine Garantie, das ist mal eben schnell ausm Kopf geschrieben)

cd "/var/customers/webs/"
for D in *; do
    if [ -d "${D}" ]; then
        chown -R "${D}":www-data "${D}"
    fi
done
Link to comment
Share on other sites

PS: Geht die Uhrzeit am Server falsch? Jetzt ist es bei mir 09:02

 

Quote aus dem Admin-Panel:

If you have chosen the correct timezone and the clock is an hour out, this is because of daylight savings time and your members can correct this by editing their 'Board settings' via their User Control Panel.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...