Jump to content
Froxlor Forum
  • 0

Eigene SSL Zertifikate je Domain einrichten


wwl

Question

Hallo, ich versuche in froxlor, je Domain ein eingenes SSL Zertifikat anzulegen.

Ich habe einige Domains die ein eignes Zertifikat brauchen.

Ich hab unter IPs und Ports die IP und Port 443 angelegt. Weiterunten kann ich dann auch die Pfade zu den 4 CertFiles angeben.

Diese werden dann aber auf allen Domains und Subdomains eingebunden und gelten Systemweit.

 

Kann ich das nicht pro Domain einzeln angeben, oder brauche ich dazu jeweils eine neue IP Adresse?

 

Besten Dank f?r Infos

 

Christian

Link to post
Share on other sites

13 answers to this question

Recommended Posts

Die Zertifikate die bei IP/Ports sind quasi nur "fallbacks" - damit welche definiert sind. Um Zertifikate per Domain zu definieren musst du als Kunde eingeloggt sein. Hier kannst du in der Domain-?bersicht auf das entsprechende Icon klicken, um Zertifikats-Daten angeben zu k?nnen.

Link to post
Share on other sites

Seit 0.9.29 und nein, musst du nicht separat freischalten. du brauchst lediglich eine IP/Port Kombination bei der SSL aktiviert ist und die Kunden-Domain muss diese nat?rlich zugewiesen bekommen haben. Verbessert implementiert ist das allerdings in der aktuellen 0.9.30-rc1 bzw. der bald kommenden 0.9.30 (stable)

Link to post
Share on other sites

Moin,

 

also ich verstehe nicht, wie das funktioniert...

Ich habe einen neuen Server mit Debian 7 eingerichtet und Froxlor auf 0.9.30-rc1 aktualisiert. Apache ist 2.2.22.

Einstellungen / SSL Einstellungen / Aktiviert: Ja

Dort sind die beiden Pfade "Pfad zum Zertifikat" und "Pfad zu der SSL-Schl?sseldatei" angegeben, die Dateien sind auch vorhanden.

Wenn ich f?r eine Domain oder Subdomain mit https aufrufe, funktioniert das auch, es wird aber immer das dort angegebene Zertifikat genommen.

Wenn ich nun f?r eine Domain (beim Kunden) ein SSL-Zertifikat und eine Key-Datei angebe, bewirkt das aber gar nichts, im Verzeichnis /etc/apache2/ssl wird nichts erstellt, das bleibt leer.

Was muss ich denn machen, damit das funktioniert?

 

Gru?,

 

Wolfgang

Link to post
Share on other sites

Der Domain des Kunden muss ein SSL-IP/Port zugewiesen sein. Danach kann der KUNDE in der Domain-?bersicht auf das SSL-Editor-Icon klicken und seine Zertifikate dort als Plain-Text hinterlegen.

Link to post
Share on other sites

Der Domain ist das so zugeordnet:

 

meinedomain.de  123.45.67.89:80
                            123.45.67.89:443

 

In der Domain-?bersicht des Kunden habe ich auf das Schloss geklickt und das SSL-Zertifikat und die Key-Datei per Copy & Paste eingef?gt. Die beiden optionalen Felder habe ich leer gelassen. Aber wie gesagt: Es tut sich nix...

Link to post
Share on other sites

1) Configs checken - wurden die entsprechen Webserver-SSL-Vhosts erstellt?

2) Wenn ja, was steht drin?

3) Liegen die generierten SSL-Dateien in dem von dir angegeben Customer-SSL-Pfad?

etc.etc.etc.

 

bitte etwas mehr info als nur "Es tut sich nix" - damit k?nnen wir hier kaum was anfangen und nur sehr schwer helfen.

Link to post
Share on other sites

Ok, also die SSL-Dateien waren nicht im Customer-SSL-Pfad.

Nachdem ich die dort rein kopiert habe, wurden die .key und .crt erzeugt und auch die ssl_vhost_xxx.

Die SSL-Dateien wurden dann ja automatisch wieder gel?scht.

M?ssen die generierten SSL-Dateien eigentlich einen bestimmten Namen haben?

Woher wei? Froxlor, welche Datei f?r welche Domain sein soll?

 

Oder habe ich irgendwo einen Denkfehler?

Muss ich in den Customer-SSL-Pfad nichts rein kopieren?

Weil erst danach hat Froxlor die .key und .crt erzeugt.

 

Ich bin ein wenig verwirrt...

Link to post
Share on other sites

Nein nicht reinkopieren, so funktioniert das doch nicht. Der Kunde gibt den Inhalt seiner Zertifikate doch in den Text-Feldern an, Froxlor erstellt darauf hin selbst?ndig die entsprechenden Dateien daraus.

 

Den Ordner den du als Customer-SSL-Pfad angibst, den sollte es geben. Die Inhalte darin verwaltet Froxlor allein, da musst du gar nichts machen. Du hast NICHTS mit .key oder .crt Dateien zu tun, dass ist doch eben Sinn der Sache. Du kopierst den Inhalt dieser Dateien, egal wo sie sind, in die entsprechenden Felder der Domain (als Kunde) und den Rest macht Froxlor.

 

Irgendwie verstehe ich dein Problem nicht.

 

Customer -> Domains -> SSL-Icon -> Inhalte der .key und .crt in die entsprechenden Felder kopieren -> speichern -> fertig. Den Rest macht Froxlor.

Link to post
Share on other sites

So hatte ich es mir auch gedacht und es auch gemacht, und es war eben nichts passiert. Die key und crt wurden nicht angelegt.

Ich hatte dich falsch verstanden und gedacht, ich muss die von mir erstellen ssl-Dateien dort rein kopieren, und dann hat er es komischerweise gemacht. Ich probiere es morgen noch mal mit einer anderen Domain...

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...