Jump to content
Froxlor Forum
  • 0
Matze

[solved] Apache 2.4.6 - mod_rewrite funktioniert nicht

Question

Hallo,

 

hab mal wieder ein neues Problem,

 

mein server hat auf Apache 2.4.6 geupdatet, nun funktioniert kein mod_rewirte mehr.

 

Habe aber im Froxlor schon die Apache 2.4-Funktion aktiviert

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Okay ein Fehler habe ich gefunden...

 

In den Configs fehlt "AllowOverride" aber wie bekomme ich das hin, das er es standardm??ig in allen Configs reinhaut

Share this post


Link to post
Share on other sites
  • 0

Wenn du mir sagen kannst, wo genau du meinst das es fehlt, k?nnen wir den Fehler sicherlich beheben :)

Share this post


Link to post
Share on other sites
  • 0

Wei? ja nicht, ob es nun ein Bug ist oder ein Fehler von mir, das ich was falsch gemacht habe

Share this post


Link to post
Share on other sites
  • 0

Im Normallfall w?rde man einfach in der allgemeinen config f?r die root Directory (z.B. /var/www/) die entsprechenden Direktiven setzen, damit das f?r alle kunden verf?gbar ist, denn meiner Meinung nach sollte das default aktiviert sein, wenn man apache verwendet, da Kunden davon ausgehen, dass sie .htaccess Dateien verwenden k?nnen.

Share this post


Link to post
Share on other sites
  • 0

Nein in einer Froxlor unabh?ngigen Konfigurationsdatei, oder auch direkt in der httpd.conf 

Share this post


Link to post
Share on other sites
  • 0

Ich denke wahrscheinlich schon wieder viel zu kompliziert....

 

Da ich keine httpd.conf finden kann im apache-verzeichnis, bin ich nun verwirrt...

 

Und die "default"-config w?re ja dann die 000_sonstwas.conf, blo? gilt die dann F?R ALLE

Share this post


Link to post
Share on other sites
  • 0

Das funktioniert aber nicht, oder ich bin echt gerade zu bl?d daf?r...

 

Habe in der 000_default.conf die <directory> hinzugef?gt einmal f?r /var/www und einmal f?r /var/webs

 

aber trotzdem klappt es nicht

Share this post


Link to post
Share on other sites
  • 0

zeig mal die komplette 000_default.conf und ?berpr?fe bitte, ob die auch inkludiert wird.

Share this post


Link to post
Share on other sites
  • 0

Hab evtl den Fehler gefunden, in der apache.conf waren diese directorys nochmal drinne und da war AllowOverride auf None...

 

Ich hoffe er beh?lt jetzt die einstellung

Share this post


Link to post
Share on other sites
  • 0

Damit es etwas verst?ndlicher ist:

z.B. in der apache2.conf oder der httpd.conf (abh?ngig von der Distribution) folgende Zeilen hinzuf?gen:

 

<Directory /var/customers/webs/>

    Options Indexes FollowSymLinks
    AllowOverride All
</Directory>
 
/var/customers/webs/ tauscht ihr aus mit dem in Froxlor  (0.9.34) > Einstellungen > Systemeinstellungen > Heimatverzeichnis > konfigurierten Pfad
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...