Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Matze

Umgestellt auf FCGID - 500 Internal Error

Question

Hallo,

 

ich habe auf meinen neuen Server Froxlor installiert und wollte FCGID aktivieren.

 

Bin der anleitung im froxlor befolgt und nun wo sich der apache neu gestartet hat, 

komme ich nicht mehr ins froxlor rein.

Die Log sagt folgendes

 

[Mon Oct 07 12:08:54 2013] [notice] Apache/2.2.22 (Debian) mod_fcgid/2.3.6 configured -- resuming normal operations
suexec policy violation: see suexec log for more details
[Mon Oct 07 12:08:55 2013] [warn] [client 84.182.29.136] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Mon Oct 07 12:08:55 2013] [error] [client 84.182.29.136] Premature end of script headers: index.php

Die suexec log sagt wiederum folgendes

 

[2013-10-07 12:15:25]: uid: (10003/froxlorlocal) gid: (10003/froxlorlocal) cmd: php-fcgi-starter
[2013-10-07 12:15:25]: target uid/gid (10003/10003) mismatch with directory (0/0) or program (0/0)

Bin gerade etwas verwundert, auf meinen alten l?uft es tadellos

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

Die Fehler Meldung sagt doch alles. Ein Ordner/Dateien geh?rt noch root obwohl sie froxlorlocal geh?ren sollte. Pr?fe mal die rechte von /var/www/froxlor

Share this post


Link to post
Share on other sites

Rechte scheinen ja alle zu stimmen, aber andere seiten gehen auch nicht, die in /var/www liegen :/

 

xyY1gVR.png

 

 

 

 

 

Share this post


Link to post
Share on other sites

Die Berechtigungen / owner der php-fcgi-starter stimmen auch? Den irgendwas geh?rt root was nicht root geh?ren sollte.

Share this post


Link to post
Share on other sites

Also der Starter sollte dem user geh?ren:

 

chattr -i php-fcgi-starter
chown froxlorloxal:froxlorlocal php-fcgi-starter

Share this post


Link to post
Share on other sites

error.log

[Mon Oct 07 13:44:47 2013] [warn] [client 84.182.29.136] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Mon Oct 07 13:44:47 2013] [error] [client 84.182.29.136] Premature end of script headers: index.php

suexec.log

[2013-10-07 13:44:47]: uid: (10003/froxlorlocal) gid: (10003/froxlorlocal) cmd: php-fcgi-starter
[2013-10-07 13:44:47]: target uid/gid (10003/10003) mismatch with directory (0/0) or program (10003/10003)

Share this post


Link to post
Share on other sites

Such doch bitte die entsprechende Datei bzw den Ordner der noch root geh?rt. Deine Berechtigungen stimmen nicht. Was eigentlich nicht passieren kann

Share this post


Link to post
Share on other sites

Hab jetzt den Server nochmal neu aufgesetzt (war ja eh nichts drauf, au?er froxlor)

 

nun habe ich nochmal die ganzen konfigurations-anleitungen befolgt, 

nun gibt es ein neues Problem

 

Wenn ich jetzt froxlor aufrufe, zeigt mir der apache den Code der index.php an

Share this post


Link to post
Share on other sites

Dann ist  f?r den Frolxor-Vhost nicht fcgid/fpm aktiviert worden, f?r die kunden aber schon und mod_php aber schon deaktivert.

Share this post


Link to post
Share on other sites

mod_php nochmal aktivieren, apache restart, entsprechende einstellungen in froxlor anpassen, cronjob abstupsen, fertig

Share this post


Link to post
Share on other sites

Entweder stehe ich mal wieder derma?en auf der Leitung oder es liegt am Montag

 

Ich aktiviere mod_php mit a2enmod php5

 
restarte apache
 
rufe apache auf und dann kommt folgende fehlermeldung "You have to make the file "lib/userdata.inc.php" readable for the http-process!"
 
auch wenn ich /var/www/froxlor kurzzeitig daf?r auf root:root umstelle

Share this post


Link to post
Share on other sites

Naja, f?r mod_php muss der Ordner /var/www/froxlor nat?rlich wieder dem webserver h?ren. Irgendwas machst du anscheinend nicht ganz richtig mit dem FCGID

Share this post


Link to post
Share on other sites

habe ja wieder folgendes eingegeben

 

chown -R root:root /var/www/froxlor

funktioniert trotzdem nicht,

 

habe auch die fcgi und suexec mods deaktiviert

Share this post


Link to post
Share on other sites

root != webserver, das ist meist "www-data" oder "apache", root ist NIE richtig

Share this post


Link to post
Share on other sites

×
×
  • Create New...