Jump to content
Froxlor Forum
  • 0

Umgestellt auf FCGID - 500 Internal Error


Matze

Question

Hallo,

 

ich habe auf meinen neuen Server Froxlor installiert und wollte FCGID aktivieren.

 

Bin der anleitung im froxlor befolgt und nun wo sich der apache neu gestartet hat, 

komme ich nicht mehr ins froxlor rein.

Die Log sagt folgendes

 

[Mon Oct 07 12:08:54 2013] [notice] Apache/2.2.22 (Debian) mod_fcgid/2.3.6 configured -- resuming normal operations
suexec policy violation: see suexec log for more details
[Mon Oct 07 12:08:55 2013] [warn] [client 84.182.29.136] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Mon Oct 07 12:08:55 2013] [error] [client 84.182.29.136] Premature end of script headers: index.php

Die suexec log sagt wiederum folgendes

 

[2013-10-07 12:15:25]: uid: (10003/froxlorlocal) gid: (10003/froxlorlocal) cmd: php-fcgi-starter
[2013-10-07 12:15:25]: target uid/gid (10003/10003) mismatch with directory (0/0) or program (0/0)

Bin gerade etwas verwundert, auf meinen alten l?uft es tadellos

Link to post
Share on other sites

19 answers to this question

Recommended Posts

error.log

[Mon Oct 07 13:44:47 2013] [warn] [client 84.182.29.136] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Mon Oct 07 13:44:47 2013] [error] [client 84.182.29.136] Premature end of script headers: index.php

suexec.log

[2013-10-07 13:44:47]: uid: (10003/froxlorlocal) gid: (10003/froxlorlocal) cmd: php-fcgi-starter
[2013-10-07 13:44:47]: target uid/gid (10003/10003) mismatch with directory (0/0) or program (10003/10003)

Link to post
Share on other sites

Hab jetzt den Server nochmal neu aufgesetzt (war ja eh nichts drauf, au?er froxlor)

 

nun habe ich nochmal die ganzen konfigurations-anleitungen befolgt, 

nun gibt es ein neues Problem

 

Wenn ich jetzt froxlor aufrufe, zeigt mir der apache den Code der index.php an

Link to post
Share on other sites

Entweder stehe ich mal wieder derma?en auf der Leitung oder es liegt am Montag

 

Ich aktiviere mod_php mit a2enmod php5

 
restarte apache
 
rufe apache auf und dann kommt folgende fehlermeldung "You have to make the file "lib/userdata.inc.php" readable for the http-process!"
 
auch wenn ich /var/www/froxlor kurzzeitig daf?r auf root:root umstelle
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...