Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Spacey

Problem with "Special settings for subdomains" - related to mailinglist feature

Question

Hi!

 

Got a slightly problem with the setting "Special settings for subdomains" (in german: ?bernehme Einstellungen f?r alle Subdomains) -> I can't turn this off!

 

When I un-check the box and save the settings, it's just active when I re-enter the domain settings. Turning off other checkboxes works. Unchecking this box for another domain within the same customer & froxlor install on the same server works.

 

I guess I need this to be turned off because I want to work with a mailintlist which uses the "lists.domain.de" format - "lists." is a subdomain and when this checkbox is active, I can't work with lists. - at least I had to turn off this setting for the above named other domain in addition to the wildcard-domain-checkbox-setting within the customer-settings.

 

Or other hints & tips for me?! :D

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

Please search the Forums and the bugtracker, this is intended.

 

This is a one-time setting, you edit a domain and check whether to update the subdomains too or not. And its always "on" because the default is oft course to update subdomains too

Share this post


Link to post
Share on other sites

Thanks - and yes I searched (the forum) but could not find anything. Maybe I used the wrong keywords :/

OK, but why it was possible to change the setting for another domain?! Mailinglists work now on that one.

 

For my domain (where it doesn't) the http config file for the mailinglist isn't created. :/

 

I've noticed another problem: New eMail-Adresses are not created anymore: "User unknown in virtual mailbox table"

 

doh....

Share this post


Link to post
Share on other sites

the option "Special settings for subdomains" is just for what it describes: the special-settings. If you enter special-settings (e.g. own httpd directives) it will use them for all the domains subdomains (or not if you say 'no' on an update). Nothing more...

 

And your e-mail problem is another thing, this can be anything, mostly misconfiguration, just visit us on IRC, we can help better there

Share this post


Link to post
Share on other sites

OK finally we resolved that mail-problem in the IRC: I used maildrop for implementing antispam & antivirus checks. It seems that since the last update the way mailboxes are handled & stored has changed. The path to the mailboxes. So maildelivery still worked for the old style paths but not for the new ones. So the maildroprc must be updated - but I guess it can't work with 2 paths / ways of storing the mails. So I removed maildrop completely:

 

main.cf -> #virtual_transport = maildrop

master.cf -> #maildrop  unix  -       n       n       -       -       pipe

and the second line as well.

 

Now I just need to find & implement a new way for doing antispam & antivirus.

 

For eMail-aliases & forwardings I had to re-check the mysql-virtual_alias_maps.cf file as well - the line "additional_conditions" was longer then the one in the latest froxy examples!

 

Maybe this helps other people as well...

 

Thanks to d00p & Sephi!

Share this post


Link to post
Share on other sites

It looks like that i have a similar problem.

After investigating i found in the maildroprc that the path for delivery is read by following line from the database:

 

DEFAULT=`echo " select maildir from mail_users where username = '$LOGNAME';" |mysql -u froxlor -p"xxxxxxx" froxlor -h 127.0.0.1 | grep \@`    

 

This is a configuration that was not changed since syscp. With the actual Froxlor 0.9.28.1-1, updated from debian repositorys, the path of the Mailboxes changes so that there is no longer the "@" in the table "maildir" for new entries, and therfore the query delivers an empty string.

I changed the query to the following and that workes for me.

 

DEFAULT=`echo " select maildir from mail_users where username = '$LOGNAME';" |mysql -u froxlor -p"xxxxxxx" froxlor -h 127.0.0.1 | grep \/`

 

The query without the grep delivers 2 strings. Once the string "maildir" and second the path for the Mailaccount.

I don't know much enough about mysql-querys and therefor i am not sure if my changes produces another problems in future.

Perhaps there is anybody out there who have another idea to resolve this in an better way.

Share this post


Link to post
Share on other sites

why don't you just use parts of the queries that dovecot uses...e.g. something like that:

SELECT CONCAT(homedir, maildir) AS userhome FROM mail_users WHERE (username = '$LOGNAME' OR email = '$LOGNAME')

Share this post


Link to post
Share on other sites

Sorry,I don't understand d00p. A one time settings makes no sense.

When I uncheck the checkbox it has to be unchecked!!!

 

I have the same problem. I can't uncheck the checkbox.

 

What I need is this:

frontend: (domain)

   ServerName domain.com

   ServerAlias www.domain.com

backend: (subdomain)

   ServerName admin.domain.com

shop: (subdomain)

   ServerName shop.domain.com

   ServerAlias *.domain.com

 

If I uncheck or not froxlor writes this config:

frontend: (domain)

   ServerName domain.com

   ServerAlias www.domain.com *.domain.com

backend: (subdomain)

   ServerName admin.domain.com

   ServerAlias *.admin.domain.com

shop: (subdomain)

   ServerName shop.domain.com

   ServerAlias *.shop.domain.com

 

It works only when I directly set the iswildcarddomain to 0 an recreate the config.

 

What can I do???

 

Thanks

Detlef

Share this post


Link to post
Share on other sites

Please read my posts CAREFULLY, especially #4 ...it's ONLY about the field special-settings, NOTHING MORE.

 

What you are searching for is "Wildcardcomain [yes|no]" which is an admin setting. And if you want the "shop.domain.com" domain to be the wildcarddomain, you would need to add this as a "subdomain of another domain" as admin

Share this post


Link to post
Share on other sites

Thank you for your quick answer.

 

Yes I know I must be in the admin panel.

Hmm, I thought that is the wildcard checkbox.

Where is that checkbox? I can't found it in any settings?

 

Like you see in my prior message, I set the shop.domain.com as subdomain.

And with this settings I got the written config files.

Share this post


Link to post
Share on other sites

Uh, yeah sorry, the "wildcard" setting is no admin but a customer setting

Share this post


Link to post
Share on other sites

It seems that this option isn't available for sub domains.

 

See:

 

[...]

 

And if you want the "shop.domain.com" domain to be the wildcarddomain, you would need to add this as a "subdomain of another domain" as admin

 

Add your subdomain (as an admin) as a new (top level) domain, set the option "This is a subdomain of another..". Then you should be able to set it as wildcard domain in the customer login.

Share this post


Link to post
Share on other sites

The "Wildcard [yes|no]" option is a customer option, see ArnoldB's post #13 - also it's default = on (which you want) so what is the problem now? I don't get it

Share this post


Link to post
Share on other sites

My problem is I can't see the "Create as wildcarddomain" checkbox

now it's the third time someone tells you:

 

Customer login -> [Domain] Settings -> [edit] Icon -> "Create as wildcarddomain?:" -> Uncheck

Share this post


Link to post
Share on other sites

Ah, because you added the subdomain as a "main domain" but as subdomain of another domain, which means, that the domain's parentdomain field is NOT null which then means, you won't get the setting showed because it's only allowed for "main domains" in the first meaning. Let me quickly put something together then you can test again

Share this post


Link to post
Share on other sites

EDIT: no patch needed. this works.

 

As Admin:

- add a domain for customer 1, domain.tld

- add another domain for customer 1, sub.domain.tld, but chose domain.tld for "This domain is a subdomain of another domain"

 

As Customer:

- goto Domain -> Settings

- find domain.tld and klick the edit-icon

- voila - "Create as wildcarddomain [y|n]" will be there

Share this post


Link to post
Share on other sites





×
×
  • Create New...