Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Stephen

FTP Does Not Work

Question

I cannot make FTP connections to FTP accounts set up by a user.

 

I am using pure-ftpd. Is this supposed to run stand alone or through xinetd? xinetd is listening on port 21 but I cannot find in the /etc/xinetd.d directory's configuration files what service this is for. There does not seem to be any "service ftp" configuration in any of the files there, including the froxlor file.

 

The pure-ftpd daemon is running.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Es steht in den Konfigurations-Templates:

 

/etc/default/pure-ftpd-common: STANDALONE_OR_INETD=standalone

 

Bitte einfach den Anweisungen auf der Konfigurations-Seite f?r pureFTPd folgen.

Share this post


Link to post
Share on other sites

I am able to make an FTP connection now. I made sure the firewall was not blocking:

/sbin/iptables -A INPUT -p tcp --dport 21 -j ACCEPT

I am not sure if this made the difference.

 

What finally did it was the shutdown of xinetd, use of the domain name without the ftp subdomain that I have been accustomed to at other hosting services. E. g.:

example.com

instead of:

ftp.example.com

and setting the FTP client for passive FTP.

Share this post


Link to post
Share on other sites





×
×
  • Create New...