Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'letsencrypt'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 22 results

  1. Dear Froxlor Community, I am proud to finally release the stable version of a new API based froxlor. Due to massive internal improvements and changes in the core (almost 600 commits since 0.9.40.1) users are now able to list/create/edit/delete resources and entities of froxlor via API (requires activation of api-usage in the settings and a user based API-key). The froxlor frontend itself uses the API backend too. Froxlor now uses composer to include some of its requirements like phpMailer, Logger, IdnaConvert and TwoFactorAuth libraries. All required files will be included in the official tarball so you do not need to worry about installing and using composer (only if you are using / testing the git-master, see https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-git-sources). Most important changes: froxlor now requires at least php-7.0 or newer, php-5.6 is no longer supported because of its EOL almost a year ago you can access data via API, for more information see https://api.froxlor.org/doc/. An example can be found here: https://github.com/Froxlor/Froxlor/tree/master/doc/example PHPUnit tested API backend with MySQL 5.6, 5.7 and 8 as well as MariaDB 10.3 and 10.4, see https://travis-ci.com/Froxlor/Froxlor compatibility for MySQL8 2FA (two-factor-authentication) for admins/resellers/customers (email or authenticator app) all froxlor-database tables will automatically be converted to the InnoDB engine added support for Debian 10 (buster) and Ubuntu 18.04 (bionic beaver) implemented Let's Encrypt via acme.sh - Note: all your current Let's Encrypt certificates will be removed and re-created due to another structure customizable error/access log handling for webserver (format, level, pipe-to-script, etc.) deprecated Debian 7 (wheezy) and Ubuntu 14.04 (trusty tahr) support dropped support for Ubuntu 12.04 (precise pangolin) dropped ticketsystem Changes in 0.10.1: allow/disallow API access on a per-customer base new API parameters for Admins.add(), Admins.update(), Customers.add() and Customers.update() bool $api_allowed (default: false for Customers, true for Admins) add explicit tlsv1.3 ciphersuite setting fixed wrong behaviour in Ftps.add() if customer is newly created and setting customer.ftpatdomain is true added expiration date to SSL certificates loaded via API request fixed wrong return in Certificates.get() if given domain does not have a certificate allow setting http2 flag for (sub)domains in customer view, fixes #725 Changes in 0.10.2: force Let's Encrypt ACMEv2 API, fixed #728 added default-ssl-vhost settings and optionally allow including of non-ssl default-vhost settings, fixes #727 new API parameters for Domains.add() and Domains.update() string $ssl_specialsettings bool $include_specialsettings bool $dont_use_default_ssl_ipandport_if_empty removed API parameters in Domains.add() bool $use_default_ssl_ipandport_if_empty new API parameters for IpsAndPorts.add() and IpsAndPorts.update() string $ssl_specialsettings bool $include_specialsettings string $ssl_default_vhostconf_domain bool $include_default_vhostconf_domain implemented DomainZones.listing() to return custom stored dns entries fix registration and termination date to flip between empty-value and 0000-00-00 Changes in 0.10.3: fallback to /tmp/froxlor.log if file-log is activated but no file given or not writeable; fixes #737 added tls-settings per domain for admins with change_serversettings-flag set; fixes #519 new API parameter for Domains.add() and Domains.update() bool $override_tls (default: false) array $ssl_protocols string $ssl_cipher_list string $tlsv13_cipher_list preserve downward compatibility for 0.10.1 updaters regarding specialsettings for ssl-enabled domains; fixes #739 Changes in 0.10.4: added support for CIDR/netmask in mysql-access-hosts; fixes #564 fixed invalid handling of escape-sequences in api-endpoint, fixes #746 fixed an issue with adding the default ftp user for new customer when added by admin/reseller with no ftp-resources; fixes #741 fixed nginx configuration issue with fastcgi_split_path_info option; fixes #744 Changes in 0.10.5: bugfix release due to errors in Let's Encrypt re-new check; fixes #747 Changes in 0.10.6: introducing new API parameters sql_search, sql_limit, sql_offset, sql_orderby for almost all listing() calls introducing new API method listingCount() for almost all modules to return the total number of entities available changed behavior of SubDomains.listing() to return all fields from the domain table instead of the limited ones for customers when called as admin added new API module SysLog to query froxlor logs according to permission optimized panel_admins and panel_customers table to avoid mysql/mariadb warning: Row size too large (> 8126); fixes #752 corrected update of hosting plans via interface; fixes #753 implemented API method EmailForwarders.listing(); fixes #754 fixed parameters defaults for Domains.update() parameters ssl_ipandports and add new parameter (see below); fixes #756 new API parameters for Domains.update() bool $remove_ssl_ipandport Download: 0.10.6 Note: Debian/Ubuntu packages are available as of 21th of October 2019 - Note that there are no packages for oldoldstable (jessie) anymore Attention: The auto-update feature is currently not working correctly for updaters from 0.9.x due to the archive taking a bit longer to extract and froxlor trying to redirect too soon thus leading to an internal server error. A quick reload does "fix" the problem. To avoid that please use the manual update options, see https://github.com/Froxlor/Froxlor/wiki Visit http://www.froxlor.org or join our IRC channel #froxlor on irc.freenode.net for support, help, participation or just a chat Thank you, d00p
  2. Hello I can't renew certs (or create new certs) since the 0.10 upgrade. was working fine before on 0.9 I'm basically getting the same output everytime i run this command. xander /var/www/froxlor # /usr/bin/php7.3 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Requesting/renewing Let's Encrypt certificates [information] Creating certificate for Westecheurope.eu [information] Adding SAN entry: Westecheurope.eu [information] Adding SAN entry: www.Westecheurope.eu [Mon 4 Nov 11:23:46 CET 2019] It is recommended to install socat first. [Mon 4 Nov 11:23:46 CET 2019] We use socat for standalone server if you use standalone mode. [Mon 4 Nov 11:23:46 CET 2019] If you don't use standalone mode, just ignore this warning. [information] Checking for LetsEncrypt client upgrades before renewing certificates: [Mon 4 Nov 11:23:45 CET 2019] Installing from online archive. [Mon 4 Nov 11:23:45 CET 2019] Downloading https://github.com/Neilpang/acme.sh/archive/master.tar.gz [Mon 4 Nov 11:23:46 CET 2019] Extracting master.tar.gz [Mon 4 Nov 11:23:46 CET 2019] Installing to /root/.acme.sh [Mon 4 Nov 11:23:46 CET 2019] Installed to /root/.acme.sh/acme.sh [Mon 4 Nov 11:23:46 CET 2019] Good, bash is found, so change the shebang to use bash as preferred. [Mon 4 Nov 11:23:47 CET 2019] OK [Mon 4 Nov 11:23:47 CET 2019] Install success! [Mon 4 Nov 11:23:47 CET 2019] Upgrade success! [Mon 4 Nov 11:23:47 CET 2019] Removing cron job [Mon 4 Nov 11:23:52 CET 2019] get to authz error. [Mon 4 Nov 11:23:52 CET 2019] _authorizations_map='www.westecheurope.eu,{"identifier":{"type":"dns","value":"www.westecheurope.eu"},"status":"pending","expires":"2019-11-07T18:17:12Z","challenges":[{"type":"http-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/1025077162/e3Lmew","token":"H07E0jvAJ-vnQ4jirnVIxqLeRxDwQ_VC6PQ0RAJgEvU"},{"type":"dns-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/1025077162/rs0T6w","token":"H07E0jvAJ-vnQ4jirnVIxqLeRxDwQ_VC6PQ0RAJgEvU"},{"type":"tls-alpn-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/1025077162/ZPjfSg","token":"H07E0jvAJ-vnQ4jirnVIxqLeRxDwQ_VC6PQ0RAJgEvU"}]} westecheurope.eu,{"identifier":{"type":"dns","value":"westecheurope.eu"},"status":"pending","expires":"2019-11-07T18:17:12Z","challenges":[{"type":"http-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/1025077160/hOWGhQ","token":"Bd7XDicTn8dtJBIYc9Eod2d7eOxZGba42pnnl5aCNyI"},{"type":"dns-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/1025077160/nj7_Ow","token":"Bd7XDicTn8dtJBIYc9Eod2d7eOxZGba42pnnl5aCNyI"},{"type":"tls-alpn-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/1025077160/v7Bc7A","token":"Bd7XDicTn8dtJBIYc9Eod2d7eOxZGba42pnnl5aCNyI"}]} ' [Mon 4 Nov 11:23:52 CET 2019] Please add '--debug' or '--log' to check more details. [Mon 4 Nov 11:23:52 CET 2019] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh [debug] [Mon 4 Nov 11:23:48 CET 2019] Creating domain key [Mon 4 Nov 11:23:49 CET 2019] The domain key is here: /root/.acme.sh/Westecheurope.eu/Westecheurope.eu.key [Mon 4 Nov 11:23:49 CET 2019] Multi domain='DNS:Westecheurope.eu,DNS:www.Westecheurope.eu' [Mon 4 Nov 11:23:50 CET 2019] Getting domain auth token for each domain [Mon 4 Nov 11:23:52 CET 2019] Getting webroot for domain='Westecheurope.eu' [error] Could not get Let's Encrypt certificate for Westecheurope.eu: [Mon 4 Nov 11:23:48 CET 2019] Creating domain key [Mon 4 Nov 11:23:49 CET 2019] The domain key is here: /root/.acme.sh/Westecheurope.eu/Westecheurope.eu.key [Mon 4 Nov 11:23:49 CET 2019] Multi domain='DNS:Westecheurope.eu,DNS:www.Westecheurope.eu' [Mon 4 Nov 11:23:50 CET 2019] Getting domain auth token for each domain [Mon 4 Nov 11:23:52 CET 2019] Getting webroot for domain='Westecheurope.eu' [information] No new certificates or certificates due for renewal found [notice] Checking system's last guid
  3. Dear Froxlor Commuity, finally - the first release candidate of our new API based version 0.10.0! A lot of work has gone into this, many internal changes (you might miss any frontend-changes, but be patient...) most importantly the API backend which not only is used by froxlor frontend itself but can also be uses from within your website/scripts/etc. Froxlor now uses composer to include some of its requirements like phpMailer, Logger, IdnaConvert and TwoFactorAuth libraries. Here are some of the new features besides API that found their way in: - 2FA / TwoFactor Authentication for accounts - MySQL8 compatibility - new implementation of Let's Encrypt (acme.sh) - customizable error/access log handling for webserver (format, level, pipe-to-script, etc.) - lots and lots of bugfixes and small enhancements You can see all changes on Github at https://github.com/Froxlor/Froxlor/compare/0.9.40.1...0.10.0-rc2 Download: 0.10.0-rc2Note: There will be no Debian packages for release-candidates.Visit http://www.froxlor.org or join our IRC channel #froxlor on irc.freenode.net.Thank you,d00p
  4. Hi, I have a domain equipped with a certificate from LE. The cert is valid another 2 months. Now I added a domain as an alias of the existing domain, but the certificate isn't updated to have the new domain as its SAN. How do I trigger getting a new and updated certificate? Should I delete the existing one? Thanks for helping out. Peter
  5. Guten Morgen liebe Community, ich hab schon gesucht hier, aber nicht wirklich was passendes gefunden, darum mach ich jetzt hier nochmal nen Thread auf. Ich nutz Froxlor nun erfolgreich seit über einem Jahr auf zwei Servern, es funktioniert soweit auch alles mit LetsEncrypt und den Zertifikaten. Jetzt hab ich nur folgendes Problem, bzw. ist dies möglich, da ich mehrere Kunden über Froxlor auf zwei Servern verwalte, muss ich natürlich auch E-Mails verwalten, und zwar verschlüsselt. Kann man das über Froxlor machen? Sprich, dass die Kunden ihre Emails über imap.kunde1.de & smtp.kunde1.de sowie imap.kunde2.de & smtp.kunde2.de usw. abrufen können. Momentan muss man ja bzw. so hat es mein Admin gemacht, ein Zertifikat für alle hinterlegen, welches auch nicht automatisch per Script geupdatet wird?! -> Ist das so richtig? Oder müssen alle Kunden ihre E-Mails per imap.hauptdomain.de abrufen?
  6. Hallo Froxlor Team, wäre es möglich, dass ihr im nächsten Release auch die fullchain.pem von Let's Encrypt abspeichert? Somit könnte man diese auch ohne die Chainfiles direkt in Programme wie dovecot und postfix einbinden. Soweit ich weiß erlaubt dovecot sogar ausschließlich fullchains Vielen Dank
  7. [Dieses Problem hat sich gelöst, ich hab mich doch tatsächlich verlesen, im Einsatz ist nur die .de, die .com ist nur eine Weiterleitung, klar funktioniert die nicht] ______________________________________________________________________________ Dann habe ich noch ein weiteres Problem und zwar habe ich eine neue Subdomain angelegt, beim versuch ein SSL Zertifikat zu ziehen kommen nun nur die folgenden Fehlermeldungen: [Lets Encrypt self-check] Please check http://www.mail.hoerth.eu/.well-known/acme-challenge/_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI - token seems to be not available. This is just a simple self-check, it might be wrong but consider using this information when Let's Encrypt fails to issue a certificate Could not get Let's Encrypt certificate for mail.hoerth.eu: Verification ended with error: {"identifier":{"type":"dns","value":"www.mail.hoerth.eu"},"status":"invalid","expires":"2018-06-15T12:01:38Z","challenges":[{"type":"dns-01","status":"invalid","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/SXa_3IeDJd19Xg3oVtLd0iaj3H2lKBN_fzM1cZPtguc\/5014287643","token":"mOYe0nDwOyTxrfZc83fmpBVeL1vZesbZrV-t_nkRdZ0"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:dns","detail":"DNS problem: NXDOMAIN looking up A for www.mail.hoerth.eu","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/SXa_3IeDJd19Xg3oVtLd0iaj3H2lKBN_fzM1cZPtguc\/5014287644","token":"_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI","keyAuthorization":"_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI.JriXbK73HFGeqTSIPL3Qg0VCDy2Qt0n4wrUZon9dCEM","validationRecord":[{"url":"http:\/\/www.mail.hoerth.eu\/.well-known\/acme-challenge\/_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI","hostname":"www.mail.hoerth.eu","port":"80"}]}],"combinations":[[0],[1]]} Ich habe dann mal nachgesehen und der Token existiert defintiv nicht - klar findet ihn Lets Encrypt also nicht, was ist denn gerade bei mir Los?
  8. Hello everybody, I try to configure a letsencrypt certificate for one of my domains https://jukusoft.com , certificates are already generated by froxlor, but i get this error, if i browse the domain with firefox: SSL_ERROR_RX_RECORD_TOO_LONG If i search with google there are many threads about this topic, but there isn't any solution for this. Also there is no good tutorial on froxlor sites. Because i dont know if this is a bug or only a issue about a not-existent documentation, i havent created a issue on github yet. I also doesnt get any results by your forum search. If this is the wrong forum, please move my topic to the right! thanks! If i try to execute "openssl s_client -showcerts -connect jukusoft.com:443 -servername jukusoft.com" i get this output: CONNECTED(00000003) 140505437533840:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:782: --- no peer certificate available --- No client certificate CA names sent --- SSL handshake has read 7 bytes and written 310 bytes --- New, (NONE), Cipher is (NONE) Secure Renegotiation IS NOT supported Compression: NONE Expansion: NONE SSL-Session: Protocol : TLSv1.2 Cipher : 0000 Session-ID: Session-ID-ctx: Master-Key: Key-Arg : None PSK identity: None PSK identity hint: None SRP username: None Start Time: 1521806504 Timeout : 300 (sec) Verify return code: 0 (ok) --- I have also configured IP / Port settings: Domain Settings: Where is the problem? And please, can you write a good tutorial / documentation for SSL & letsencrypt configuration for froxlor?
  9. Hallo, ich hab mal ein kleines Problem wo ich die Gemeinde hier um Hilfe bitten möchte. ich möchte meine letsencrypt zertifikate auch so einstellen können, dass das Zertifikat auch für webseiten mit portangaben funktioniert. zum Beispiel "Serverip:10000" oder "Serverip:8108" könnt ihr mir da helfen ?? würde mich freuen.
  10. Hi, I wonder if there is anyone who able to properly set up Let's Encrypt feature with nginx? I followed suggested steps but I couldn't make it happen. - activate Let's Encrypt in the settings - as admin, goto Configuration -> select your distro -> select Webserver -> select your software - copy'n'paste the acme.conf part of the configration template - restart/reload webserver Then I run the cron php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid But, when I try to enable Let's Encrypt for a domain, the system automatically uncheck this option after I save. Any idea? Thanks
  11. Hallo, gibt es eine Möglichkeit ein LE-Zertifikat vor dem Ablaufdatum zu erneuern? Hintergrund ist, dass bei einem bereits ausgestellten Zertifikat für eine Domain der SAN für www.domain.tld hinzugefügt werden soll und ich nicht auf das Zertifikatsablaufdatum warten kann. Und bei einer Site mit bestehender http2https-Redirection das Cert löschen, um es neu generieren zu lassen, würde ja mindestens 2 Konfigzyklen ohne SSL bedeuten... viele Grüße Frank
  12. Hallo, ich habe einen Froxor-Server, der sich hinter einer Firewall befindet und mit privaten IPs installiert ist. Die Firewall leitet die Anfragen per NAT auf den Server weiter. Ohne SSL hat bisher alles sauber funktioniert. Die Lets-Encrypt funktion bekomme ich nicht ohne Workaround zum laufen. Die DNS-Auflösung weist auf den öffentiche IP der Firwall. Die Firwall kann allerdings den connect von innen auf die öffentlche NAT-IP nicht anständig behandelt so dass die Überprüfung des Challenge-Files nicht funktioniert. Mein Workaround ist daher, dass ich die Hostnamen der Lets-Encrypt Domains mit der privaten IP-Adresse in die /etc/hosts eintrage. Damit läuft der curl-Aufruf für die Validierung direkt auf die private IP und alles klappt. Das ist natürlich Fehleranfällig. Gibt es eine Möglichkeit, den Self-Check des Challenge-Files abzuschalten? Den Versuch, den Betreiber dieser sch... Firewall in die Pflicht zu nehmen, musste ich leider als gescheitert erklären. Angeblich geht das mit der Firewall nicht... Der Vollständigkeit halber... Der Check von den Lets-Encrypt Server funktioniert sauber, da der ja von extern auf die NAT-IP geht. viele Grüße Frank Nachtrag: Version: Git cf4f15a83c4769347ee3175c6a5d1dc399df89dc (19.12.17)
  13. Einen wunderschönen guten Abend, Ich habe ein kleines Problem mit Subdomains auf meinem Webserver. Ich habe für diesen Froxlor mit LetsEncrypt eingestellt und bereits RainLoop als Webmailer eingerichtet. Das hat wunderbar funktioniert über meinedomain.de/webmailordner. Nun wollte ich allerdings eine Subdomain anlegen (webmail.meinedomain.de) das will aber nicht funktionieren. Die Subdomain bekommt korrekt ein SSL Zertifikat zugewiesen, allerdings wird die in dem Verzeichnis liegende PHP Datei nicht ausgeführt sondern einfach nur der Inhalt angezeigt. Somit ist das Aufrufen des Webmailers nicht möglich. Rufe ich den Webmailer wieder über "meinedomain.de/webmailordner" auf funktioniert alles ganz normal. Ebenfalls wollte ich das Verzeichnis von meinedomain.de ändern, sobald ich das allerdings mache bekomme ich nur noch den Fehler 403 forbidden unter der Domain. Sobald ich den Pfad wieder in den Kundenroot ändere funktioniert es wieder. Allerdings sollen auf den Server doch diverse Domains für verschiedene Dienste umgezogen werden und die aktuelle Domain ist nur für einen Dienst gedacht soll also auf einen Unterordner verweisen, wo ist hier das Problem? Vielen Dank für eure Hilfe! In den angehängten Screenshot ist die Konfiguration in Froxlor zu sehen, falls noch etwas benötigt wird reiche ich das natürlich sofort nach.
  14. Hallo Froxlor Team, gibt es eine möglichkeit den froxlor beizubringen das wenn man mehr als 5 oder 10 subdomains mit Let'sEncrypt machen will , er dann automatisch die Hauptdomain z.b. domainA.de als SAN macht ? sprich das er nicht einzeln alle subdomains als Zertifikat erstellt sondern die subdomains in die SAN mit einbindet ... also das z.b. daraus dann wird domainA.de www.domainA.de sub1.domainA.de sub2.domainA.de usw. und als einziges Zertifikat macht. oder hab ich da ne einstellung übersehen ? Gruss Starwing
  15. Hallo, ich habe das Forum schon rauf und runter gelesen, bin aber die Tage nicht weiter gekommen. Ich bekomme im Log Fehlermeldungen das die Zertifikate nicht verlängert werden können. Noch einem Beitrag hier habe ich dann das cronjob Script per Hand aufgerufen "/var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug" und folgende Debug Ausgabe bekommen. Eine test-Datei habe ich auch schon probiert unter "/var/www/froxlor/.well-known/acme-challenge/" abzulegen, und dann mit der Domain aufzurufen. Das klappt ohne Probleme. Und es ist auch egal ob es sich um eine Hauptdomain oder Subdomain handelt. Der Server läuft übrigens unter Debian Jessie und mittlerweile sind alle letsencrypt Zertifikate leider abgelaufen. Wo müsste ich denn noch suchen? - - - - - [information] Updating wiresx2web.dg3fbl.de [information] Adding SAN entry: wiresx2web.dg3fbl.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Using existing account key [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for wiresx2web.dg3fbl.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for wiresx2web.dg3fbl.de [information] letsencrypt Token for wiresx2web.dg3fbl.de saved at /var/www/froxlor/.well-known/acme-challenge/1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI and should be available at http://wiresx2web.dg3fbl.de/.well-known/acme-challenge/1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI [error] letsencrypt Please check http://wiresx2web.dg3fbl.de/.well-known/acme-challenge/1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/wiresx2web.dg3fbl.de\/.well-known\/acme-challenge\/1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI): failed to open stream: HTTP request failed! HTTP\/1.0 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/iKFoWJ2IxpzgAhe1kOtD6XS0PjKLSCNdhHFGMBA5XdE/2331751669 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for wiresx2web.dg3fbl.de: Verification ended with error: {"identifier":{"type":"dns","value":"wiresx2web.dg3fbl.de"},"status":"invalid","expires":"2017-11-04T19:53:22Z","challenges":[{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/iKFoWJ2IxpzgAhe1kOtD6XS0PjKLSCNdhHFGMBA5XdE\/2331751667","token":"b3CwxBVqZPluzQZheZWT1GSeY1wT0HdRI9nXkQzYX64"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/wiresx2web.dg3fbl.de\/.well-known\/acme-challenge\/1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI: \"<!DOCTYPE HTML PUBLIC \"-\/\/IETF\/\/DTD HTML 2.0\/\/EN\">\n<html><head>\n<title>404 Not Found<\/title>\n<\/head><body>\n<h1>Not Found<\/h1>\n<p\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/iKFoWJ2IxpzgAhe1kOtD6XS0PjKLSCNdhHFGMBA5XdE\/2331751669","token":"1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI","keyAuthorization":"1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI.JRnlJHkwZsm4-XcnRPBe87rrBQZ3Mzxtj0kr5nYulZY","validationRecord":[{"url":"http:\/\/wiresx2web.dg3fbl.de\/.well-known\/acme-challenge\/1Xksj2yT56ttOocBj0dk3GbL2elts4G2zRmTFsIZFyI","hostname":"wiresx2web.dg3fbl.de","port":"80","addressesResolved":["87.140.45.66"],"addressUsed":"87.140.45.66","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/iKFoWJ2IxpzgAhe1kOtD6XS0PjKLSCNdhHFGMBA5XdE\/2331751671","token":"CrMPSD4NBVcerPeQ77kCN5pBAdh64JiiUh_jADGzO9c"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid
  16. Hallo, ich hatte das Probleme, dass die lets encrpyt Zertifikate ausgelaufen waren und nicht automatisch erneuert wurden. Läuft das überhaupt über den Cronjob oder muss man das manuell anstoßen? So sieht aktuell mein Crontab für froxlor aus: # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null
  17. Servus zusammen, Wir nutzen seit langem Froxlor als Kundenpanel und sind sehr happy damit! Wir haben damals relativ zeitnah auf die Version 0.9.36 upgedated (sind noch immer auf dieser Version!) um Let's Encrypt auf einigen Domains nutzen zu können. Nun haben wir aber auch Kunden, die ihre eigenen Custom SSL Zertifikate nutzen wollen. Leider kann ich aber das gelbe Lock Symbol bei den Domains nirgendwo mehr finden! Ich hab nun ewig herumgesucht und finde es nicht mehr wo man die "Zertifikat Strings" einfügen konnte ... das gelbe Lock Symbol ist wie gesagt einfach weg!! Was mache ich falsch? Muss ich Lets Encrypt wieder deaktivieren weil diese beiden SSL Lösungen nicht koexistieren können (wüsste aber nicht den Grund warum dem so wäre). Muss ich updaten? Bin ich blind? Hoffe ihr könnte helfen, ich bzw. der Kunde brauchen dieses Feature! Besten Dank im Voraus, mfg Patrick
  18. Hi, ich hab Eure tolle LetsEncrypt Funktion getestet und find sie echt mega gelungen. Erleichtert einem wirklich die Arbeit und gibt einem Zeit für wichtigeres :-) Jetzt ist da nur eine kleine Sache die noch nicht so rund läuft. Ich weiß nicht, ob das an einer Setting liegt oder bis dato noch nicht möglich ist aber eben schon in der GUI steht. Wenn ich eine Subdomain anlege und da LetsEncrypt nutzen möchte, vergibt er mit kein Zertifikat. Bei den Main-Domains gabs da keine Probleme. Müsste da dann ja auch so gehen - oder? Danke schon vorab für Info oder Hilfe?
  19. Hallo Froxlor Gemeinde, ich versuche gerade auf unserem Server Seiten via letsencrypt zu verschlüsseln. Mit den Froxlor eigenen Tools hatte ich leider keinen Erfolg. Das kann an unserem Setup liegen oder an meiner Unfähigkeit (Achtung Serveradmin-Noob!). (Der Fehler den ich bekomme ist folgender) Could not get Let's Encrypt certificate for mysite.com: Please check http://mysite/.well-known/acme-challenge/YI6nQJMglYzLJoOf-2u_MRZMivqlD5w29wovISnRJpA - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/mysite\/.well-known\/acme-challenge\/YI6nQJMglYzLJoOf-2u_MRZMivqlD5w29wovISnRJpA): failed to open stream: HTTP request failed! HTTP\/1.1 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":171} Wenn jemand dafür eine Lösung hat immer her damit. Was jedoch funktioniert hat ist direkt mit dem letsencrypt Kommandozeilen Tool ein Zertifikat zu erstellen. Nun habe ich das Problem, dass letsencrypt die ssl_vhost_xx.conf angepasst hat. Diese wird von froxlor jedoch bei einer Änderung an der Domain neu generiert. Meine Fragen: Wo sollte ich die Einstellungen der Domain anpassen, damit sich froxlor und letsencrypt nicht in die Quere kommen? (Geschätz unter "Eigene vHost-Einstellungen:" der Domain) Welchen Teil aus der .conf muss ich übernehmen? Welcher Teil der .conf verändert sich bei einem erneuern des Zertifikats durch letsencrypt? Vielen Dank vorab Fabian
  20. Hallo, ich habe Letsencrypt erfolgreich zum Laufen gebracht, allerdings bekomme von den Google Webmaster Tools die Rückmeldung, dass der www Alias nicht Teil des Zertifikats ist, sondern nur die Domain selbst. In Froxlor habe ich bei der Domain auf www Alias gestellt. Ist das derzeit noch ein Bug oder mache ich etwas falsch?
  21. Leider bekomme ich immer eine Fehlermeldung im Cronjob, wenn ich ein Zertifikat mit Let's Encrypt erstellen möchte. In Chrome erhalte ich bei Aufruf der Domain: ERR_SSL_PROTOCOL_ERROR Meine Configuration in Froxlor sieht wie folgt aus:
  22. Guten Morgen zusammen, ich habe erfolgreich die 0.9.35 am laufen (0.9.35-rc1 (DB: 201603150)) und die lets encrypt - Unterstützung funktioniert nach einigen anfänglichen Schwierigkeiten ganz hervorragend. Es gibt aber eine Domain, bei der die Beantragung des Zertifikats fehlschlagt. Im Systemlog erscheint folgende Meldung: Could not get Let's Encrypt certificate for rh-its.de: No challenges received for *.rh-its.de. Whole response: {"type":"urn:acme:error:malformed","detail":"Error creating new authz :: Invalid character in DNS name","status":400} In den Domain-Einstellungen steht ServerAlias auf "www". Warum versucht Froxlor, die Domain mit dem Wildcard-* bei letsencrypt einzureichen und was kann ich dagegen tun? Vielen Dank für eure Hilfe!
×
×
  • Create New...