Jump to content
Froxlor Forum

Search the Community

Showing results for tags 'letsencrypt'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Froxlor
    • Announcements
    • Feedback
    • Development
    • Bugs and Feature Requests
    • Trashcan
  • Support
    • General Discussion
  • Other Languages
    • German / Deutsch

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 23 results

  1. Hi, I'm just wondering what the difference is between the following 2 folders: Why is froxlor installing acme.sh cron everytime it runs at 3am everyday especially since the 5-min let's encrypt froxlor cron is already in place? Also, all my db config points to /etc/ssl/froxlor-custom for the domains and all keys/certificates inside that folder have a different md5 from the ones under /root/.acme.sh/, so I'm wondering what's with the mismatch? Are we updating certificates for domains twice? If anyone can shed some more light on this, it will be very much appreciated.
  2. Dear Froxlor Community, I am proud to finally release the stable version of a new API based froxlor. Due to massive internal improvements and changes in the core (almost 600 commits since 0.9.40.1) users are now able to list/create/edit/delete resources and entities of froxlor via API (requires activation of api-usage in the settings and a user based API-key). The froxlor frontend itself uses the API backend too. Froxlor now uses composer to include some of its requirements like phpMailer, Logger, IdnaConvert and TwoFactorAuth libraries. All required files will be included in the off
  3. Hello I can't renew certs (or create new certs) since the 0.10 upgrade. was working fine before on 0.9 I'm basically getting the same output everytime i run this command. xander /var/www/froxlor # /usr/bin/php7.3 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Requesting/renewing Let's Encrypt certificates [information] Creating certificate for Westecheurope.eu [information] Adding SAN entry: Westecheurope.eu [information] Adding SAN entry: www.Westecheurope.eu [Mon 4 Nov 11:23:46 CET 2019] It is recommended to install socat first.
  4. Dear Froxlor Commuity, finally - the first release candidate of our new API based version 0.10.0! A lot of work has gone into this, many internal changes (you might miss any frontend-changes, but be patient...) most importantly the API backend which not only is used by froxlor frontend itself but can also be uses from within your website/scripts/etc. Froxlor now uses composer to include some of its requirements like phpMailer, Logger, IdnaConvert and TwoFactorAuth libraries. Here are some of the new features besides API that found their way in: - 2FA / TwoFactor Authentic
  5. Hi, I have a domain equipped with a certificate from LE. The cert is valid another 2 months. Now I added a domain as an alias of the existing domain, but the certificate isn't updated to have the new domain as its SAN. How do I trigger getting a new and updated certificate? Should I delete the existing one? Thanks for helping out. Peter
  6. Guten Morgen liebe Community, ich hab schon gesucht hier, aber nicht wirklich was passendes gefunden, darum mach ich jetzt hier nochmal nen Thread auf. Ich nutz Froxlor nun erfolgreich seit über einem Jahr auf zwei Servern, es funktioniert soweit auch alles mit LetsEncrypt und den Zertifikaten. Jetzt hab ich nur folgendes Problem, bzw. ist dies möglich, da ich mehrere Kunden über Froxlor auf zwei Servern verwalte, muss ich natürlich auch E-Mails verwalten, und zwar verschlüsselt. Kann man das über Froxlor machen? Sprich, dass die Kunden ihre Emails über imap.kunde1.de & smtp
  7. Hallo Froxlor Team, wäre es möglich, dass ihr im nächsten Release auch die fullchain.pem von Let's Encrypt abspeichert? Somit könnte man diese auch ohne die Chainfiles direkt in Programme wie dovecot und postfix einbinden. Soweit ich weiß erlaubt dovecot sogar ausschließlich fullchains Vielen Dank
  8. [Dieses Problem hat sich gelöst, ich hab mich doch tatsächlich verlesen, im Einsatz ist nur die .de, die .com ist nur eine Weiterleitung, klar funktioniert die nicht] ______________________________________________________________________________ Dann habe ich noch ein weiteres Problem und zwar habe ich eine neue Subdomain angelegt, beim versuch ein SSL Zertifikat zu ziehen kommen nun nur die folgenden Fehlermeldungen: [Lets Encrypt self-check] Please check http://www.mail.hoerth.eu/.well-known/acme-challenge/_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI - token seems
  9. Hello everybody, I try to configure a letsencrypt certificate for one of my domains https://jukusoft.com , certificates are already generated by froxlor, but i get this error, if i browse the domain with firefox: SSL_ERROR_RX_RECORD_TOO_LONG If i search with google there are many threads about this topic, but there isn't any solution for this. Also there is no good tutorial on froxlor sites. Because i dont know if this is a bug or only a issue about a not-existent documentation, i havent created a issue on github yet. I also doesnt get any results by your
  10. Hallo, ich hab mal ein kleines Problem wo ich die Gemeinde hier um Hilfe bitten möchte. ich möchte meine letsencrypt zertifikate auch so einstellen können, dass das Zertifikat auch für webseiten mit portangaben funktioniert. zum Beispiel "Serverip:10000" oder "Serverip:8108" könnt ihr mir da helfen ?? würde mich freuen.
  11. Hi, I wonder if there is anyone who able to properly set up Let's Encrypt feature with nginx? I followed suggested steps but I couldn't make it happen. - activate Let's Encrypt in the settings - as admin, goto Configuration -> select your distro -> select Webserver -> select your software - copy'n'paste the acme.conf part of the configration template - restart/reload webserver Then I run the cron php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Let's Encrypt ce
  12. Hallo, gibt es eine Möglichkeit ein LE-Zertifikat vor dem Ablaufdatum zu erneuern? Hintergrund ist, dass bei einem bereits ausgestellten Zertifikat für eine Domain der SAN für www.domain.tld hinzugefügt werden soll und ich nicht auf das Zertifikatsablaufdatum warten kann. Und bei einer Site mit bestehender http2https-Redirection das Cert löschen, um es neu generieren zu lassen, würde ja mindestens 2 Konfigzyklen ohne SSL bedeuten... viele Grüße Frank
  13. Hallo, ich habe einen Froxor-Server, der sich hinter einer Firewall befindet und mit privaten IPs installiert ist. Die Firewall leitet die Anfragen per NAT auf den Server weiter. Ohne SSL hat bisher alles sauber funktioniert. Die Lets-Encrypt funktion bekomme ich nicht ohne Workaround zum laufen. Die DNS-Auflösung weist auf den öffentiche IP der Firwall. Die Firwall kann allerdings den connect von innen auf die öffentlche NAT-IP nicht anständig behandelt so dass die Überprüfung des Challenge-Files nicht funktioniert. Mein Workaround ist daher, dass ich die Hostnamen der Lets-Enc
  14. Einen wunderschönen guten Abend, Ich habe ein kleines Problem mit Subdomains auf meinem Webserver. Ich habe für diesen Froxlor mit LetsEncrypt eingestellt und bereits RainLoop als Webmailer eingerichtet. Das hat wunderbar funktioniert über meinedomain.de/webmailordner. Nun wollte ich allerdings eine Subdomain anlegen (webmail.meinedomain.de) das will aber nicht funktionieren. Die Subdomain bekommt korrekt ein SSL Zertifikat zugewiesen, allerdings wird die in dem Verzeichnis liegende PHP Datei nicht ausgeführt sondern einfach nur der Inhalt angezeigt. Somit ist das Aufrufen des
  15. Hallo Froxlor Team, gibt es eine möglichkeit den froxlor beizubringen das wenn man mehr als 5 oder 10 subdomains mit Let'sEncrypt machen will , er dann automatisch die Hauptdomain z.b. domainA.de als SAN macht ? sprich das er nicht einzeln alle subdomains als Zertifikat erstellt sondern die subdomains in die SAN mit einbindet ... also das z.b. daraus dann wird domainA.de www.domainA.de sub1.domainA.de sub2.domainA.de usw. und als einziges Zertifikat macht. oder hab ich da ne einstellung übersehen ? Gruss Starwing
  16. Hallo, ich habe das Forum schon rauf und runter gelesen, bin aber die Tage nicht weiter gekommen. Ich bekomme im Log Fehlermeldungen das die Zertifikate nicht verlängert werden können. Noch einem Beitrag hier habe ich dann das cronjob Script per Hand aufgerufen "/var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug" und folgende Debug Ausgabe bekommen. Eine test-Datei habe ich auch schon probiert unter "/var/www/froxlor/.well-known/acme-challenge/" abzulegen, und dann mit der Domain aufzurufen. Das klappt ohne Probleme. Und es ist auch egal ob es sich um eine Haup
  17. Hallo, ich hatte das Probleme, dass die lets encrpyt Zertifikate ausgelaufen waren und nicht automatisch erneuert wurden. Läuft das überhaupt über den Cronjob oder muss man das manuell anstoßen? So sieht aktuell mein Crontab für froxlor aus: # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 */6 * * *
  18. Servus zusammen, Wir nutzen seit langem Froxlor als Kundenpanel und sind sehr happy damit! Wir haben damals relativ zeitnah auf die Version 0.9.36 upgedated (sind noch immer auf dieser Version!) um Let's Encrypt auf einigen Domains nutzen zu können. Nun haben wir aber auch Kunden, die ihre eigenen Custom SSL Zertifikate nutzen wollen. Leider kann ich aber das gelbe Lock Symbol bei den Domains nirgendwo mehr finden! Ich hab nun ewig herumgesucht und finde es nicht mehr wo man die "Zertifikat Strings" einfügen konnte ... das gelbe Lock Symbol ist wie gesagt einfach weg!! Was m
  19. Hi, ich hab Eure tolle LetsEncrypt Funktion getestet und find sie echt mega gelungen. Erleichtert einem wirklich die Arbeit und gibt einem Zeit für wichtigeres :-) Jetzt ist da nur eine kleine Sache die noch nicht so rund läuft. Ich weiß nicht, ob das an einer Setting liegt oder bis dato noch nicht möglich ist aber eben schon in der GUI steht. Wenn ich eine Subdomain anlege und da LetsEncrypt nutzen möchte, vergibt er mit kein Zertifikat. Bei den Main-Domains gabs da keine Probleme. Müsste da dann ja auch so gehen - oder? Danke schon vorab für Info oder Hilfe?
  20. Hallo Froxlor Gemeinde, ich versuche gerade auf unserem Server Seiten via letsencrypt zu verschlüsseln. Mit den Froxlor eigenen Tools hatte ich leider keinen Erfolg. Das kann an unserem Setup liegen oder an meiner Unfähigkeit (Achtung Serveradmin-Noob!). (Der Fehler den ich bekomme ist folgender) Could not get Let's Encrypt certificate for mysite.com: Please check http://mysite/.well-known/acme-challenge/YI6nQJMglYzLJoOf-2u_MRZMivqlD5w29wovISnRJpA - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/mysite\/.well-known\/acme-challenge\/YI6nQJMglYzLJoOf-2
  21. Hallo, ich habe Letsencrypt erfolgreich zum Laufen gebracht, allerdings bekomme von den Google Webmaster Tools die Rückmeldung, dass der www Alias nicht Teil des Zertifikats ist, sondern nur die Domain selbst. In Froxlor habe ich bei der Domain auf www Alias gestellt. Ist das derzeit noch ein Bug oder mache ich etwas falsch?
  22. Leider bekomme ich immer eine Fehlermeldung im Cronjob, wenn ich ein Zertifikat mit Let's Encrypt erstellen möchte. In Chrome erhalte ich bei Aufruf der Domain: ERR_SSL_PROTOCOL_ERROR Meine Configuration in Froxlor sieht wie folgt aus:
  23. Guten Morgen zusammen, ich habe erfolgreich die 0.9.35 am laufen (0.9.35-rc1 (DB: 201603150)) und die lets encrypt - Unterstützung funktioniert nach einigen anfänglichen Schwierigkeiten ganz hervorragend. Es gibt aber eine Domain, bei der die Beantragung des Zertifikats fehlschlagt. Im Systemlog erscheint folgende Meldung: Could not get Let's Encrypt certificate for rh-its.de: No challenges received for *.rh-its.de. Whole response: {"type":"urn:acme:error:malformed","detail":"Error creating new authz :: Invalid character in DNS name","status":400} In den Domain-Einstellungen steh
×
×
  • Create New...