Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
cisum

404, vHosts

Question

Moin, erstmal ein Lob f?r die Arbeit!

 

Ich habe allerdings ein kleines Problem:

Ich habe einen Kunden und eine Domain angelegt und kann seitdem nicht mehr auf das Verzeichnis froxlor zugreifen. (IP-Adresse/froxlor)

Ich bekomme dann immer einen 404-Fehler.

 

Auf die angelegte Domain kann ich zugreifen und bekomme

 

* This domain was created using Froxlor.

* There is no content on this domain yet.

 

 

Wenn ich meinen Apache neustarte bekomme ich folgende Meldung:

Restarting web server: apache2[Thu Apr 01 19:21:07 2010] [warn] VirtualHost IPADDRESSE:80 overlaps with VirtualHost IPADDRESSE:80, the first has precedence, perhaps you need a NameVirtualHost directive

... waiting [Thu Apr 01 19:21:08 2010] [warn] VirtualHost IPADDRESSE:80 overlaps with VirtualHost IPADDRESSE:80, the first has precedence, perhaps you need a NameVirtualHost directive

 

W?rd mich ?ber Hilfe freuen! :)

 

Gru?,

cisum

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

Hi,

 

die NameVirtualHost Directive wird bei mir von Froxlor automatisch erstellt.

 

Schau mal im Admin-CP unter Server => IPs und Ports und dort bei deiner StandardIP, ob "Erstelle NameVirtualHost-Eintrag: " auf Ja steht.

 

Gru?

 

Daniel

Share this post


Link to post
Share on other sites

Dann manuell in der Datenbank ?ndern.

 

Verbindung mit der Datenbank herstellen (in der Shell):

# mysql -u froxlor -p[deinfroxlorpassword] froxlor

 

Dann Tabelle `panel_ipsandports` aktualisieren:

mysql> UPDATE `panel_ipsandports` SET `namevirtualhost_statement` = '1' WHERE `id` = '1';

 

Jetzt noch dem Cronjob sagen, dass er die Konfigurationen neu schreiben soll beim n?chsten Lauf:

mysql> INSERT INTO `panel_tasks` SET `type` = '1';

 

Und schlie?elich die Datenbankverbindung wieder schlie?en

mysql> \q

Share this post


Link to post
Share on other sites

Vielen Dank!

Ich bekomme nun keine Warnung mehr, wenn ich den Apache neustarte, allerdings bekomme ich noch immer den 404-Fehler, wenn ich auf froxlor zugreifen m?chte.

Vielleicht eine Idee?

Share this post


Link to post
Share on other sites

Zeigt denn der standard-vhost von apache auf deine froxlor installation? oder hast du einen eigenen vhost daf?r angelegt? Oder l?sst du einene durch Froxlor anlegen (IPs and Ports => vHost-Container)?

Share this post


Link to post
Share on other sites

Zeigt denn der standard-vhost von apache auf deine froxlor installation? oder hast du einen eigenen vhost daf?r angelegt? Oder l?sst du einene durch Froxlor anlegen (IPs and Ports => vHost-Container)?

 

Der Standard vHost zeigt auf eine Defaultseite von Froxlor.

Selbst habe ich keinen vHost angelegt.

 

Wo finde ich die von froxlor angelegten vHosts?

 

 

Edit:

Der Standard vHost zeigt auf den von mir angelegten Kunden/Domain.

Wo kann ich das wie ?ndern?

Share this post


Link to post
Share on other sites

Der Standard vHost zeigt auf den von mir angelegten Kunden/Domain.

 

Na das kann ja nicht sein, dann hast du was falsch gemacht.

 

Aktualisiere die Datenbank mal mit folgendem:

mysql> UPDATE `panel_ipsandports` SET `vhostcontainer` = '1', `vhostcontainer_servername_statement` = '1' WHERE `id` = '1';

 

Dann wie weiter oben beschrieben den Aktualisierungs-Task einf?gen:

mysql> INSERT INTO `panel_tasks` SET `type` = '1';

 

Dann Cronjob laufen lassen und schauen ob du dann an Froxlor wieder drankommst.

 

d00p

Share this post


Link to post
Share on other sites

Dann Cronjob laufen lassen und schauen ob du dann an Froxlor wieder drankommst.

 

HAllo zusammen,

 

mich plagt seit heute mittag das gleiche Problem. Bei mir hat auch das keine ?nderung gebracht. :(

 

Gr??e

Dominique

Share this post


Link to post
Share on other sites

Ihr habt sicher Debian. Macht mal statt einem "apache restart" ein "apache stop" und dann erst wieder "apache start", wirkt bei Debian manchmal wunder

Share this post


Link to post
Share on other sites

Ihr habt sicher Debian. Macht mal statt einem "apache restart" ein "apache stop" und dann erst wieder "apache start", wirkt bei Debian manchmal wunder

 

Debian habe ich... gehen tut es trotzdem leider nicht...

Share this post


Link to post
Share on other sites

Hast du denn auch die oben genannten Einstellungen in panel_ipsandports gemacht und den Cronjob danach laufen lassen?

Share this post


Link to post
Share on other sites

bitte configs mal nopasten, sonst wirds schwer

 

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
	Options FollowSymLinks
	AllowOverride None
</Directory>
<Directory /var/www/>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
	Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

   Alias /doc/ "/usr/share/doc/"
   <Directory "/usr/share/doc/">
       Options Indexes MultiViews FollowSymLinks
       AllowOverride None
       Order deny,allow
       Deny from all
       Allow from 127.0.0.0/255.0.0.0 ::1/128
   </Directory>

</VirtualHost>

 

# 05_froxlor_dirfix_nofcgid.conf
# Created 02.04.2010 23:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# 05_froxlor_dirfix_nofcgid.conf
# Created 02.04.2010 23:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

 <Directory "/var/customers/webs/">
   Order allow,deny
   allow from all
 </Directory>

 

# 10_froxlor_ipandport_88.198.50.195.80.conf
# Created 02.04.2010 23:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

NameVirtualHost x.x.x.x:80
<VirtualHost x.x.x.x:80>
ServerName static.x-x-x-x.clients.your-server.de
</VirtualHost>

 

# 20_froxlor_normal_vhost_dominique-ronde.de.conf
# Created 02.04.2010 23:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 2 - CustomerID: 1 - CustomerLogin: dronde
<VirtualHost x.x.x.x:80>
 ServerName tld.de
 ServerAlias www.tld.de
 ServerAdmin ronde@hitdorf.com
 DocumentRoot "/var/customers/webs/123/"
 php_admin_value open_basedir "/var/customers/webs/123/:/tmp/"
 php_admin_flag safe_mode Off 
 Alias /webalizer "/var/customers/webs/123/webalizer/tld.de"
 ErrorLog "/var/customers/logs/xxxxxx.de-error.log"
 CustomLog "/var/customers/logs/xxxxxx.de-access.log" combined
</VirtualHost>

 


Share this post


Link to post
Share on other sites

Das ist aber nicht alles. Poste mal die Ausgabe von

apache2 -S

Das zeigt alle Vhosts an die dem Webserver bekannt sind.

Share this post


Link to post
Share on other sites

Wenn ich bei meinem default vHost:

<VirtualHost *:80>
       ServerAdmin webmaster@localhost

       DocumentRoot /var/www/
       <Directory />
               Options FollowSymLinks
               AllowOverride None
       </Directory>
       <Directory /var/www/>
               Options Indexes FollowSymLinks MultiViews
               AllowOverride None
               Order allow,deny
               allow from all
       </Directory>

       ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
       <Directory "/usr/lib/cgi-bin">
               AllowOverride None
               Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
               Order allow,deny
               Allow from all
       </Directory>

       ErrorLog /var/log/apache2/error.log

       # Possible values include: debug, info, notice, warn, error, crit,
       # alert, emerg.
       LogLevel warn

       CustomLog /var/log/apache2/access.log combined

   Alias /doc/ "/usr/share/doc/"
   <Directory "/usr/share/doc/">
       Options Indexes MultiViews FollowSymLinks
       AllowOverride None
       Order deny,allow
       Deny from all
       Allow from 127.0.0.0/255.0.0.0 ::1/128
   </Directory>

in der ersten Zeile statt dem * die Server-IP eintrage, funktioniert es, ich bekomme dann beim Apachestart jedoch folgende Meldung:

[warn] NameVirtualHost *:80 has no VirtualHosts

Somit kann dies glaube ich auch nicht die perfekte L?sung sein, oder?

Share this post


Link to post
Share on other sites

Naja, doch das ist schon richtig, nur hast du irgendwo in der config noch ein NameVirtualHost *:80 was er halt nichtmehr braucht und deswegen eine Warning ausgibt

Share this post


Link to post
Share on other sites

Jo, in der ports.conf.

Habs auskommentiert und jetzt l?uft alles rund. - Bis auf proftpd der meckert wegen irgendwelchen locales, aber das bekomm ich schon hin. :)

 

 

Vielen Dank!

Share this post


Link to post
Share on other sites

×
×
  • Create New...