Jump to content
Froxlor Forum
  • 0

[solved] Php socket files not being created


trazx

Question

Hi,

 

Thought I should open a seperate topic for this. Froxlor is working fine except that it is not creating certain files. My configuration is nginx/php5-fpm--when froxlor creates the vhost files it fails to create the following file: /var/run/nginx/blahblah.com-php-fpm.socket

 

In the viritul host file this is the entry:

 

fastcgi_pass unix:/var/run/nginx/blahblah.com-php-fpm.socket

 

to get php to work for that viritual host I have to manually edit it to 127.0.0.1:port to get it to work...

 

I am wondering what can be done so that froxlor can actually create the socket files. I've checked the permissions of /var/run/nginx/ and it is www-data which is fine right?

 

Thanks alot

Link to post
Share on other sites

2 answers to this question

Recommended Posts

please post a full virtual-host and best would be a screenshot of your webserver- and fpm-settings (Froxlor panel).

 

Also, what permission does /var/run/nginx have? on my test-box it's 750

Link to post
Share on other sites

please post a full virtual-host and best would be a screenshot of your webserver- and fpm-settings (Froxlor panel).

 

Also, what permission does /var/run/nginx have? on my test-box it's 750

opps I didn't realize this topic is till open :( sorry I had managed to fix the issue but have no idea how that happened, it was something to do with the permissions. Sorry for anyone who was waiting for an answer :( my bad.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...