Jump to content
Froxlor Forum
  • 0

how can I get Correct PowerDNS records for domain?


ulas

Question

I created a domain with froxlor but it does not create soa record and MX records properly.

 

How can I fix that to add each domain to its MX and SOA records.

 

In addition this, I wonder that how can I add default domain NS records?

 

Do I need to install powerdns admin?

or is there any patch?

 

I am working on Freebsd

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

I created a domain with froxlor but it does not create soa record and MX records properly.

 

What does your zone-file look like?

 

In addition this, I wonder that how can I add default domain NS records?

 

It's in the settings...

 

Do I need to install powerdns admin?

or is there any patch?

 

No, and no

Link to comment
Share on other sites

Instructions of settings have wrong information.

 

Then please tell us what exactly is wrong, and what the correct way is.

 

cron job seems does not work and can I ask froxlor master is enough for cron job?

 

recheck that you have configured the crond correctly, that the pathes are correct and that you have restarted crond after the configuration.

And yes, calling froxlor_master_cronjob.php is the only file that needs to be called.

 

finally, why syscp instructions removed from demo installation:(

 

What 'syscp instructions'?

Link to comment
Share on other sites

For example


allow-axfr-ips=<SLAVE DNS SERVER>
allow-recursion=127.0.0.1
daemon=yes
guardian=yes
launch=bind
lazy-recursion=yes
recursor=<IP DNSRECURSION>
master=yes
bind-config=/etc/namedb/froxlor_bind.conf
bind-check-interval=180

 

touch /etc/bind/froxlor_bind.conf
chown root:0 /etc/bind/froxlor_bind.conf
chmod 0600 /etc/bind/froxlor_bind.conf

 

 

do you see the directory name of froxlor_bind.conf is wrong?

 

In addition this, cronjob registration command also has wrong directory name for freebsd. maybe it is correct for debian but it is wrong for freebsd 8.1

Link to comment
Share on other sites

do you see the directory name of froxlor_bind.conf is wrong?

 

Well than change the "Bind configuration directory" in the settings!?

 

In addition this, cronjob registration command also has wrong directory name for freebsd. maybe it is correct for debian but it is wrong for freebsd 8.1

 

Please, don't just say "this is wrong and this is wrong"...please SHOW us where the mistake is because i don't know what you mean.

Link to comment
Share on other sites

echo "*/1 * * * *     root     /usr/local/bin/php -q /var/customers/froxlor/scripts/froxlor_master_cronjob.php" >> /etc/crontab

 

this commands come on froxlor settings and its path also wrong. generally, freebsd setups apache on /usr/local/www/apache22/data.

 

In this case we should be careful.

 

echo "*/1 * * * *     root     /usr/local/bin/php -q /usr/local/www/apache22/data/froxlor/scripts/froxlor_master_cronjob.php" >> /etc/crontab

 

it is correct for general. if froxlor get its path from apache and print it in setting page php.

it would be good to not get confused:)

 

 

sorry , If I get you confused you.

Link to comment
Share on other sites

/var/customers/froxlor/scripts/froxlor_master_cronjob.php

 

THIS path is automatically detected by Froxlor (it knows where it's installed)...so you installed Froxlor to /var/customers/froxlor (which is wrong anyways) and that's why it shows '/var/customers/froxlor/scripts/froxlor_master_cronjob.php' as path

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...